Page 1 of 2 12 LastLast
Results 1 to 15 of 20

Thread: New RSV owner but 😥

  1. #1
    apriliaforum newb
    Join Date
    Sep 2019
    Location
    UK
    Posts
    13

    New RSV owner but 😥

    Hi People

    I've just joined the group today as I have just purchased My first Mille, it's a Gen 1, yr 2000 with low mileage and only 2 previous owners before Me.

    I rode the bike home from a private purchase "not far" the fuel light was on !

    Anyways over the weekend I done some basic maintenance checks etc before filling up with fuel. This is where things turned bad!

    Somebody at the garage pointed out that my bike is pissing out fuel everywhere from the overflow pipe near middle of exhaust.

    It just wouldn't stop! Ummm some what embarrassing, after dumping a few litres of fuel on the forcourt it finally stopped. Ok I was really confused about the situation but managed to have a short ride, it started pissing out again but finally stopped for good although I can smell fuel on my drive now but no signs of spillage.

    So either the internal fuel pipes have come away from their attachment during my very very brief ride home " not likely imo " or the pipes are split etc and the previous owner new about it and thought He'd blag it, "More than likely imo"

    So I'm pretty hacked off that someone would do that to a fellow biker, potentially turning me into a human fireball 😮

    I will pull the tank off as soon as I can, and I have read the various posts about this being a common problem on the steel tanks etc.

    I'm hoping somebody will be able to give me a list of items required to carry out the repair myself ?

    I understand I need submersible pipe but how long ? And inner diameter ?
    If the original clips are no good will any metal hose clip be ok to use ?

    Also something about having to purchase a new gasket ? Is this essential ? If so is it a main dealer only item ?

    Any advice and help would be most appreciated.

    Regards Buc

  2. #2
    apriliaforum expert JMH's Avatar
    Join Date
    Dec 2012
    Location
    Paimio, Finland
    Posts
    2,090
    Very straightforward. I don’t use oetiker clamps but these:




    https://www.apriliaforum.com/forums/...tenance-item-!

    but then I’m anal about using the correct Loctite (when any similar sealant would do)
    Mille Aarrr -02 (1060 BB, Gen2 heads, 2-2 Akra, timed cams, bespoke Gabro chip + TSS slipper) & KTM 625 SXC -05
    My riding lines are like Hendrix's solos. Unexpected and always different.

  3. #3
    apriliaforum expert redratbike's Avatar
    Join Date
    Oct 2009
    Location
    with my modded collectors,Kent,UK
    Posts
    3,060
    Call Griff and the boys at AP workshops (formally Aprilia performance )

    he’ll sell you a kit of pipes and clamps

    tel:01827 20285500

    Tell him redratbike sent you

    https://www.apworkshops.co.uk/
    please get in touch if you would like a modded collector,adjustable lock-stops or quick release tank and seat pins

  4. #4
    apriliaforum newb
    Join Date
    Sep 2019
    Location
    UK
    Posts
    13
    Thank you for help and advice.

  5. #5
    apriliaforum expert
    Join Date
    Apr 2010
    Location
    california
    Posts
    1,025
    Quote Originally Posted by JMH View Post
    Very straightforward. I donít use oetiker clamps
    any particular reason why?

    -doc

  6. #6
    apriliaforum expert JMH's Avatar
    Join Date
    Dec 2012
    Location
    Paimio, Finland
    Posts
    2,090
    ^
    don’t have the tool

    and with ”very straightforward” I meant the process of changing the hoses regardless of the clamp type used
    Last edited by JMH; 09-11-2019 at 12:51 PM.
    Mille Aarrr -02 (1060 BB, Gen2 heads, 2-2 Akra, timed cams, bespoke Gabro chip + TSS slipper) & KTM 625 SXC -05
    My riding lines are like Hendrix's solos. Unexpected and always different.

  7. #7
    apriliaforum newb
    Join Date
    Sep 2019
    Location
    UK
    Posts
    13
    Ok You Lovely Aprilia Experts, I have pulled the tank off and I have found that both vent pipes were not connected to the upper tank at all, just sat in the petrol loosely ��

    The reason they were not attached to the upper tank is one has broken away but both never even had a clamp on them ��

    So it appears someone has been upto mischief inside the tank before ��

    I have taken several photos of pump/tank etc, and will attemp to upload them shortly if I can. Please can somebody advise me if

    1. The u bend pipe going from pump to filter is original pipe ?

    2. Short straight pipe from filter is original pipe ?

    3. Does fuel filter look like a original Aprilia item ?

    4. Does the 2 vent pipes that go inside tank look like original pipes ?

    Any correct info will be gratefully appreciated.

    I will attempt to upload some pics now.

  8. #8
    apriliaforum newb
    Join Date
    Sep 2019
    Location
    UK
    Posts
    13
    Click image for larger version. 

Name:	IMG_20190912_182146304.jpg 
Views:	6 
Size:	92.5 KB 
ID:	388335Click image for larger version. 

Name:	IMG_20190912_182255161.jpg 
Views:	6 
Size:	92.0 KB 
ID:	388336Click image for larger version. 

Name:	IMG_20190912_182406087.jpg 
Views:	6 
Size:	96.0 KB 
ID:	388337Click image for larger version. 

Name:	IMG_20190912_182515021.jpg 
Views:	6 
Size:	84.4 KB 
ID:	388338Click image for larger version. 

Name:	IMG_20190912_183936232.jpg 
Views:	6 
Size:	98.9 KB 
ID:	388339Click image for larger version. 

Name:	IMG_20190912_182205542.jpg 
Views:	6 
Size:	91.1 KB 
ID:	388340

  9. #9
    apriliaforum newb
    Join Date
    Sep 2019
    Location
    UK
    Posts
    13
    Click image for larger version. 

Name:	IMG_20190912_182554217.jpg 
Views:	6 
Size:	98.5 KB 
ID:	388341Click image for larger version. 

Name:	IMG_20190912_182558653.jpg 
Views:	6 
Size:	99.4 KB 
ID:	388342 the heat Sheild looks like it's ok/re useable, but what about the foam type stuff attached to the bottom of the tank ? It's all very brittle and breaks up etc plus there's lots missing, will this be ok as it is or do I need to somehow get some more ?

    Regards Buc

  10. #10
    apriliaforum newb
    Join Date
    Sep 2019
    Location
    UK
    Posts
    13
    Ok thanks, can somebody confirm that the vent hoses would/should of had from new 2 clamps to hold them on to the top of the tank ?

    Or would they have been just pushed on ?

    Thanks

  11. #11
    apriliaforum expert JMH's Avatar
    Join Date
    Dec 2012
    Location
    Paimio, Finland
    Posts
    2,090
    Don’t know but what is the harm of having clamps? After all the counter parts seem to be metal.

    You can check this from spare part pictures. Your tank is 98-00.

    Once it is open I would change all hoses and the filter.
    Mille Aarrr -02 (1060 BB, Gen2 heads, 2-2 Akra, timed cams, bespoke Gabro chip + TSS slipper) & KTM 625 SXC -05
    My riding lines are like Hendrix's solos. Unexpected and always different.

  12. #12
    apriliaforum newb
    Join Date
    Sep 2019
    Location
    UK
    Posts
    13
    Ok thanks, can somebody confirm that the vent hoses would/should of had from new 2 clamps to hold them on to the top of the tank ?

    Or would they have been just pushed on ?

    Thanks

  13. #13
    apriliaforum expert JMH's Avatar
    Join Date
    Dec 2012
    Location
    Paimio, Finland
    Posts
    2,090
    Parts picture does not actually give this one away. However, the bottom of the breather hoses have clamps so one can at least reason that so should the fuel cap part have as well.

    http://www.wendelmotorraeder.de/fuel...901101016.html
    Mille Aarrr -02 (1060 BB, Gen2 heads, 2-2 Akra, timed cams, bespoke Gabro chip + TSS slipper) & KTM 625 SXC -05
    My riding lines are like Hendrix's solos. Unexpected and always different.

  14. #14
    apriliaforum newb
    Join Date
    Sep 2019
    Location
    UK
    Posts
    13
    Alright, thanks for your help. ��

  15. #15
    apriliaforum expert TeddyG's Avatar
    Join Date
    Feb 2012
    Location
    Portland OR
    Posts
    791
    From the OEM parts lists heres a Gen 1 pump
    Attached Images Attached Images  

Page 1 of 2 12 LastLast

Similar Threads

  1. Potential New RSV Owner
    By denali in forum RSVR and RSVR Factory (2004-2009)
    Replies: 19
    Last Post: 12-20-2007, 08:17 PM
  2. New RSV owner from NZ
    By skel* in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 4
    Last Post: 11-13-2007, 03:51 AM
  3. New RSV owner, map/gas mileage questions...
    By RSVsniper in forum RSVR and RSVR Factory (2004-2009)
    Replies: 4
    Last Post: 09-10-2007, 01:16 PM
  4. New RSV owner !!
    By rsvsharpy in forum RSVR and RSVR Factory (2004-2009)
    Replies: 14
    Last Post: 12-01-2004, 11:56 AM
  5. New RSV owner / member
    By PAC 762 in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 11
    Last Post: 07-19-2003, 10:02 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •