Results 1 to 5 of 5

Thread: Well dang that was dumb

  1. #1
    apriliaforum newb
    Join Date
    Jan 2018
    Location
    Colorado Springs, CO
    Posts
    14

    Well dang that was dumb

    I was working on my T today and managed to break a bolt off. Its the bolt that holds (held) my steering damper to the frame. I thought it was loose... Yeah, I should have checked the torque settings. I tried tightening it. Made a couple small turns and snapped it.

    Ive got a buddy with a right angle drill and some bolt extractors coming over tomorrow. I feel dumb and just wanted to vent a minute.

  2. #2
    apriliaforum prov-nov
    Join Date
    May 2011
    Location
    Latimer, MS
    Posts
    85
    Definitely an annoyance, but it could have been worse; you could have stripped the threads in the frame! I definitely get a lot of use out of my two torque wrenches when I do anything on my Tuono.
    Mike Rodriguez

  3. #3
    apriliaforum expert johnnyjellybean's Avatar
    Join Date
    Sep 2017
    Location
    Laurentian mountains, Quebec
    Posts
    638
    Quote Originally Posted by Buck Rogers View Post
    Definitely an annoyance, but it could have been worse; you could have stripped the threads in the frame! I definitely get a lot of use out of my two torque wrenches when I do anything on my Tuono.
    That probably would be an easier fix.... tap.... helicoil .... better than new!

  4. #4
    apriliaforum newb
    Join Date
    Jan 2018
    Location
    Colorado Springs, CO
    Posts
    14
    Quote Originally Posted by johnnyjellybean View Post
    That probably would be an easier fix.... tap.... helicoil .... better than new!
    this is the route that I decided on. Much easier. The easy out... well there's nothing easy about them.

    On Another note, I just ordered a new Ohlins shock spring to help support my 205 pound ass.

  5. #5
    apriliaforum prov-nov
    Join Date
    Sep 2016
    Location
    montreal
    Posts
    58
    Quote Originally Posted by johnnyjellybean View Post
    That probably would be an easier fix.... tap.... helicoil .... better than new!
    annoying to do upside lol

Similar Threads

  1. Well... That was a long outage...
    By Grenadiers in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 5
    Last Post: 07-03-2010, 12:39 PM
  2. headshake, well that was no fun lol
    By zc911 in forum Tuono 1000 R and Tuono Factory (2006-2010)
    Replies: 9
    Last Post: 07-07-2008, 08:22 PM
  3. Well, *that* was weird
    By Tony F in forum SL1000 Falco Forum (all years)
    Replies: 8
    Last Post: 03-13-2008, 05:22 PM
  4. Well that was a waste of a morning.
    By OreoGaborio in forum RSV Tuono, Tuono R, Tuono Racing, and Tuono Factory (2002-2005)
    Replies: 15
    Last Post: 02-04-2008, 10:14 PM
  5. Well, THAT Was Fun! - Lost Back Tire...
    By Knife in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 11
    Last Post: 05-19-2005, 11:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •