Results 1 to 7 of 7

Thread: Can someone help with a Non Starting 06 Morini SR50 Ditech with Malossi 70cc/ HGT Reg

  1. #1
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Boulder, CO
    Posts
    3

    Can someone help with a Non Starting 06 Morini SR50 Ditech with Malossi 70cc/ HGT Reg

    Hi all
    Scoot was running fine and has low miles on the 70cc kit.
    Cranks No start

    I read through the FAQs as much as I could (more technical than I'm used to)
    Seems a bit different of a process with the HGT Regulator
    Battery is fine
    Put in a brand new NGK ZMR7AP plug to start with...no effect.
    Fuel MAY be about 9 months old and is 15% Ethanol.

    Is there a walkthrough or Troubleshooting list I can follow with the mods?

    Thanks!!
    Scooty

  2. #2
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Boulder, CO
    Posts
    3
    Oh Yeah only the ECU error 23 I think but it has the Malossi ECU.

  3. #3
    apriliaforum Member Mayor McTurd's Avatar
    Join Date
    Apr 2017
    Location
    Bloomington IL
    Posts
    166
    23 is a faulty atmospheric sensor/faulty ecu. :/

    ---------------------------------------------------------------

    If you have an Aprilia scooter, come join us on Facebook!

    https://www.facebook.com/groups/695754433952451/
    ----------------------------------------------------------------
    If you have an Aprilia scooter, come join us!

    https://www.facebook.com/groups/695754433952451/

  4. #4
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Boulder, CO
    Posts
    3
    Quote Originally Posted by Scooty McScoot View Post
    Oh Yeah only the ECU error 23 I think but it has the Malossi ECU.
    Thanks Mayor McTurd...

    The Service light was always on when it was running perfectly last year. I was told that was the Malossi Aftermarket ECU that comes with the 70cc Big Bore Kit.
    But now it doesn't start.
    Would the ERROR 23 be on with the Malossi ECU?

    Thx
    Last edited by Scooty McScoot; 08-13-2019 at 10:40 PM. Reason: wrong quote...

  5. #5
    apriliaforum Member Mayor McTurd's Avatar
    Join Date
    Apr 2017
    Location
    Bloomington IL
    Posts
    166
    Oh yeah, I forgot about that. That's the reason I used the malossi piggyback ecu instead, so I wouldn't have the service light.

    Start with the basic stuff first. Is your fuel pump working? Can you hear it priming when you turn the key on?

    Is there fuel on the new plug?

    Are you getting spark?

    ---------------------------------------------------------------

    If you have an Aprilia scooter, come join us on Facebook!

    https://www.facebook.com/groups/695754433952451/
    ----------------------------------------------------------------
    If you have an Aprilia scooter, come join us!

    https://www.facebook.com/groups/695754433952451/

  6. #6
    apriliaforum Member rank1's Avatar
    Join Date
    Mar 2019
    Location
    Hungary
    Posts
    152
    Unplug the ecu and reset tps,ecu.It should be starting again.If not maybe ecu damaged?I have piaggio, thank god.About fuel pump,dont get confused about that bzzz prime sound.U need to listen carefully,u should hear a heavy bzzz sound.Let it prime 2-3 x then crank the engine.Take off air filter and add a little break cleaner of starter fluid then crank the engine.Let us know whats going on.

  7. #7
    apriliaforum Junkie lenko223's Avatar
    Join Date
    Oct 2009
    Location
    Zemun, Serbia, EU
    Posts
    293
    Test the fuel pump so you can see if it is correct and if it gives a sound ... too many worn out brushes of electric motors in the pump give a sound but not enough pressure ... in 70% of cases, failures come from the pump ...
    APRILIA SR 50 DiTech Morini 2003;
    ECU De-Restricted,
    Champion RG6YC
    Leo-Vince ZX De-Restricted pipe,
    Stage 6 strong (red)springs,
    polini 5,5gr rollers,
    Malossi Red contra spring
    Vario: Polini
    Air box Malossi red sponge
    top Speed 110 kmh
    side foot - Buzzeti
    15W blue bulb
    a higher degree of reparation of fuel pumps

Similar Threads

  1. please can someone help with tail light wiring????
    By jpgibson in forum 2006-2011 Aprilia RXV, SXV, MXV 4.5/5.5 V-Twins
    Replies: 9
    Last Post: 06-08-2008, 07:17 AM
  2. can someone help me
    By Dveloped in forum RS250
    Replies: 1
    Last Post: 01-31-2004, 09:18 PM
  3. Can someone help me post!!!!
    By rs50crazii in forum RS50 Technical
    Replies: 1
    Last Post: 01-31-2004, 11:41 AM
  4. Can you help with electrical problem on '95 Peg?
    By microbike in forum Pegaso 650 Cube and IE
    Replies: 1
    Last Post: 04-04-2002, 04:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •