Results 1 to 2 of 2

Thread: 2003 Atlantic 500

  1. #1
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Pennsylvania
    Posts
    6

    EFI light not on, won't start. 2003 Atlantic 500

    I have a 2003 Aprilia Atlantic 500 that won't start. It's been sitting in the garage for the past 5 or 6 years. I would charge the battery and run it once a year just to fire it up. This year I put the battery in and it will not start. When I go to start it the engine via the electric start, it will not crank. Seems to be an electrical issue to me. The EFI light does not come on when the key is turned to start. Could be the problem? Need help on troubleshooting the problem. Thanks.
    Last edited by Muskyhunter509; 08-13-2019 at 11:15 AM.

  2. #2
    apriliaforum newb
    Join Date
    Apr 2017
    Location
    Chelyabinsk, Russia
    Posts
    4
    Look at fuses. Clean their contacts.

Similar Threads

  1. 2003 Atlantic 500 Stalling
    By Lyon44 in forum Aprilia and Piaggio 500cc
    Replies: 17
    Last Post: 09-03-2014, 11:58 PM
  2. Buy 2003 Atlantic 500?
    By scootinjuju in forum Aprilia and Piaggio 500cc
    Replies: 9
    Last Post: 08-29-2007, 07:46 AM
  3. 2003 Atlantic 500 for Sale in Texas
    By bmuhlenk in forum Aprilia and Piaggio 500cc
    Replies: 0
    Last Post: 09-03-2004, 10:04 AM
  4. For sale 2003 Atlantic 500
    By Porkie in forum Aprilia and Piaggio 500cc
    Replies: 3
    Last Post: 04-22-2004, 08:46 PM
  5. 2003 Atlantic 500 for sale
    By Porkie in forum Aprilia and Piaggio 500cc
    Replies: 1
    Last Post: 02-10-2004, 09:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •