Page 1 of 2 12 LastLast
Results 1 to 15 of 26

Thread: Aprilia SR50 DiTech 2001 Morini - bad idle.

  1. #1
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    11

    Aprilia SR50 DiTech 2001 Morini - bad idle. (FIXED)

    Hey!

    I recently bought myself a scooter to use to and from work..

    When I first bought it had been sitting for a while, so it sputtered a lot when giving gas with cold engine. The problem with sputtering slowly went away and i have ran few tanks of gas throughout it now, so no bad old gas left. Only minimal sputtering when giving full gas when cold.

    New spark plug, new thermostat and new oil injection line.

    Now the biggest and most annoying problem is that it idles really bad! Runs fine otherwise, good acceleration.

    https://youtu.be/vvGNdfNU3uY

    Anyone have any idea?

    Thanks in advance
    Last edited by Magneten; 08-29-2019 at 01:46 PM.

  2. #2
    apriliaforum expert Louder North's Avatar
    Join Date
    Nov 2011
    Location
    Ottawa, ON Canada
    Posts
    1,000
    Quote Originally Posted by Magneten View Post
    Hey!

    I recently bought myself a scooter to use to and from work..

    When I first bought it had been sitting for a while, so it sputtered a lot when giving gas with cold engine. The problem with sputtering slowly went away and i have ran few tanks of gas throughout it now, so no bad old gas left. Only minimal sputtering when giving full gas when cold.

    New spark plug, new thermostat and new oil injection line.

    Now the biggest and most annoying problem is that it idles really bad! Runs fine otherwise, good acceleration.

    https://youtu.be/vvGNdfNU3uY

    Anyone have any idea?

    Thanks in advance
    Doesn't sound too bad. What year is it and how many km on it? Could be any number of age related things...
    2007 SR 50 Ditech (Morini) 19,000 kms AND 2011 SR 50 Ditech (Piaggio) 2000 kms
    Buzzetti side stand 03/18/12
    Porter Cable water trap 06/19/12
    ECU completely derestricted ver 2.8.0 08/10/12)
    LV ZX-R 09/10/12 - repaired and painted 10/18/14
    Motul Scooter Power 2T oil
    NGK ZMR7AP spark plug, indexed, gapped to .030
    Malossi Multivar 2000 w. 7.5 gm Dr. Pulley sliders (13/06/15), Malossi Special Belt, White contrast spring @ 8000 km 11/12/12,
    Malossi X K belt, front brake pads @19,000 km 06/15/17
    8mm Mirror Riser Extender 05/12/2013
    Michelin Power Pure tires @ 9000 km 05/18/2013, replaced @19,000 07/19/2017
    HGT adjustable fuel pressure regulator 06/08/2013
    90 kph on slight down hill; 103 kph fastest ever going down hill

  3. #3
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    11
    Quote Originally Posted by Louder North View Post
    Doesn't sound too bad. What year is it and how many km on it? Could be any number of age related things...
    Just passed 14000km, and its a 2001


    Sent from my iPhone using Tapatalk

  4. #4
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    11
    Quote Originally Posted by Louder North View Post
    Doesn't sound too bad. What year is it and how many km on it? Could be any number of age related things...
    Just passed 14000, and its a 2001 model


    Sent from my iPhone using Tapatalk

  5. #5
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    11
    Quote Originally Posted by Louder North View Post
    Doesn't sound too bad. What year is it and how many km on it? Could be any number of age related things...
    It just passed 14,000 km, and its a 2001 model.

  6. #6
    apriliaforum Member rank1's Avatar
    Join Date
    Mar 2019
    Location
    Hungary
    Posts
    152
    Idle sound weak.Never use old fuel.Clean the airinjector also if u can buy new fuel filter or clean it.Airfilter clean?

  7. #7
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    11

    Question

    Quote Originally Posted by rank1 View Post
    Idle sound weak.Never use old fuel.Clean the airinjector also if u can buy new fuel filter or clean it.Airfilter clean?
    I don’t know if it has a fuel filter, was planning to add one.

    I have cleaned air filter thoroughly, oiled it and squeezed out the excess oil, like in my old trial days. My Gas Gas 125 had carb tho much easier to work with if you ask me.

    I have ran a few tanks of 95, and currently running 98. Shouldn’t be any bad gas left in the tank.

    What part is the airinjector?

    Thanks !

  8. #8
    apriliaforum Member rank1's Avatar
    Join Date
    Mar 2019
    Location
    Hungary
    Posts
    152
    Click image for larger version. 

Name:	DSC00397.jpg 
Views:	9 
Size:	98.5 KB 
ID:	387247
    Red is airinjector.Carefully remove that black injector house first.If the airinjector stuck,push the start button a few times until it pops out.Dont forget any o-rings.Disconnect the connector and there u go,u can start clean it with fuel or brake cleaner.U can check the condition of the sparkplug while the airinjector is out.Start a few times and check inside the hole u should see a nice strong blue sparks.If u have mechanic skills it should be easy job,if not better dont touch it.
    First try new sparkplug,clean the air filter.
    Last edited by rank1; 08-26-2019 at 04:25 PM.

  9. #9
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    11
    Quote Originally Posted by rank1 View Post
    Attachment 386251
    Red is airinjector.Carefully remove that black injector house first.If the airinjector stuck,push the start button a few times until it pops out.Dont forget any o-rings.Disconnect the connector and there u go,u can start clean it with fuel or brake cleaner.U can check the condition of the sparkplug while the airinjector is out.Start a few times and check inside the hole u should see a nice strong blue sparks.If u have mechanic skills it should be easy job,if not better dont touch it.
    First try new sparkplug,clean the air filter.
    I did today, took of the injector house, and the injector it self. Cleaned it all up with compressed air. Injector is nice with a solid beam of gasoline when tested.

    Air injector however had a few bad seals including the first white seal, and the house it sits in had a black oily liquid, I’m thinking it’s residue from combustion that is leaking in to the air injector house. Tip of air injector had a lot of carbon buildup. Cleaned it with a bronze brush and it cleaned up real nice. I replaced the seals with non original o-rings I had laying around.

    Idle is way better, but still some coughing/misses. Going to buy some brake cleaner and order original seals and do the job again!

    Injector house got new seal, and changed out bad return gas hose. Did a compression test as well, just above 8bar, 118 psi. Very nice

    And hey, thanks for the good instructions on how to do it!
    Last edited by Magneten; 08-11-2019 at 03:56 PM.

  10. #10
    apriliaforum Member rank1's Avatar
    Join Date
    Mar 2019
    Location
    Hungary
    Posts
    152
    Try to get original o-rings.i made some mistakes before to use from cars but they re different.If one ring didnt match, it will not seal properly.It can cause leaks so misfires, fouled injectors and plugs because of pressure drops.

  11. #11
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    11
    Quote Originally Posted by rank1 View Post
    Try to get original o-rings.i made some mistakes before to use from cars but they re different.If one ring didnt match, it will not seal properly.It can cause leaks so misfires, fouled injectors and plugs because of pressure drops.
    I did take injector apart again now and put in new o-rings and teflon seal (making sure to squeeze teflon seal using a 10mm hose and a hoseclamp, to make it flush with air injector body making it easier to refit in to engine) Cleaned everything, added a water trap to pressured air hose, really thought that was the problem after the white gunk I discovered in the injector house after disassembly, still bad idle, still hard to start when cold.

    Engine has a CPR8E plug, I took it out after reading about people having to regap those to 0.5mm. Well mine was 0.25mm, ridiculous!!! I regapped it to 0.5mm and slammed that baby in there again. Running beautiful ever after!

    https://youtu.be/njx4cVquwO8

    Also, removed two restrictor rings from variatior, now its doing 85kmh

  12. #12
    apriliaforum Member rank1's Avatar
    Join Date
    Mar 2019
    Location
    Hungary
    Posts
    152
    Click image for larger version. 

Name:	1212.jpg 
Views:	16 
Size:	96.2 KB 
ID:	387423
    I did replace all 8 mm hoses for 6 mm.All high pressure cuz last week the fuel hose just blow up.Mine also catch a lot of sludge.But stil has a choking issue.Eat more fuel then normal,even after pressure regulator and fuel injector got new o-rings.Cant figure it out yet.Probably pressure drop cuz at wot she just choke all the time and i cant hold throttle half open cuz around 6-7k rpm he fouling the plug sound like too much fuel injected at that area.Next week get a used compressor.We ll see.Im using now my old Cpr8eb.
    Last edited by rank1; 08-29-2019 at 05:34 PM.

  13. #13
    apriliaforum Junkie lenko223's Avatar
    Join Date
    Oct 2009
    Location
    Zemun, Serbia, EU
    Posts
    293
    The fuel pump can be the cause of many illogical failures ... check it ...
    APRILIA SR 50 DiTech Morini 2003;
    ECU De-Restricted,
    Champion RG6YC
    Leo-Vince ZX De-Restricted pipe,
    Stage 6 strong (red)springs,
    polini 5,5gr rollers,
    Malossi Red contra spring
    Vario: Polini
    Air box Malossi red sponge
    top Speed 110 kmh
    side foot - Buzzeti
    15W blue bulb
    a higher degree of reparation of fuel pumps

  14. #14
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    11

    Aprilia SR50 DiTech 2001 Morini - bad idle.

    Quote Originally Posted by rank1 View Post
    Click image for larger version. 

Name:	1212.jpg 
Views:	16 
Size:	96.2 KB 
ID:	387423
    I did replace all 8 mm hoses for 6 mm.All high pressure cuz last week the fuel hose just blow up.Mine also catch a lot of sludge.But stil has a choking issue.Eat more fuel then normal,even after pressure regulator and fuel injector got new o-rings.Cant figure it out yet.Probably pressure drop cuz at wot she just choke all the time and i cant hold throttle half open cuz around 6-7k rpm he fouling the plug sound like too much fuel injected at that area.Next week get a used compressor.We ll see.Im using now my old Cpr8eb.
    Sounds like you’re either getting too much fuel or too little fuel. I’m no mechanic but I would check pressure on compressor and fuel pump to spec.

    Quote Originally Posted by High Gain Tuning View Post
    Combined pressure should be air + fuel, not air + fuel + air.

    Static fuel pressure is around 36 psi
    Air pressure is altitude dependent but 60-70 psi is normal at idle.
    Running fuel pressure where you have the gauge should be those two combined... 96-106psi.

  15. #15
    apriliaforum Member rank1's Avatar
    Join Date
    Mar 2019
    Location
    Hungary
    Posts
    152
    Pump seems works fine.I had one older which died on me couple of monts ago.The only symptom i know about the pump is when he not make a heavy bzz sound,its over.Need to repair it.But the one i'm using now,bzz good.I dont have a " t " hose connection so cant check pressure only the compressor.when i crank the engine it hangs around 2,5 bar.Sound terrible weak.Idle sound the same as Magneten's bike when he had bad idle issues.If there isnt enough pressure then the engine get messed up mixture.About sludge,when i took off the injector without water trap i didnt saw any sludge a bit in the compressor hose.Before time i didnt had issues with malossi 70 kit but now is just not the same.I was thinking maybe take off the tc unit and use stock ecu with polini bowl but i dont like that plastic crap.I get a nice cloud spray so probably the ecu in some rpm injecting too much fuel or is it about that slop effect?When im open the throttle he just move like a rocket but after a few second he just choking then go again.Its not fun,but also wasting fuel.
    Last edited by rank1; 08-30-2019 at 06:07 AM.

Page 1 of 2 12 LastLast

Similar Threads

  1. Aprilia SR50 Ditech not starting or idling
    By Aussie_Sean in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 13
    Last Post: 05-13-2012, 09:34 AM
  2. Aprilia SR50 diTech 2002 morini engine misfire on full throttle?
    By ced950121 in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 15
    Last Post: 04-14-2012, 03:24 PM
  3. 2001 Aprilia Sr50 Ditech FS 70cc
    By Lt. Aldo Raine in forum Aprilia Motorcycles and Scooters for Sale / Wanted
    Replies: 2
    Last Post: 11-02-2010, 12:05 PM
  4. 2001 Aprilia SR50 Ditech Scooter w/485 miles 4 Sale
    By Jason Barishman in forum Aprilia Motorcycles and Scooters for Sale / Wanted
    Replies: 0
    Last Post: 06-24-2009, 12:22 PM
  5. Aprilia SR50 DITECH Derestriction Bad points?
    By jusdan in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 12
    Last Post: 05-20-2007, 08:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •