Results 1 to 9 of 9

Thread: Aprilia SR50 DiTech 2001 Morini - bad idle.

  1. #1
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    6

    Aprilia SR50 DiTech 2001 Morini - bad idle.

    Hey!

    I recently bought myself a scooter to use to and from work..

    When I first bought it had been sitting for a while, so it sputtered a lot when giving gas with cold engine. The problem with sputtering slowly went away and i have ran few tanks of gas throughout it now, so no bad old gas left. Only minimal sputtering when giving full gas when cold.

    New spark plug, new thermostat and new oil injection line.

    Now the biggest and most annoying problem is that it idles really bad! Runs fine otherwise, good acceleration.

    https://youtu.be/vvGNdfNU3uY

    Anyone have any idea?

    Thanks in advance

  2. #2
    apriliaforum expert Louder North's Avatar
    Join Date
    Nov 2011
    Location
    Ottawa, ON Canada
    Posts
    997
    Quote Originally Posted by Magneten View Post
    Hey!

    I recently bought myself a scooter to use to and from work..

    When I first bought it had been sitting for a while, so it sputtered a lot when giving gas with cold engine. The problem with sputtering slowly went away and i have ran few tanks of gas throughout it now, so no bad old gas left. Only minimal sputtering when giving full gas when cold.

    New spark plug, new thermostat and new oil injection line.

    Now the biggest and most annoying problem is that it idles really bad! Runs fine otherwise, good acceleration.

    https://youtu.be/vvGNdfNU3uY

    Anyone have any idea?

    Thanks in advance
    Doesn't sound too bad. What year is it and how many km on it? Could be any number of age related things...
    2007 SR 50 Ditech (Morini) 19,000 kms AND 2011 SR 50 Ditech (Piaggio) 2000 kms
    Buzzetti side stand 03/18/12
    Porter Cable water trap 06/19/12
    ECU completely derestricted ver 2.8.0 08/10/12)
    LV ZX-R 09/10/12 - repaired and painted 10/18/14
    Motul Scooter Power 2T oil
    NGK ZMR7AP spark plug, indexed, gapped to .030
    Malossi Multivar 2000 w. 7.5 gm Dr. Pulley sliders (13/06/15), Malossi Special Belt, White contrast spring @ 8000 km 11/12/12,
    Malossi X K belt, front brake pads @19,000 km 06/15/17
    8mm Mirror Riser Extender 05/12/2013
    Michelin Power Pure tires @ 9000 km 05/18/2013, replaced @19,000 07/19/2017
    HGT adjustable fuel pressure regulator 06/08/2013
    90 kph on slight down hill; 103 kph fastest ever going down hill

  3. #3
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    6
    Quote Originally Posted by Louder North View Post
    Doesn't sound too bad. What year is it and how many km on it? Could be any number of age related things...
    Just passed 14000km, and its a 2001


    Sent from my iPhone using Tapatalk

  4. #4
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    6
    Quote Originally Posted by Louder North View Post
    Doesn't sound too bad. What year is it and how many km on it? Could be any number of age related things...
    Just passed 14000, and its a 2001 model


    Sent from my iPhone using Tapatalk

  5. #5
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    6
    Quote Originally Posted by Louder North View Post
    Doesn't sound too bad. What year is it and how many km on it? Could be any number of age related things...
    It just passed 14,000 km, and its a 2001 model.

  6. #6
    apriliaforum Member
    Join Date
    Mar 2019
    Location
    Hungary
    Posts
    110
    Idle sound weak.Never use old fuel.Clean the airinjector also if u can buy new fuel filter or clean it.Airfilter clean?

  7. #7
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    6

    Question

    Quote Originally Posted by rank1 View Post
    Idle sound weak.Never use old fuel.Clean the airinjector also if u can buy new fuel filter or clean it.Airfilter clean?
    I don’t know if it has a fuel filter, was planning to add one.

    I have cleaned air filter thoroughly, oiled it and squeezed out the excess oil, like in my old trial days. My Gas Gas 125 had carb tho much easier to work with if you ask me.

    I have ran a few tanks of 95, and currently running 98. Shouldn’t be any bad gas left in the tank.

    What part is the airinjector?

    Thanks !

  8. #8
    apriliaforum Member
    Join Date
    Mar 2019
    Location
    Hungary
    Posts
    110
    Attachment 386251
    Red is airinjector.Carefully remove that black injector house first.If the airinjector stuck,push the start button a few times until it pops out.Dont forget any o-rings.Disconnect the connector and there u go,u can start clean it with fuel or brake cleaner.U can check the condition of the sparkplug while the airinjector is out.Start a few times and check inside the hole u should see a nice strong blue sparks.If u have mechanic skills it should be easy job,if not better dont touch it.
    First try new sparkplug,clean the air filter.
    Last edited by rank1; 08-10-2019 at 02:35 PM.

  9. #9
    apriliaforum newb
    Join Date
    Aug 2019
    Location
    Norway
    Posts
    6
    Quote Originally Posted by rank1 View Post
    Attachment 386251
    Red is airinjector.Carefully remove that black injector house first.If the airinjector stuck,push the start button a few times until it pops out.Dont forget any o-rings.Disconnect the connector and there u go,u can start clean it with fuel or brake cleaner.U can check the condition of the sparkplug while the airinjector is out.Start a few times and check inside the hole u should see a nice strong blue sparks.If u have mechanic skills it should be easy job,if not better dont touch it.
    First try new sparkplug,clean the air filter.
    I did today, took of the injector house, and the injector it self. Cleaned it all up with compressed air. Injector is nice with a solid beam of gasoline when tested.

    Air injector however had a few bad seals including the first white seal, and the house it sits in had a black oily liquid, I’m thinking it’s residue from combustion that is leaking in to the air injector house. Tip of air injector had a lot of carbon buildup. Cleaned it with a bronze brush and it cleaned up real nice. I replaced the seals with non original o-rings I had laying around.

    Idle is way better, but still some coughing/misses. Going to buy some brake cleaner and order original seals and do the job again!

    Injector house got new seal, and changed out bad return gas hose. Did a compression test as well, just above 8bar, 118 psi. Very nice

    And hey, thanks for the good instructions on how to do it!
    Last edited by Magneten; 08-11-2019 at 03:56 PM.

Similar Threads

  1. Aprilia SR50 Ditech not starting or idling
    By Aussie_Sean in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 13
    Last Post: 05-13-2012, 09:34 AM
  2. Aprilia SR50 diTech 2002 morini engine misfire on full throttle?
    By ced950121 in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 15
    Last Post: 04-14-2012, 03:24 PM
  3. 2001 Aprilia Sr50 Ditech FS 70cc
    By Lt. Aldo Raine in forum Aprilia Motorcycles and Scooters for Sale / Wanted
    Replies: 2
    Last Post: 11-02-2010, 12:05 PM
  4. 2001 Aprilia SR50 Ditech Scooter w/485 miles 4 Sale
    By Jason Barishman in forum Aprilia Motorcycles and Scooters for Sale / Wanted
    Replies: 0
    Last Post: 06-24-2009, 12:22 PM
  5. Aprilia SR50 DITECH Derestriction Bad points?
    By jusdan in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 12
    Last Post: 05-20-2007, 08:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •