Results 1 to 4 of 4

Thread: Dash reset (I think)

  1. #1
    apriliaforum newb
    Join Date
    Jul 2019
    Location
    UK
    Posts
    1

    Dash reset (I think)

    Hi All, Bought my Falco in Austria a couple of years ago and had no problems, til yesterday. Having looked through pages and pages on this forum I couldn't find an answer to my resetting problem. It may be there but no search results and over 500 pages.
    Now when I turn on instead of the tacho just swining up to the red line and back the needle clicks anticlockwise a few times first. The only apparent problem is having to keep switching from Kph to mph.
    I tried diconnecting the battery for 30 mins but no change. Does anyone know the cause and how to fix this? Thanks in anticipation.

  2. #2
    apriliaforum expert Falcopops's Avatar
    Join Date
    May 2006
    Location
    NOT Townsville Australia unfortunately
    Posts
    1,896
    seems like your dash is losing power when you switch off, the ticking tacho is it powering up again. I'd be looking for a blown fuse or broken/lose wire
    "I like to put a little silicone grease on the seals, too, to keep them looking young and fresh like a prom queen." - SoulDaddy

  3. #3
    apriliaforum expert FalcoPilot's Avatar
    Join Date
    Jun 2004
    Location
    North Georgia, U S of A....
    Posts
    6,256
    I had five dash resets on my last ride. My battery is around six years old. Twelve years ago I added a capacitor to the dash circuit board as recommended but had no effect. Seems like each time I start getting resets it's because the battery is on it's last legs. I ordered a new one last week and hopefully that will take care of it for me as it has in the past. BTW, my Falco lives on a Battery Tender, inside a garage, when not being ridden.
    2003 Aprilia Falco SL1000R
    2016 Ford F-150 XLT
    1991 Ford Mustang GT
    1968 Mustang Coupe

  4. #4
    apriliaforum expert kzmille's Avatar
    Join Date
    Jul 2003
    Location
    North Florida
    Posts
    18,734
    Dash resets are caused by low voltage. Probably a weak battery. Test it and the charging system.
    This is America. Use your turn signals or WE WILL KILL YOU - remember Sandra Bland

Similar Threads

  1. Dash Reset?
    By Taliskar in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 22
    Last Post: 11-15-2007, 11:14 PM
  2. Dash resetting common?
    By steveT in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 14
    Last Post: 03-23-2004, 10:40 AM
  3. Dash resetting again. Possible fix?
    By Smoke Eater in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 25
    Last Post: 12-30-2003, 10:01 AM
  4. Dash reset / weak battery problem (FAQ)
    By RichL025 in forum 1000cc f.a.q
    Replies: 5
    Last Post: 09-25-2003, 03:38 PM
  5. Dash reset / weak battery problem (FAQ)
    By RichL025 in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 3
    Last Post: 09-08-2003, 05:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •