Results 1 to 5 of 5

Thread: Startering problem

  1. #1
    apriliaforum newb
    Join Date
    Jul 2017
    Location
    AZ,TN,RI
    Posts
    14

    Startering problem

    Need some help from the collective...In the middle of a ride last weekend when I noticed my voltage dropping. Figured the battery gave up the ghost...installed new battery, as soon as I hook up the neg cable motor starts turning over, even without the key in the ignition. Whats the problem, a buddy suggested the rectifier..unhooked that..same deal. HELP!

    Thanx
    Last edited by Diamondhead; 06-11-2019 at 04:32 PM. Reason: Typo

  2. #2
    apriliaforum expert thesprocket26's Avatar
    Join Date
    Oct 2012
    Location
    SW Idaho, USA
    Posts
    901
    if its cranking it means your starter solenoid it welded together. time for a new one or upgrade to the Motocraft style.

    if/when you fix that, the regulator/rectifiers are known to go out and cause charging issues. there are upgrades for that as well.
    If your idea of sport-touring is multi-position seats, cruise control and electrically-adjustable windshields, you’re probably not Italian and you don’t deserve a Futura. - Kevin Duke

    2001 RST1000 Futura - GSXR coil mod, Magnecore HT leads, Honda reg/rec mod, custom built twin tail mufflers, LED high beams, LED front turn lamps, LED rear brake and turn lamps, Oxford heated grips, Oberon clutch slave, fancy blue hardware bits, air horn mod, pannier stainless cable retention mod, large Odyssey battery mod, 05 fuel map

  3. #3
    apriliaforum newb
    Join Date
    Jul 2017
    Location
    AZ,TN,RI
    Posts
    14
    Yep..it was the solenoid...never see one fail closed usually they stay open...thanx...I even had a spare

  4. #4
    apriliaforum expert Kennibear's Avatar
    Join Date
    Aug 2016
    Location
    Washington State USA
    Posts
    541
    Watch your starting voltage (you need a voltmeter on you dash) as welded solenoids tend to fry the starters. See the link about the $99 CanAm starter replacement.

    KB

    Sent from my E6833 using Tapatalk

  5. #5
    apriliaforum expert Kennibear's Avatar
    Join Date
    Aug 2016
    Location
    Washington State USA
    Posts
    541
    The underseat area on the RST1000 lends itself to the Ford solenoid upgrade covered in the sticky at the top of the forum.
    You should do it.

    KB

    Sent from my E6833 using Tapatalk

Similar Threads

  1. Starting problems - Moto 6.5
    By prymaka in forum Professional Racing Discussion
    Replies: 10
    Last Post: 04-22-2019, 01:19 PM
  2. Starting problems? No way!
    By el2frij in forum Scarabeo 50, SR50, Mojito 50, Rally, Fly 50
    Replies: 8
    Last Post: 08-10-2016, 01:33 AM
  3. RST starting problems
    By Neil in forum RST1000 Futura (all years)
    Replies: 13
    Last Post: 07-08-2003, 02:38 PM
  4. Starting Problems?
    By snwolff in forum SL1000 Falco Forum (all years)
    Replies: 8
    Last Post: 01-19-2003, 02:41 PM
  5. Starting problems
    By cbenson in forum Pegaso 650 Cube and IE
    Replies: 2
    Last Post: 07-08-2002, 10:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •