Results 1 to 3 of 3

Thread: Well... that was fun

  1. #1
    apriliaforum newb
    Join Date
    Oct 2012
    Location
    Norfolk, VA, USA
    Posts
    11

    Well... that was fun

    The paint job was getting pretty beat up.... so I decided to get the panels painted... my paint guy was a little... apprehensive to take the pieces off.... honestly it wasn't that bad... just hoping to get them all back on ok!

  2. #2
    apriliaforum newb
    Join Date
    Oct 2012
    Location
    Norfolk, VA, USA
    Posts
    11

    Attahments

    https://1drv.ms/u/s!Aqs7vKhoUNVXgrdW5hQPbUbq7HvQQw

    I couldn't figure out how to add an attachment, even using the forum help. I did not see the noted steps on the forum... I hope this link works!

    VR
    TJ

  3. #3
    apriliaforum newb
    Join Date
    May 2018
    Location
    Glendale AZ (formerly Oz, Albury NSW)
    Posts
    26
    The link just shows a naked Mana

Similar Threads

  1. Well it was fun while it lasted...
    By flyinisaac in forum RST1000 Futura (all years)
    Replies: 9
    Last Post: 07-07-2009, 10:03 PM
  2. headshake, well that was no fun lol
    By zc911 in forum Tuono 1000 R and Tuono Factory (2006-2010)
    Replies: 9
    Last Post: 07-07-2008, 08:22 PM
  3. Well, *that* was weird
    By Tony F in forum SL1000 Falco Forum (all years)
    Replies: 8
    Last Post: 03-13-2008, 05:22 PM
  4. Well that was a waste of a morning.
    By OreoGaborio in forum RSV Tuono, Tuono R, Tuono Racing, and Tuono Factory (2002-2005)
    Replies: 15
    Last Post: 02-04-2008, 10:14 PM
  5. Well, THAT Was Fun! - Lost Back Tire...
    By Knife in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 11
    Last Post: 05-19-2005, 11:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •