Results 1 to 8 of 8

Thread: Dash Frozen on Reset Service Screen

  1. #1
    apriliaforum newb
    Join Date
    Apr 2019
    Location
    Vancouver
    Posts
    8

    Dash Frozen on Reset Service Screen

    Wanted to get rid of the little wrench icon on my 09 sr 50 factory. Put in the default service code, went down to service reset. Clicked the yes button and now its frozen there. Even if I take the keys/toggle the killswitch its stuck on that screen. I can ride the bike and the tachometer will stay at 1k, screen backlight will be on with the service reset screen stuck there. Still rideable like normal.

    How do I fix this?

    Thanks.

  2. #2
    apriliaforum expert Louder North's Avatar
    Join Date
    Nov 2011
    Location
    Ottawa, ON Canada
    Posts
    988
    Try disconnecting and re-connecting the battery.
    2007 SR 50 Ditech (Morini) 19,000 kms AND 2011 SR 50 Ditech (Piaggio) 2000 kms
    Buzzetti side stand 03/18/12
    Porter Cable water trap 06/19/12
    ECU completely derestricted ver 2.8.0 08/10/12)
    LV ZX-R 09/10/12 - repaired and painted 10/18/14
    Motul Scooter Power 2T oil
    NGK ZMR7AP spark plug, indexed, gapped to .030
    Malossi Multivar 2000 w. 7.5 gm Dr. Pulley sliders (13/06/15), Malossi Special Belt, White contrast spring @ 8000 km 11/12/12,
    Malossi X K belt, front brake pads @19,000 km 06/15/17
    8mm Mirror Riser Extender 05/12/2013
    Michelin Power Pure tires @ 9000 km 05/18/2013, replaced @19,000 07/19/2017
    HGT adjustable fuel pressure regulator 06/08/2013
    90 kph on slight down hill; 103 kph fastest ever going down hill

  3. #3
    apriliaforum newb
    Join Date
    Apr 2019
    Location
    Vancouver
    Posts
    8
    Quote Originally Posted by Louder North View Post
    Try disconnecting and re-connecting the battery.
    Am completely mechanically inept, loosened the nut and dropped it into the scooter! Had to look around my basement for a replacement, found one but its painted black. Screwed that one on and my problem seems to be fixed now. Is having a painted nut like that unsafe to have against a battery terminal?

    This is could be placebo, but is it possible that I restricted the ecu again in what I did? Is there an easy way to test if the ecu is in dev mode?

  4. #4
    apriliaforum expert Louder North's Avatar
    Join Date
    Nov 2011
    Location
    Ottawa, ON Canada
    Posts
    988
    Quote Originally Posted by chr0m389 View Post
    Am completely mechanically inept, loosened the nut and dropped it into the scooter! Had to look around my basement for a replacement, found one but its painted black. Screwed that one on and my problem seems to be fixed now. Is having a painted nut like that unsafe to have against a battery terminal?

    This is could be placebo, but is it possible that I restricted the ecu again in what I did? Is there an easy way to test if the ecu is in dev mode?
    Is it unsafe? 'No' and since it is working, that problem is solved - score one for you.

    What you did had no effect on the ECU and unless the previous owner tells you otherwise, there is no easy way to detect if the ECU is in dev mode. Do you know how fast you can go with it and what RPM it is at when you do?
    2007 SR 50 Ditech (Morini) 19,000 kms AND 2011 SR 50 Ditech (Piaggio) 2000 kms
    Buzzetti side stand 03/18/12
    Porter Cable water trap 06/19/12
    ECU completely derestricted ver 2.8.0 08/10/12)
    LV ZX-R 09/10/12 - repaired and painted 10/18/14
    Motul Scooter Power 2T oil
    NGK ZMR7AP spark plug, indexed, gapped to .030
    Malossi Multivar 2000 w. 7.5 gm Dr. Pulley sliders (13/06/15), Malossi Special Belt, White contrast spring @ 8000 km 11/12/12,
    Malossi X K belt, front brake pads @19,000 km 06/15/17
    8mm Mirror Riser Extender 05/12/2013
    Michelin Power Pure tires @ 9000 km 05/18/2013, replaced @19,000 07/19/2017
    HGT adjustable fuel pressure regulator 06/08/2013
    90 kph on slight down hill; 103 kph fastest ever going down hill

  5. #5
    apriliaforum newb
    Join Date
    Apr 2019
    Location
    Vancouver
    Posts
    8
    Quote Originally Posted by Louder North View Post
    Is it unsafe? 'No' and since it is working, that problem is solved - score one for you.

    What you did had no effect on the ECU and unless the previous owner tells you otherwise, there is no easy way to detect if the ECU is in dev mode. Do you know how fast you can go with it and what RPM it is at when you do?
    I can go around 70-75 km/h on flat, the rpm stays at 8k it may go a bit over but will drop to 8. There's a big hill up to my house, usually that hill will make me drop to 50-55km/h but today I was dropped to 35km/h. The bike was derestricted with the previous owner by a piaggio authorized shop here. I did some searching and found that the there's an ecu error 15 memo. Looked on the forum here and that's something related to rev limiting? Later today I'll look at the rpm's more on my commute and post again.

    Thanks.

  6. #6
    apriliaforum newb
    Join Date
    Apr 2019
    Location
    Vancouver
    Posts
    8
    Quote Originally Posted by Louder North View Post
    Is it unsafe? 'No' and since it is working, that problem is solved - score one for you.

    What you did had no effect on the ECU and unless the previous owner tells you otherwise, there is no easy way to detect if the ECU is in dev mode. Do you know how fast you can go with it and what RPM it is at when you do?
    Just finished going up that same hill and was at my usual speeds I was before, I wonder what made it so much slower last time... But yea rpm never goes above 8.5k for the most part.

  7. #7
    apriliaforum expert Louder North's Avatar
    Join Date
    Nov 2011
    Location
    Ottawa, ON Canada
    Posts
    988
    Quote Originally Posted by chr0m389 View Post
    Just finished going up that same hill and was at my usual speeds I was before, I wonder what made it so much slower last time... But yea rpm never goes above 8.5k for the most part.
    It is likely that the ECU is still restricted.
    2007 SR 50 Ditech (Morini) 19,000 kms AND 2011 SR 50 Ditech (Piaggio) 2000 kms
    Buzzetti side stand 03/18/12
    Porter Cable water trap 06/19/12
    ECU completely derestricted ver 2.8.0 08/10/12)
    LV ZX-R 09/10/12 - repaired and painted 10/18/14
    Motul Scooter Power 2T oil
    NGK ZMR7AP spark plug, indexed, gapped to .030
    Malossi Multivar 2000 w. 7.5 gm Dr. Pulley sliders (13/06/15), Malossi Special Belt, White contrast spring @ 8000 km 11/12/12,
    Malossi X K belt, front brake pads @19,000 km 06/15/17
    8mm Mirror Riser Extender 05/12/2013
    Michelin Power Pure tires @ 9000 km 05/18/2013, replaced @19,000 07/19/2017
    HGT adjustable fuel pressure regulator 06/08/2013
    90 kph on slight down hill; 103 kph fastest ever going down hill

  8. #8
    apriliaforum newb
    Join Date
    Apr 2019
    Location
    Vancouver
    Posts
    8
    Quote Originally Posted by Louder North View Post
    It is likely that the ECU is still restricted.
    When I bought it I had a pre purchase inspection done by a dealer, they said that since it revs to over 10k rpm on the stand that it's de restricted. Is that wrong?

Similar Threads

  1. Service light on and service on dash, oops.
    By FactoryPete2016 in forum 2012-2019 Tuono V4 - All Variants
    Replies: 10
    Last Post: 08-27-2018, 12:27 PM
  2. reseting service indicator on 2001 RSVMille
    By deeeliciousblue in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 3
    Last Post: 08-14-2018, 04:58 PM
  3. 2016 Tuono RSV4 RF Service on dash question, not reset 12412..something I did wrong !
    By scotman623 in forum 2012-2019 Tuono V4 - All Variants
    Replies: 8
    Last Post: 12-21-2015, 10:38 PM
  4. Reset service light on sr50r carburetor version. How?
    By IVv in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 4
    Last Post: 05-16-2009, 11:44 PM
  5. Reset Service Icon on Mana
    By tha-mask in forum 2008-2014 Mana 850 and Mana 850 GT-ABS
    Replies: 3
    Last Post: 09-30-2008, 03:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •