Page 1 of 2 12 LastLast
Results 1 to 15 of 16

Thread: 2018 RSV4 RR 341mi. Urgent Service Alert no change in power; or engine sound

  1. #1
    apriliaforum newb
    Join Date
    Jun 2017
    Location
    Sacramento, CA
    Posts
    13

    2018 RSV4 RR 341mi. Urgent Service Alert no change in power; or engine sound

    Warm evening, riding home cruising down the highway at about 70 in 3rd gear, I get a Urgent Service Alert and the engine idiot light icon comes on. I'm babying the bike since I'm in a break-in period. No power loss, no changes in the sound of the engine. I exit freeway, take surface roads in first gear at about 30-40mph and get home fine. Turn off the bike. Alert disappears but engine idiot light remains on. I'm perplex of what the problem might be, and don't know how to obtain additional diagnostic information. Starts and runs fine. I can take it to my distant dealer but I was hoping to get a better idea of what it could be so that I can determine whether I should tow it or ride it there....

  2. #2
    apriliaforum expert pauldayona's Avatar
    Join Date
    Nov 2013
    Location
    Netherlands
    Posts
    879
    IAWdiag/ Guzzidiag can read all errors. The first aid kit you should have.

  3. #3
    apriliaforum newb
    Join Date
    Jun 2017
    Location
    Sacramento, CA
    Posts
    13

    Thank you!

    Quote Originally Posted by pauldayona View Post
    IAWdiag/ Guzzidiag can read all errors. The first aid kit you should have.
    Thanks for the reply. I'll get started collecting the components today.

  4. #4
    apriliaforum expert desmolvr's Avatar
    Join Date
    Oct 2009
    Location
    Fresno, CA
    Posts
    524
    Did you add a tail tidy or led blinkers by chance? Any changes made to the bike or completely stock.

  5. #5
    apriliaforum newb
    Join Date
    Apr 2019
    Location
    United States
    Posts
    21
    Quote Originally Posted by wobblygecko View Post
    Warm evening, riding home cruising down the highway at about 70 in 3rd gear, I get a Urgent Service Alert and the engine idiot light icon comes on. I'm babying the bike since I'm in a break-in period. No power loss, no changes in the sound of the engine. I exit freeway, take surface roads in first gear at about 30-40mph and get home fine. Turn off the bike. Alert disappears but engine idiot light remains on. I'm perplex of what the problem might be, and don't know how to obtain additional diagnostic information. Starts and runs fine. I can take it to my distant dealer but I was hoping to get a better idea of what it could be so that I can determine whether I should tow it or ride it there....
    Did you remove the exhaust valve cable?

  6. #6
    apriliaforum prov-nov wspawn's Avatar
    Join Date
    Oct 2015
    Location
    Melbourne Australia
    Posts
    70
    I suggest take it directly to your dealer if its under warranty.

  7. #7
    apriliaforum newb
    Join Date
    Jun 2017
    Location
    Sacramento, CA
    Posts
    13
    Tail tidy with original blinkers about 3 weeks ago.

  8. #8
    apriliaforum newb
    Join Date
    Jun 2017
    Location
    Sacramento, CA
    Posts
    13
    Haven't changed anything with exhaust, just sliders and an ASV brake lever. Trying to leave it stock until I get past the first service interval....

  9. #9
    apriliaforum newb
    Join Date
    Jun 2017
    Location
    Sacramento, CA
    Posts
    13
    Trying to. They are saying that it telling me that I needed to do the first oil change. I countered with "why at 314 mi. ?" They: "Are you riding it hard?" Me: "No, keeping to break-in protocols". They: "Might be something wrong, you should drive it over" Me: "Couldn't that damage the engine further?" They: "Probably not..." Me: " I have it towed over" They: "We can't pay for that" Me: "You'll reimburse me if it turns out to be a warranty problem" So I'll let you all know when I find out. Our dealership locally is not very good I'm finding... Thanks for the help!

  10. #10
    apriliaforum newb
    Join Date
    Dec 2018
    Location
    Nashville, TN
    Posts
    11
    You’re going to have your brand new bike towed? I realize you likely mean putting it on a rollback vs truly having it towed, but there is no way in hell that I’d ever voluntarily allow a tow jockey near my bike. Way too much chance he’ll fail to tie it down properly or damage a fairing/fork/other.

    Do you or a friend own a pickup that you could borrow? Worst case you can rent a motorcycle trailer from U-Haul for dirt cheap.

  11. #11
    apriliaforum newb
    Join Date
    Jun 2017
    Location
    Sacramento, CA
    Posts
    13
    Update: As for towing; my insurance covered the towing, and the guy they sent specializes in bikes showing up with this new flat-bed. So I get it to the dealer, and it sits for 2 working days. I called them on the 2nd day, and finally get an update at about 4pm. The bike needed ECU and dashboard updates. They flashed both, and I'll pick it up tomorrow. Kinda awkward way of notifying me with an "urgent" service alert.. Curious how URGENT it was... Don't know if there was anything else since I didn't get to talk to the tech (tomorrow). Thanks to all for the suggestions, and assistance. I'll update this tread with a final post once I have the bike home and diagnostics running on it. Cheers and Thank you!!

  12. #12
    Max Lean Angle / Administrator Ed / AF1 Racing's Avatar
    Join Date
    Jun 2003
    Location
    Austin, TX
    Posts
    9,652
    how long have you had your bike? part of selling them is making sure all the updates are done.

  13. #13
    apriliaforum newb
    Join Date
    Jun 2017
    Location
    Sacramento, CA
    Posts
    13
    Sorry for the delay, life problems.... Turns out the Urgent Service Alert was all about the Dash and ECU needing updates. Finally got it into the shop and a few days later I have a working motorcycle. Would have preferred an "Important Service Alert" on my display but I guess it all about context. Funny thing was that the Dealer disconnected my V4-MP (2.0) and neglected to connected back up... <sigh>. Appreciate all the assistance and hope to be able to play it forward in the future. Cheers!

  14. #14
    apriliaforum expert plocky's Avatar
    Join Date
    Oct 2015
    Location
    Tasmania
    Posts
    4,425
    Hmm! Insurance company should ask the dealer for the tow costs for being so stupid not to pre-deliver the bike properly by checking Dash & ECU for important updates.

    This is the truth.
    Quote Originally Posted by Ed / AF1 Racing View Post
    how long have you had your bike? part of selling them is making sure all the updates are done.
    2015(16) RSV4 RR Ascari Black 201HP

  15. #15
    just another Aprilia fanatic amauri's Avatar
    Join Date
    Sep 2003
    Location
    Westminster, CA - USA
    Posts
    14,898
    "URGENT SERVICE" is not caused by downlevel ECU and dashboard software.

    Did your dealer at least read the error log (before updating ECU) and note the error codes in your repair order copy?
    Never accept mediocrity, always demand competence.

    Certified Aprilia Moto Service in Southern California
    Call me at 714 892-4056 for appointment

Page 1 of 2 12 LastLast

Similar Threads

  1. 2012 aprc r factory spec trade for 2018 rsv4 rr
    By meherzad7 in forum 2010-2019 RSV4 - All Variants
    Replies: 5
    Last Post: 06-09-2018, 03:14 PM
  2. 2018 RSV4 RR and RSV4 RF Prices
    By Ed / AF1 Racing in forum 2010-2019 RSV4 - All Variants
    Replies: 1
    Last Post: 01-14-2018, 01:28 PM
  3. RSV4 jumping rpm urgent service code p0208
    By russianmeow in forum 2010-2019 RSV4 - All Variants
    Replies: 9
    Last Post: 11-17-2017, 08:11 AM
  4. Urgent service light ... no dealers near
    By ldanny in forum 2008-2016 Shiver 750 / Dorsoduro 750
    Replies: 3
    Last Post: 10-03-2017, 08:35 AM
  5. Shiver quit running. Message "urgent service" but no codes
    By Haasroad in forum 2008-2016 Shiver 750 / Dorsoduro 750
    Replies: 1
    Last Post: 07-03-2014, 03:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •