Results 1 to 6 of 6

Thread: Clutch lever not returning

  1. #1
    apriliaforum expert
    Join Date
    Aug 2015
    Location
    Dallas, TX
    Posts
    978

    Clutch lever not returning

    Wondering if you guys have had this issue as well. My clutch lever this morning wasn't returning back to original position unless i pushed it. Maybe the lever joint needs some lube... maybe my clutch springs are going bad? I'll be messing with it this weekend but I thought I'd ask. Clutch doesn't seem to be slipping even flogged in 1st gear.

    Thoughts?
    Don't be a jerk... jerk

    2016 KTM 250 xc
    2013 KTM 350 xcf ---------------SOLD
    2011 Husqvarna 630 ------------SOLD
    2007 KTM Superduke 990-------SOLD
    2009 Dorsoduro 750
    2003 KLX 400R
    2009 YZ450 -----------------------SOLD
    2007 ZZR600 ----------------------SOLD
    2006 CBR600RR ------------------SOLD
    2009 Ninja 250 -------------------SOLD

  2. #2
    apriliaforum prov-nov
    Join Date
    Jul 2017
    Location
    Canada
    Posts
    37
    I can't remember what the exact culprit was on my bike but I remember having the same issue.

    I just pushed it up by hand and then one afternoon I dropped the bike and broke my clutch lever. Got new aftermarket ones and haven't had a problem since.

    How much slack does it have?

    Sent from my LYA-L0C using Tapatalk

  3. #3
    apriliaforum expert
    Join Date
    Aug 2015
    Location
    Dallas, TX
    Posts
    978
    it has no slack really. once I push it back (probably last 15-20% of motion) the little black lever/idler which the lever pushes on returns to its full "out" position.

    Lever pushes on idler and idler pushes on reservoir rod.

    So I should drop the bike and that will fix it? lol jk
    Don't be a jerk... jerk

    2016 KTM 250 xc
    2013 KTM 350 xcf ---------------SOLD
    2011 Husqvarna 630 ------------SOLD
    2007 KTM Superduke 990-------SOLD
    2009 Dorsoduro 750
    2003 KLX 400R
    2009 YZ450 -----------------------SOLD
    2007 ZZR600 ----------------------SOLD
    2006 CBR600RR ------------------SOLD
    2009 Ninja 250 -------------------SOLD

  4. #4
    apriliaforum expert rule62's Avatar
    Join Date
    Aug 2015
    Location
    Gilbert, Arizona (USA)
    Posts
    1,267
    Just take off the lever, clean and lube the bush, bolt, and perch, and make sure it's not too tight when you put it back on. I use a little blue loctite on my lever bolts, over any undue tightening. See how that goes. Should only take about 5 mins.
    2016 Honda CBR 1000rr SP Repsol

    2014 Dorsoduro 750 ABS - sold

  5. #5
    apriliaforum prov-nov
    Join Date
    Jul 2017
    Location
    Canada
    Posts
    37
    Quote Originally Posted by RadicalTireSkid View Post

    So I should drop the bike and that will fix it? lol jk
    Lol you didn't hear it from me

    Sent from my LYA-L0C using Tapatalk

  6. #6
    apriliaforum expert
    Join Date
    Aug 2015
    Location
    Dallas, TX
    Posts
    978
    Quote Originally Posted by rule62 View Post
    Just take off the lever, clean and lube the bush, bolt, and perch, and make sure it's not too tight when you put it back on. I use a little blue loctite on my lever bolts, over any undue tightening. See how that goes. Should only take about 5 mins.
    yep that's the 1st thing to try come good friday
    Don't be a jerk... jerk

    2016 KTM 250 xc
    2013 KTM 350 xcf ---------------SOLD
    2011 Husqvarna 630 ------------SOLD
    2007 KTM Superduke 990-------SOLD
    2009 Dorsoduro 750
    2003 KLX 400R
    2009 YZ450 -----------------------SOLD
    2007 ZZR600 ----------------------SOLD
    2006 CBR600RR ------------------SOLD
    2009 Ninja 250 -------------------SOLD

Similar Threads

  1. ATC and ABS shutting off (not clutch lever)
    By CrankyGypsy in forum 2010-2019 RSV4 - All Variants
    Replies: 24
    Last Post: 07-27-2018, 05:33 AM
  2. AM6 Clutch Release Lever Not Engaging Clutch
    By oliverwilde in forum RS50 Technical
    Replies: 5
    Last Post: 01-13-2015, 08:57 PM
  3. shift lever not returning
    By blurry in forum RSVR and RSVR Factory (2004-2009)
    Replies: 3
    Last Post: 05-14-2009, 08:59 PM
  4. Clutch lever when pulled does not have enough pressure
    By akrsv in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 18
    Last Post: 03-29-2009, 11:26 AM
  5. Replacing clutch lever.....???
    By AV8OR in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 1
    Last Post: 06-21-2003, 02:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •