Results 1 to 4 of 4

Thread: fuel pump problems resolved

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    apriliaforum newb
    Join Date
    Oct 2012
    Location
    Kentucky
    Posts
    18

    fuel pump problems resolved

    I would like to thank all the guys who responded to my recent query about my bike just shutting down due to fuel pump issues. I had read several posts concerning the solder joint within the wiring harness going to the pump. Regardless of all my testing, I could never find a problem there and had ruled it out. Then finally, after running the engine in the garage, turning off the key and back on, the fuel pump didn't come on. I was able to trace the electrical problem to the junction, so I removed the fuel pump for the umpteenth time and was able to wiggle the part of the wiring that goes inside the tank and recreate the problem for the first time. WhaLaa! Discovered the issue! It still blows my mind as to how that joint in the wiring can actually fail! Thanks to all those who sent suggestions and I will join the group of riders who have had the issue. Mine just seemed to be so intermittent that I could not pinpoint it for the longest time. I removed the mastic that housed the connection, re-soldered the wires and am riding again with confidence I won't get stranded. I had forgotten how fun this bike is to ride!
    Thanks again to all who took time to offer help.
    Bruce

  2. #2
    apriliaforum expert JMH's Avatar
    Join Date
    Dec 2012
    Location
    Paimio, Finland
    Posts
    2,020
    Happy days!
    Mille Aarrr -02 (1060 BB, Gen2 heads, 2-2 Akra, timed cams, bespoke Gabro chip + TSS slipper) & KTM 625 SXC -05
    My riding lines are like Hendrix's solos. Unexpected and always different.

  3. #3
    apriliaforum Member
    Join Date
    Aug 2017
    Location
    Murrieta, CA
    Posts
    156
    Bruce, congrats on finding and fixing! What did you use to reseal where the wires enter the tank?
    2001 Futura - Blue
    2007 RSVR - Red
    2000 Moto Guzzi V11 Sport - Green
    2005 Tuono - Black

  4. #4
    apriliaforum expert
    Join Date
    Jul 2003
    Location
    RI.
    Posts
    1,542
    Yep my pump drove me nuts. It seems that some of the joints don't even get soldered! I guess to much vino the nite before!!
    Don-M

    2003 Aprilia Tuono
    2009 Moto Guzzi Griso 8V Sold it
    2015 EBR1190SX
    1975 Kawasaki Z1
    2015 Norton Commando 961SE

Similar Threads

  1. Fuel pump problem
    By frane1012 in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 10
    Last Post: 02-12-2014, 02:50 AM
  2. SR50 Fuel Pump Problems
    By masicycle in forum Scarabeo 50, SR50, Mojito 50, Rally, Fly 50
    Replies: 0
    Last Post: 06-05-2008, 01:33 PM
  3. Fuel pump problem , Flow of fuel even if engine is off !!!
    By djkerm in forum Scarabeo 50, SR50, Mojito 50, Rally, Fly 50
    Replies: 4
    Last Post: 09-03-2006, 09:51 AM
  4. new owner, fuel pump problem
    By Rubberdown in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 9
    Last Post: 07-10-2006, 12:35 PM
  5. Fuel pump problem?
    By anssi in forum RST1000 Futura (all years)
    Replies: 10
    Last Post: 08-11-2004, 08:04 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •