Results 1 to 2 of 2

Thread: EFI error -1

  1. #1
    apriliaforum newb
    Join Date
    Sep 2018
    Location
    Norway
    Posts
    1

    EFI error -1

    Hi there

    I'm rebuilding a bike I got as part of another deal. It's 75% complete, but has been used as a spare part bike. So I have some challenges New battery. New oil. Oil pressure when I turn the engine with the starter, with the spark plugs removed. But the EFI light blinks. When connecting the cables to see the error code, it shows "-1".

    I have an ECU program on my PC. Tried it on my second Futura, and it worked fine. But on my project bike, the program can't find the ECU.

    Tested putting a spark plug into the cable from the coil, to see if I got a spark when trying to start... Nothing...

    So... I need some help here The problem might be some parts missing, since I don't have full control.

    http://www.apriliafutura.co.uk/works...ing/efi-error/

    Click image for larger version. 

Name:	IMG_0309.jpg 
Views:	18 
Size:	508.7 KB 
ID:	368078Click image for larger version. 

Name:	IMG_0310.jpg 
Views:	18 
Size:	500.2 KB 
ID:	368079Click image for larger version. 

Name:	IMG_0312.jpg 
Views:	20 
Size:	486.0 KB 
ID:	368080Click image for larger version. 

Name:	IMG_0315.jpg 
Views:	19 
Size:	525.0 KB 
ID:	368081Click image for larger version. 

Name:	IMG_0316.jpg 
Views:	18 
Size:	507.3 KB 
ID:	368082



    The strange thing is that sometimes the EFI lamp is "OK", meaning dark...

    I hope to get this motor running soon. Thanks

    GT

  2. #2
    apriliaforum expert RAS's Avatar
    Join Date
    Aug 2003
    Location
    PA USA
    Posts
    8,432
    -1 is not an error code. It means your kill switch is in the off position. I'm thinking the starter won't spin with the kill switch activated though.

    For some reason, I seem to recall that mine will run with the airbox open.

    Not sure what yer trying to show with the video. The oil level in the sight tube is not gonna budge until the motor gets up to operating temp.

    Can't help you with the ECU programming. You have no spark, does your fuel pump prime? If you have neither, you might have a faulty tip-over sensor or faulty "engine stop" relay.

    Have you checked all of the fuses - the ones in front as well as the 2, 30Amain fuses?

Similar Threads

  1. 2006 SR50: results of my EFI error
    By p700 in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 2
    Last Post: 04-22-2006, 06:53 AM
  2. 2002 motor in 2000 bike giving "EFI" error
    By krisbattye in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 2
    Last Post: 01-26-2006, 06:52 AM
  3. EFI error after long wheelie
    By Leoallafila in forum RSVR and RSVR Factory (2004-2009)
    Replies: 5
    Last Post: 04-12-2005, 10:36 AM
  4. EFI errors
    By CPH_2004 in forum RSVR and RSVR Factory (2004-2009)
    Replies: 6
    Last Post: 06-24-2004, 11:38 PM
  5. EFI error
    By new mexico jay in forum RST1000 Futura (all years)
    Replies: 4
    Last Post: 01-20-2003, 05:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •