Results 1 to 3 of 3

Thread: RS4 Fault diagnosis

  1. #1
    apriliaforum newb
    Join Date
    Jul 2018
    Location
    United Kingdom
    Posts
    4

    RS4 Fault diagnosis

    Evening folks. Been googling for a while now but all I can find is posts relating to the rs125 or the rsv4.

    need to diagnose a fault on an RS4 125. Itís my first bike and while Iím familiar with car diagnostics Iím struggling with the bike. Iíve found what appears to be a diagnostics socket under the seat although I could be wrong (small oval socket with 2 wires). Is there a way to make faults show on the display either button combinations or bridging these two wires? Always been a home mechanic but if I need to bite the bullet and pay a dealer to do this then so be it.

    2012 Aprilia RS4 125. Showing red triangle with exclamation mark but no other lights accompanying it. And it only shows when itís really pushing on. Back off the throttle and the light goes off.

  2. #2
    apriliaforum newb
    Join Date
    Oct 2018
    Location
    Tamworth
    Posts
    19
    I have the same problem, I have no idea what it is have a feeling it's something to do with the injector ?

  3. #3
    apriliaforum expert
    Join Date
    Jun 2013
    Location
    croatia
    Posts
    2,417
    you need to connect a Piaggio or Aprilia scanner and read it out or delate the error. Car scanners are not compatible with the bike ecu.
    You can get it at any dealership.

Similar Threads

  1. SR50 Ditech - ECU/Injector Diagnosis - ECU fault 11/12
    By nz.reidfamily in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 5
    Last Post: 01-11-2017, 06:51 PM
  2. Occam's razor applied to fault diagnosis
    By Stu_O in forum ETV1000 CapoNord (2001-2007)
    Replies: 6
    Last Post: 01-09-2014, 06:16 AM
  3. Fault Diagnosis Please
    By phibes4000 in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 16
    Last Post: 01-17-2008, 10:40 PM
  4. ecu fault codes (diagnosis wires) yeah again
    By farva03R in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 8
    Last Post: 02-28-2006, 10:53 AM
  5. Low Speed engine cutting out intermittent fault.
    By ALLAN in forum RST1000 Futura (all years)
    Replies: 8
    Last Post: 05-06-2003, 01:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •