Results 1 to 3 of 3

Thread: Puig 992 install on 2009 SC250 -- Issue with previous install -- Body part question

  1. #1
    apriliaforum newb thunderkat59's Avatar
    Join Date
    Sep 2017
    Location
    Louisville, KY
    Posts
    14

    Angry Puig 992 install on 2009 SC250 -- Issue with previous install -- Body part question

    Hello,
    I have Googled this for hours, and looked at parts fiche, but still cant find what I need to see . . .
    The previous owner of my '09 SC put some jury-rigged, 2ft tall, Harley type windshield on that involved
    running long threaded rods through the turn indicator housings. I cannot get the front bodypiece/windscreen
    off to try to make heads or tails of this set up. I ape-fisted one of the threaded rods out, only to have the
    indicator fall off,sending bolts/washers into the bike. Now, I really need to get into that assembly to put it
    together correctly and get the other threaded rod out.
    In summation, what will get the required front panels off so I may fix the indicators and install the new 992 I
    just got from AF1?
    To add to this, there are some screws missing from the previous install, but the panels still seem stuck in place.
    Any insights into this exercise of supreme frustration would be appreciated more than you might know . . .

    Thank you!

    LM in KY

  2. #2
    apriliaforum prov-nov Finprilia's Avatar
    Join Date
    Jan 2017
    Location
    Finland
    Posts
    37
    Hey,
    here is Sportcity Workshop manual, it has helped me much.
    http://www.mediafire.com/file/nsc0qp...e+Workshop.pdf

  3. #3
    apriliaforum newb thunderkat59's Avatar
    Join Date
    Sep 2017
    Location
    Louisville, KY
    Posts
    14
    Quote Originally Posted by Finprilia View Post
    Hey,
    here is Sportcity Workshop manual, it has helped me much.
    http://www.mediafire.com/file/nsc0qp...e+Workshop.pdf
    Thank you Finprilia!

    Back out for round two . . .


    Lm in KY

    EDIT: Thank you again, Finprilia . . . Unhooking the tabs and flexing the front panel down did the trick!
    Last edited by thunderkat59; 07-15-2018 at 03:41 PM.

Similar Threads

  1. has anyone had issues with the throttle body boots rubber cracking?
    By beerock in forum RSVR and RSVR Factory (2004-2009)
    Replies: 6
    Last Post: 04-20-2016, 10:13 PM
  2. PUIG 992 Windscreen (SC250) for sale
    By 4onthfloor in forum Other Stuff For Sale
    Replies: 0
    Last Post: 03-01-2011, 06:55 PM
  3. Finally back on the road..now with issues
    By Brian_M in forum RST1000 Futura (all years)
    Replies: 8
    Last Post: 10-26-2008, 01:32 AM
  4. Any Issues with Rally Raid Shock Installation?
    By Italiaphile in forum ETV1000 CapoNord (2001-2007)
    Replies: 1
    Last Post: 07-03-2007, 07:00 AM
  5. Issue with the Electronics on my bike...
    By Mtrhd0024 in forum RS50 Technical
    Replies: 8
    Last Post: 05-04-2007, 04:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •