Page 2 of 2 FirstFirst 12
Results 16 to 24 of 24

Thread: 2014 RSV4 Lost Key

  1. #16
    just another Aprilia fanatic amauri's Avatar
    Join Date
    Sep 2003
    Location
    Westminster, CA - USA
    Posts
    15,039
    Do you have both keys next to each other on the key ring when trying to start the bike?
    Never accept mediocrity, always demand competence.

    Certified Aprilia Moto Service in Southern California
    Call me at 714 892-4056 for appointment

  2. #17
    apriliaforum prov-nov
    Join Date
    May 2016
    Location
    Brooklyn, NY
    Posts
    30
    No, I was switching them from sitting on the seat to the ignition so I wouldn't mix them up.

  3. #18
    just another Aprilia fanatic amauri's Avatar
    Join Date
    Sep 2003
    Location
    Westminster, CA - USA
    Posts
    15,039
    Ok, if the keys are close or next to each other, the two ID chips will interfere with each other and confuse the immobilizer.

    I don't understand what you mean when you say "My #1 has no user code so it's still 00000."
    With the one key that is working correctly, do you see any code related message on the dash immediately after ign on?
    Never accept mediocrity, always demand competence.

    Certified Aprilia Moto Service in Southern California
    Call me at 714 892-4056 for appointment

  4. #19
    apriliaforum expert pauldayona's Avatar
    Join Date
    Nov 2013
    Location
    Netherlands
    Posts
    946
    Keys dont have their own usercode. The dash has one, or not. When the dash asks a usercode on one key, then that one is not learned in the dash.


    Send from my mobile

  5. #20
    apriliaforum prov-nov
    Join Date
    May 2016
    Location
    Brooklyn, NY
    Posts
    30
    Ok, my code works but I keep getting error IMMO B003 and when I try to do a recovery it doesn't recognize the #2 key. This means the #2 key transponder isn't working, correct? My #2 key looks identical except that when they cut the key pattern I see some brass coloring in the groove. Maybe it's a key with no transponder? Should I get another key and try again? Thanks for all your help. I found out that my SXV key turns the lock in my RSV4. It has a different pattern cut on it but it turns, lol. Is that weird?

  6. #21
    just another Aprilia fanatic amauri's Avatar
    Join Date
    Sep 2003
    Location
    Westminster, CA - USA
    Posts
    15,039
    The IMMO B003 error is reporting that it read a chip that is not programmed into memory.

    With the 2017+ bikes, programming a new key into immobilizer's memory requires the PADS (not like the older bikes).

    A tech will have to connect the PADS to the instrument panel interface, using the special cable set E703, and execute the "reset keys" option.
    This will clear the immobilizer of all keys previously saved, and allow you to enter up to four new keys.

    The only gotcha is that you must enter the user code before the process will complete.

    If your user code is still the default 00000 then no problem, but if the code has been changed you must enter that new code.
    Never accept mediocrity, always demand competence.

    Certified Aprilia Moto Service in Southern California
    Call me at 714 892-4056 for appointment

  7. #22
    apriliaforum prov-nov
    Join Date
    May 2016
    Location
    Brooklyn, NY
    Posts
    30
    Quote Originally Posted by amauri View Post
    The IMMO B003 error is reporting that it read a chip that is not programmed into memory.

    With the 2017+ bikes, programming a new key into immobilizer's memory requires the PADS (not like the older bikes).

    A tech will have to connect the PADS to the instrument panel interface, using the special cable set E703, and execute the "reset keys" option.
    This will clear the immobilizer of all keys previously saved, and allow you to enter up to four new keys.

    The only gotcha is that you must enter the user code before the process will complete.

    If your user code is still the default 00000 then no problem, but if the code has been changed you must enter that new code.
    Thanks dude! You are a boss! OMW to the dealer...

  8. #23
    apriliaforum newb
    Join Date
    Apr 2014
    Location
    EU
    Posts
    5
    Is it the same with the 2010 models ?

  9. #24
    just another Aprilia fanatic amauri's Avatar
    Join Date
    Sep 2003
    Location
    Westminster, CA - USA
    Posts
    15,039
    Quote Originally Posted by amauri View Post
    (not like the older bikes)..

    .....
    Never accept mediocrity, always demand competence.

    Certified Aprilia Moto Service in Southern California
    Call me at 714 892-4056 for appointment

Page 2 of 2 FirstFirst 12

Similar Threads

  1. [RSV4] 2014 RSV4 Clip-ons [Texas]
    By jrD in forum Aprilia Parts and Accessories for Sale / Wanted
    Replies: 3
    Last Post: 07-15-2016, 05:42 AM
  2. [RSV4] 2014 RSV4 OEM Sachs shock absorber - Excellent condition [Texas]
    By jrD in forum Aprilia Parts and Accessories for Sale / Wanted
    Replies: 1
    Last Post: 12-02-2015, 01:32 PM
  3. [RSV4] 2014 RSV4 Use + Maintenance Book [Texas]
    By jrD in forum Aprilia Parts and Accessories for Sale / Wanted
    Replies: 1
    Last Post: 08-22-2015, 03:34 PM
  4. [RSV4] 2014 RSV4 Factory Engine Parts
    By dastrix in forum Aprilia Parts and Accessories for Sale / Wanted
    Replies: 7
    Last Post: 02-03-2015, 04:55 AM
  5. [RSV4] WTB: 2013 or 2014 RSV4 Fuel Tank
    By beckett_bgs in forum Aprilia Parts and Accessories for Sale / Wanted
    Replies: 8
    Last Post: 11-24-2014, 09:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •