Results 1 to 3 of 3

Thread: 1 issue after 1st ride

  1. #1
    apriliaforum newb
    Join Date
    Feb 2016
    Location
    London
    Posts
    1

    1 issue after 1st ride

    Hi All,

    I'm a brand-new owner of an MP3 500, just rode it back from the dealership yesterday. One thing: The speedo is in kph, not mph - sure, the mph is indicated in a smaller inner dial, but is frankly very difficult to read. Apparently Piaggio don't bother to make a proper dial for the UK market - bit of an oversight I reckon, especially with a safety issue - I need to know how fast I'm going.

    Any thoughts?

    Cheers,

    jobetim

  2. #2
    apriliaforum expert
    Join Date
    Jun 2013
    Location
    croatia
    Posts
    2,442
    no, the dials are like they are
    you can buy aftermarket dial discs

  3. #3
    apriliaforum newb BVL123's Avatar
    Join Date
    Nov 2015
    Location
    BVL123
    Posts
    6
    Yes, I sympathize with you plight, but that's what happen when you buy the Piaggio, MP3 that was made for a EU market. I live in the U.S. and experienced the same situation. I simply learned the kilometer ratio and everything was fine. Hey it's fun when people look at the scooter and see it's maximum speed 180 in kilometers and then it's 180 MPH. They think it's a racing scooter! The Piaggio does go fast compared with most scooters, so they believe it goes 180 MPH.

Similar Threads

  1. Aprilia sr 125 riding issues after upgrading parts
    By Wrigh1991 in forum Other Aprilia Models
    Replies: 1
    Last Post: 10-27-2013, 12:04 PM
  2. Beo starting issue -- after long ride.
    By jkdrummer in forum Aprilia and Piaggio 150cc-350cc
    Replies: 2
    Last Post: 09-17-2012, 02:15 PM
  3. A few issues after a good ride
    By alanw in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 6
    Last Post: 09-03-2012, 01:14 PM
  4. Weird Issue after today's ride.
    By Rosscofat in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 113
    Last Post: 05-30-2012, 02:05 PM
  5. 1st ride after pv clean *wow*
    By GOLDY21 in forum RS125 Euro-archive
    Replies: 4
    Last Post: 10-12-2003, 07:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •