Results 1 to 3 of 3

Thread: Aprilia sport city 50 2t misfiring.

  1. #1
    apriliaforum newb
    Join Date
    Sep 2015
    Location
    Coventry
    Posts
    1

    Aprilia sport city 50 2t misfiring.

    Hi there, I'm fairly new to owning my scooter I've only had it for around 5 months and it is also my first scooter so I know absolutely nothing about it. I was coming home from college today and all of a sudden I lost a lot of power and I could only go around 20mph, it was like the power would cut out, then after around 5 minutes I would lose all power completely and have to stop then let it sit for a minute then restart the engine.I managed to get it home and my step-dad had a look at the bike, he suggested it was misfiring but he wasn't sure. The previous owner was pretty rough with the bike by the look of it and it has been raining a lot so I wasn't sure if that had anything to do with it. Any help would be much appreciated!

  2. #2
    apriliaforum expert
    Join Date
    Jun 2013
    Location
    croatia
    Posts
    2,431
    check the resistance on the kick starter if you feel compression its fine

    i would personaly replace the spark plug and check the air filter and clean the carburetor jets
    then check out if the oil lines and pump is fine
    also make sure you have enough oil

  3. #3
    apriliaforum Member PGO6GOD's Avatar
    Join Date
    Jun 2015
    Location
    Des Moines, Wa
    Posts
    183
    Quote Originally Posted by Jack banfield View Post
    Hi there, I'm fairly new to owning my scooter I've only had it for around 5 months and it is also my first scooter so I know absolutely nothing about it. I was coming home from college today and all of a sudden I lost a lot of power and I could only go around 20mph, it was like the power would cut out, then after around 5 minutes I would lose all power completely and have to stop then let it sit for a minute then restart the engine.I managed to get it home and my step-dad had a look at the bike, he suggested it was misfiring but he wasn't sure. The previous owner was pretty rough with the bike by the look of it and it has been raining a lot so I wasn't sure if that had anything to do with it. Any help would be much appreciated!

    Check the compression analize the engine, compression about 200lbs 50 needed to start, fallow these guys and you will get the best.

    Sounds like tune up to me, these old gals are picky, but ya love them rather sand, road, snow, or mud.

    If ya need to know it's not as hard as you make it. You should check your auto choke first to see if it's sticky, then if that didnt work then do a full tune up, bucket off CARB cleaner would be nice, check the oil supply, check everything. Mechanical first, then electrical.
    Last edited by PGO6GOD; 09-19-2015 at 01:58 PM.
    Riding a real Hondas to easy, to rebuild a clone with custom specs pisses on the genuine real deal.

    "I GIVE MY 100% ALL IN ANY VEHICLE I TOUCH SO WHEN I TELL YOU WHATS GOING ON PAY ATTENTION."

Similar Threads

  1. FS : Aprilia sport city emblems [2] new in package CHEAP !!
    By superbikeitalia in forum Aprilia Parts and Accessories for Sale / Wanted
    Replies: 0
    Last Post: 01-20-2013, 08:47 AM
  2. Aprilia Sport City One 50cc, Miles to the gallon?
    By MrvTea in forum Other Aprilia Models
    Replies: 2
    Last Post: 04-13-2012, 10:41 AM
  3. Aprilia Sport City 500 pla
    By MrvTea in forum Other Aprilia Models
    Replies: 0
    Last Post: 04-12-2012, 02:15 PM
  4. Aprilia sport city 125cc (a blessing is disguise!)
    By razlove in forum Aprilia and Piaggio 150cc-350cc
    Replies: 0
    Last Post: 04-30-2009, 09:59 AM
  5. Aprilia Sport City 200
    By jimscoot in forum Aprilia and Piaggio 150cc-350cc
    Replies: 9
    Last Post: 07-29-2005, 03:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •