Page 3 of 3 FirstFirst 123
Results 31 to 44 of 44

Thread: new 2003 Futura Owner

  1. #31
    apriliaforum expert SoCalSV's Avatar
    Join Date
    Feb 2011
    Location
    OKC, OK
    Posts
    634
    Heheh - I bought her with really low miles.... Part of the reason I had to strip it down was because it was sitting so long - everything rubber was rotten and dried out :/

    I'm gonna have to do it again before I can go more than a couple hundred miles at a stretch. Well, maybe not ALL the way through it, but enough that I'm comfortable being a few hours away from home.
    I donít need to trek through Africa and I donít need to climb Everest ó I need to ride every f***ing curvy road between here and there. Thatís far more powerful. Far more majestic. Far more of a journey.

  2. #32
    apriliaforum Member chefdanny69's Avatar
    Join Date
    Mar 2015
    Location
    New Jersey
    Posts
    109
    well, i decided to take it to a aprilia dealer to get a full service, and they are going to fix all the recalls on the bike and also check into my blinker situation, i will keep all posted!

  3. #33
    apriliaforum expert SoCalSV's Avatar
    Join Date
    Feb 2011
    Location
    OKC, OK
    Posts
    634
    Nope. Undo to the bolts, pull the old batt out, put the new one in and bob's yer uncle. the Tie down is a bit fiddly if I remember but it's mostly obvious how to get it in/out. Yuasa YT12 if I remember....?
    I donít need to trek through Africa and I donít need to climb Everest ó I need to ride every f***ing curvy road between here and there. Thatís far more powerful. Far more majestic. Far more of a journey.

  4. #34
    apriliaforum Member chefdanny69's Avatar
    Join Date
    Mar 2015
    Location
    New Jersey
    Posts
    109
    well i did put a new battery in the bike! and i still got the same problem with the blinkers! they worked fine when the bike has a load, but when i am at idle for a few minutes the stop blinking and the just stay lit up? they dont blink? when i blip the throttle they start blinking? its a pain in the ass! also what kind of fairing fasteners does our bike use, because i need a few of them!

  5. #35
    apriliaforum Member chefdanny69's Avatar
    Join Date
    Mar 2015
    Location
    New Jersey
    Posts
    109
    hello all, well i took my bike to a dealer, big mistake, it was there for 3 weeks waiting on parts and the did a full service and guess what! i got it home and its leaking oil, i believe from the connection to the oil cooler, i am bring it back tomorrow so they can check it out! as with my blinkers, they checked the charging system and they said all was good, they also fixed the recall, well my blinkers still are not working correctly, the dealer honestly fucked up my bike even more! but the blinker stays lit when i run the bike in traffic when it in gear, when i shift to neutral it starts to work? not fast but it works. When the bike is in gear and it stays lit if i blip the throttle it starts to blink, when i am moving the blinker works if i have rpm, CAN ANYONE HELP ME OUT? WHAT SHOULD I CHECK? ITS A BRAND NEW BATTERY, CHARGING SYSTEM WORKS!

  6. #36
    apriliaforum Member chefdanny69's Avatar
    Join Date
    Mar 2015
    Location
    New Jersey
    Posts
    109
    well i did some research on other threads and it seems that my flasher unit is load sensitive, that makes sensce with my situation! so i need an electronic flasher unit that flashes with all type of loads, so my question is what type of flasher, name brand...i live in new jersey, any help would be great and i decided to do all my own maintenance on my bike!

  7. #37
    apriliaforum prov-nov
    Join Date
    Jan 2014
    Location
    Wellington, New Zealand
    Posts
    76
    If I were you, I would replace the flasher unit next personally, and with one which is LED compatible so that you can upgrade to LED indicators is you ever want to. I believe the flasher unit is with a rail of relays under the dash / behind the headlight, just forward of the fuse box. According to the workshop manual, the flasher unit is right next to the large tilt sensor in the middle, to the right if you are sitting on the bike.

    I don't knwo how easy it is to get at, when I replaced mine I had all the fairings off.

    I think it's a 2 prong right angle flasher unit.
    _____________________
    aotearoasteve
    Wellington, New Zealand
    2002 RST 1000 Futura - Red/Black, no silicon plugs in the fuel rails

  8. #38
    apriliaforum expert spesnaz's Avatar
    Join Date
    Mar 2014
    Location
    California
    Posts
    1,316
    The flasher is very simple to access, remove the center trim over the fuse panel, remove the side trims next to the instrument cluster, then lift the cluster out and pivot it to the right.

    The relays are right behind the cluster.

    Bob

  9. #39
    apriliaforum prov-nov
    Join Date
    Jan 2014
    Location
    Wellington, New Zealand
    Posts
    76
    _____________________
    aotearoasteve
    Wellington, New Zealand
    2002 RST 1000 Futura - Red/Black, no silicon plugs in the fuel rails

  10. #40
    apriliaforum Member chefdanny69's Avatar
    Join Date
    Mar 2015
    Location
    New Jersey
    Posts
    109
    well, i just got more news about my bike! I brought it back to the service shop and they told me that someone before me sealed up the heads with sealer and the head gasket was the wrong one and that was the cause of my oil leak! well long story short they are going to replace the seal! now has the futura had issues with leaky valve seals? well hopefully it will be all fixed, i am going to get the recommended flasher unit, now what parts should i get to turn my indicators to LED? THANKS ALL! THE LINK I WAS SENT FOR THE FLASHER UNIT, WONT SEND TO THE USA?

  11. #41
    apriliaforum prov-nov
    Join Date
    Jan 2014
    Location
    Wellington, New Zealand
    Posts
    76
    Hey,

    You can see the connections on the ebay flasher unit, you just need to find any one which is suitable for LED's and has that connection shape, they are pretty generic. Try you local bike shop. I got mine off the local version of ebay (trademe.co.nz) from a local distributor.
    If you really can't find one I would be happy to find one and send it to you for say USD$100?

    I originally bought mine because I had bought some cheap mirrors from ebay which had LED flashers, but they looked so shite on the bike and I couldn't live with them.

    I found some replacement RSV1000 mirrors with integrated indicators, but these don't use LED bulbs.
    I'm have replace my main headlight with LED, but have not yet gotten around to the other bulbs yet.

    If you pull apart the tail light unit, or any other bulbs, maybe you can post the bulb types and sizes here for future reference?

    Shame to hear about your oil leak, from the sounds of it most owners don't need to even crack the rocker covers on these engines.
    _____________________
    aotearoasteve
    Wellington, New Zealand
    2002 RST 1000 Futura - Red/Black, no silicon plugs in the fuel rails

  12. #42
    apriliaforum expert Argh Oh's Avatar
    Join Date
    Nov 2012
    Location
    AL, USA
    Posts
    2,468
    Just got a couple of these myself, there are also round ones available.

    http://www.ebay.com/itm/281453588004...%3AMEBIDX%3AIT
    01 Blue #84, 11/12 with: HeliBars, foam grips, 05 map, Borla cans (Replaced by 2" pipe)/stock silencer, derestricted, metal QD, dash socket, wiring mod. Me: Ford relay +10awg & grd, fuel pump rewire, FPR, vac hoses. Evap gone, CBR coils/harness+ Magnecor, clutch switch bypass. S.S. clutch & front line, RaceTech Gold fork, Cogent rebuilt Sachs, tapered head bearings. Added LED run lights/indicators/brake. All signals also run lights. All lights but Hi/park/brake on dash switch. Hi beam mod, vest plug, wiring block, blue dash SMD's/Red V meter, Tune IFT, PCIII gone. Stripped/polished rims, vented screen, rear petal disc. FH008 soldered DC plug/added grd/hard soldered AC. L/R dash indicator lights, RG frame/fork sliders, vented screen.

  13. #43
    apriliaforum Member chefdanny69's Avatar
    Join Date
    Mar 2015
    Location
    New Jersey
    Posts
    109
    funny reading over old posts! well the futura has 42k and is running strong! it has its electrical issues but its still alive! i have taken it to deals gap 4 times now and have been on it from jersey to Charlotte non stop 13 hours with no issue! love the bike just love it! dont plan on selling her either! still got that dam blinker issue! but i deal with it!

  14. #44
    apriliaforum prov-nov craydds's Avatar
    Join Date
    Oct 2009
    Location
    Las Cruces, NM
    Posts
    61
    Quote Originally Posted by Argh Oh View Post
    While you have tail light off I really suggest reinforcing the lens seams with epoxy, the turn lenses have been know to take flight.
    I found out the hard way, just happened to me. Now I need a new taillight.

Page 3 of 3 FirstFirst 123

Similar Threads

  1. New 2001 Futura Owner
    By Basquard in forum RST1000 Futura (all years)
    Replies: 7
    Last Post: 10-06-2013, 03:09 PM
  2. New 02' Futura owner - not happy!!
    By madracng in forum RST1000 Futura (all years)
    Replies: 106
    Last Post: 04-28-2010, 12:17 PM
  3. New NorCal Futura Owner
    By BlueLake in forum RST1000 Futura (all years)
    Replies: 8
    Last Post: 08-25-2008, 01:07 PM
  4. New UK futura owner in the making
    By Seb in forum RST1000 Futura (all years)
    Replies: 13
    Last Post: 05-01-2008, 02:37 PM
  5. New prospective Futura Owner.....
    By chancha in forum RST1000 Futura (all years)
    Replies: 19
    Last Post: 02-27-2008, 01:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •