Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 31

Thread: DNA filter install

  1. #16
    apriliaforum prov-nov motardman's Avatar
    Join Date
    Oct 2011
    Location
    New Zealand
    Posts
    56
    Quote Originally Posted by Micah / AF1 Racing View Post
    If you have pipes running the DD1200 with the DB killers in place works better for closed loop running. Closed loop
    control on Motorcycles with their short exhaust pipes combined with a free flowing set of slip ons and running at lower rpms is usually way too rich. This has everything to do with atmospheric air reversion into the exhaust pipes at lower rpms. Basically reversion allows the o2 sensor to be exposed to too much air, it senses lean because the lambda probe cannot tell the difference between reversion air and oxygen left over during the combustion process. DB killers reduce reversion air more than anything else beneficial they do.

    If you still have stock pipes and catalyzer...well that just may be too rich in terms of mapping or Ag/r target values.
    That's wise words Micah, makes perfect sense, I'd never thought of it that way.....now I wish I'd bought the arrows instead of the Leo's even though I love the full carbon. I wonder if the Arrows Y pipe with the cats would fit with the Leo's and if they sell it separately?

  2. #17
    apriliaforum prov-nov Chris09's Avatar
    Join Date
    Aug 2011
    Location
    brisvegas
    Posts
    48
    Got the 10,000 klm service done today and stg 2 dna put in same time by sean at Brisbane aprilia (Springwood)
    Man, night & day difference! Breathes heaps better!
    DAMN CRAZY SUNDAY RIDER

  3. #18
    apriliaforum Member
    Join Date
    Oct 2012
    Location
    Melbourne, Australia
    Posts
    222
    Some more pics for the install procedure, hope they are helpful. Don't know how you guys did it without removing the tank!?!

    Click image for larger version. 

Name:	1.jpg 
Views:	38 
Size:	148.2 KB 
ID:	232706Click image for larger version. 

Name:	2.jpg 
Views:	39 
Size:	253.4 KB 
ID:	232707Click image for larger version. 

Name:	3.jpg 
Views:	36 
Size:	249.0 KB 
ID:	232708Click image for larger version. 

Name:	4.jpg 
Views:	33 
Size:	269.7 KB 
ID:	232709Click image for larger version. 

Name:	5.jpg 
Views:	34 
Size:	281.7 KB 
ID:	232710Click image for larger version. 

Name:	6.jpg 
Views:	34 
Size:	277.5 KB 
ID:	232711Click image for larger version. 

Name:	7.jpg 
Views:	38 
Size:	237.8 KB 
ID:	232712

  4. #19
    apriliaforum Member
    Join Date
    Oct 2012
    Location
    Melbourne, Australia
    Posts
    222
    150km to try out the new filter. At 2 sets of light when I was stopped the revs slowly went down and eventually it stalls... this was happening a while ago when the demand sensor / fly-by-wire and o2 sensor went faulty and it fouled all plugs and had no power above 4000rpm.... however it's running fine with heaps of up and go, but the stalling issue happens when i stationary.... Can anyone suggest what the problem might be??????

  5. #20
    apriliaforum Member
    Join Date
    Dec 2008
    Location
    Sweden
    Posts
    98
    Hi
    Do u guys use airfilter oil for the dna filter.

  6. #21
    apriliaforum Member
    Join Date
    Oct 2012
    Location
    Melbourne, Australia
    Posts
    222
    I did.. K&N Filter oil, spray on

  7. #22
    apriliaforum Member
    Join Date
    Dec 2008
    Location
    Sweden
    Posts
    98
    Quote Originally Posted by motardman View Post
    That's wise words Micah, makes perfect sense, I'd never thought of it that way.....now I wish I'd bought the arrows instead of the Leo's even though I love the full carbon. I wonder if the Arrows Y pipe with the cats would fit with the Leo's and if they sell it separately?
    I have a pair of GPR slipons without catalyzers, so if i install a stage 2 DNA filter, will the bike run to lean, and do i have to do anything with the fuel or am i good to go.
    Best regards Micke
    Last edited by extreme67; 12-14-2013 at 05:56 AM.

  8. #23
    apriliaforum Member
    Join Date
    Dec 2008
    Location
    Sweden
    Posts
    98
    Quote Originally Posted by Mr.Dorso View Post
    I did.. K&N Filter oil, spray on
    Thanks :-)

  9. #24
    apriliaforum Member
    Join Date
    Oct 2012
    Location
    Melbourne, Australia
    Posts
    222
    Who is running just the DNA filter? No fatduc..

    Is it running fine? Cheers.

  10. #25
    apriliaforum prov-nov
    Join Date
    Feb 2013
    Location
    Kuala Lumpur
    Posts
    37
    I've installed the DNA Stage 2 last week and I've also a Leo Vince without DB Killer. So far I'm not positive impressed about the change and I'm thinking going back to original.
    I owe a 2011 model without any update on the software and the bike was always running smooth despite the smelly clothes or backpack.

    Since I changed to DNA the bike feels not smooth anymore and the engine has some misfire and sometimes the engine just go off on a traffic light which I never had before.
    My local Aprilia Dealer wants to install the new mapping but I’m not sure if this would help.

    I have no Problems that the engine is running hot with the dna except in stop and go in Kuala Lumpur traffic jams. The bike still runs quite rich because the smell in clothes are still there..

    Greetings Bernd


  11. #26
    apriliaforum expert lanter's Avatar
    Join Date
    May 2009
    Location
    Guilford CT
    Posts
    657
    The new software should make a positive difference for sure.
    2011 Dorsoduro 1200

  12. #27
    apriliaforum expert Brinks_2's Avatar
    Join Date
    Oct 2007
    Location
    Perth Western Australia
    Posts
    1,065
    Gabro told me he is close with the chip for the DD1200. Fingers crossed it wont be far.
    2 eyes,2ears,2hands,2feet----TWO CYLINDERS

    Falco Mods-K&N Filter,EVO airbox & stacks,SL Carbons ,Penske 8983, carbon front mudguard, dash,top yoke, swingarm covers and sprocket cover, bellypan, billet bar ends and levers, tinted screen & headlight cover, braided brake/clutch lines, Evoluzione clutch slave, Mille oil tank, Sargeant seat, tail tidy, Gilles vario bars, Mille swinger, Rad-cooler guards, Gabro chip. SOLD
    DD 1200 - Gel seat, Arrows & map, shock tube, EVO Tail tidy, rad and oil guard, DNA Stage 2, Lightech bolt kit, Rizoma resouvoirs, Lux grips, Renthal bars, CRG levers, Carbon body work.
    2006 SR50 - Morini motor - My $100 dollar resto project, underway currently.

  13. #28
    apriliaforum Member
    Join Date
    Oct 2012
    Location
    Melbourne, Australia
    Posts
    222
    Gabro.. Chip..? Whats this..??

    Brinks are you running the DNA stage 2 without fatduc?

  14. #29
    apriliaforum expert Brinks_2's Avatar
    Join Date
    Oct 2007
    Location
    Perth Western Australia
    Posts
    1,065
    Yes mate, a bit rich tho. Looked into a fatduc for the DD and decided it was already running rich enough. Had heard Gabro was looking at a custom chip, so decided to wait. Gabro does chips for Aprilia's, has been doing them for years on the rotax's. I have one in my Falco, which has helped cornering dramatically due to improved throttle response. If he can get one done and says it's improved, I will be all over him to purchase one and install it. Do a search on what others say after they have installed a Rotax chip from Gabro.
    2 eyes,2ears,2hands,2feet----TWO CYLINDERS

    Falco Mods-K&N Filter,EVO airbox & stacks,SL Carbons ,Penske 8983, carbon front mudguard, dash,top yoke, swingarm covers and sprocket cover, bellypan, billet bar ends and levers, tinted screen & headlight cover, braided brake/clutch lines, Evoluzione clutch slave, Mille oil tank, Sargeant seat, tail tidy, Gilles vario bars, Mille swinger, Rad-cooler guards, Gabro chip. SOLD
    DD 1200 - Gel seat, Arrows & map, shock tube, EVO Tail tidy, rad and oil guard, DNA Stage 2, Lightech bolt kit, Rizoma resouvoirs, Lux grips, Renthal bars, CRG levers, Carbon body work.
    2006 SR50 - Morini motor - My $100 dollar resto project, underway currently.

  15. #30
    apriliaforum Member
    Join Date
    Oct 2012
    Location
    Melbourne, Australia
    Posts
    222
    Cheers Brinks will look it up. Still running rich without a fatduc and stage 2.. Wow! Might uninstall fatduc and see how it runs.. Do you run sport mode or touring mode? No stalling or drop of revs at lights?

    almost feels like some sensors may be faulty again...

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •