Page 1 of 3 123 LastLast
Results 1 to 15 of 43

Thread: Slight problems after rebuild.

  1. #1
    apriliaforum Member
    Join Date
    Oct 2009
    Posts
    93

    Slight problems after rebuild.

    Hey all, just did the top end on my MX50, including a new cylinder, cylinder head, piston & rings.

    The first thing i noticed after starting up the bike is that it would not idle, i messed around with the idle screw but i found it wouldnt idle unless at high RPM's. As it was getting dark i thought i would ride home gently but hold on the throttle a small bit at junctions.

    When i got home i noticed there was a small amount of coolant coming out the exhaust, so i took out the spark plug and found it damp with coolant. I presume this is the main O ring not sealed right? Any tips to get it to seal correctly, yes i did tighten the bolts in the zig zag pattern to the correct torque.

    Do you think this would be the problem as to why the bike wont idle, as there is coolant seeping into the cylinder? Basic 2 stroke theroy says yes, as the fuel is being diluted.

  2. #2
    Banned
    Join Date
    Aug 2009
    Location
    Worthing, West Sussex, UK
    Posts
    537
    Check the cylinder and head for cracks mate

    I mean REALLY check, these cracks can be almost naked to the human eye, and will still leak and fuck your bike


    If water is getting into the bore, chances are its going into the crank, Say hello to bottom end bearing replacements!

  3. #3
    Banned
    Join Date
    Aug 2009
    Location
    Worthing, West Sussex, UK
    Posts
    537
    Also - Check the head gasket hasnt blown at all, and make sure it is entirely the perfect and correct one for the bike!

  4. #4
    apriliaforum Member
    Join Date
    Oct 2009
    Posts
    93
    Cylinder and head look sound, no cracks at all, i spent a good 20 mins checking them over before i installed onto the bike.

    The bottom end should be okay with a total runtime of around 10 mins, with a slight coolant leak?

    The main O ring is the correct one, i bought the whole thing as a kit from pj's online, maybe it just wasnt seated correctly? Should i be using some form of instant gasket to aid the seal?

  5. #5
    moderator
    Join Date
    Jun 2008
    Location
    UK
    Posts
    8,332
    O ring. Simple as.
    RIP Spike

  6. #6
    apriliaforum Member
    Join Date
    Oct 2009
    Posts
    93
    Quote Originally Posted by Dom.C View Post
    O ring. Simple as.
    Any specific tips for a good seal?

  7. #7
    moderator
    Join Date
    Jun 2008
    Location
    UK
    Posts
    8,332
    Quote Originally Posted by theoperators View Post
    Any specific tips for a good seal?
    Have you replaced it? I would advise getting a new one for sure.
    RIP Spike

  8. #8
    apriliaforum Member
    Join Date
    Oct 2009
    Posts
    93
    Yes its a brand new O ring, came with the kit.

  9. #9
    Banned
    Join Date
    Aug 2009
    Location
    Worthing, West Sussex, UK
    Posts
    537
    Water corrodes engine parts, simple as, unless your running anti-freeze - even so, its not completley safe

    I would definatley agree with Dom, New head gasket mate, It may be brand new, but my last one fucking melted

    Wipe down the Cylinder and engine, then run for about 30 seconds, give it some revs occasionally whilst really closely studying the engine, for ANY signs of liquid, then get back to us mate.

  10. #10
    apriliaforum Member
    Join Date
    Oct 2009
    Posts
    93
    Should i pull my top end off now and check for fluid in the crankcase? Or would it be safe to leave it until sunday? My coolant level doesnt seem to have gone down very much at all. Im running full antifreeze.

    I will order in another O ring tomrrow, slap it in on tuesday and tell you how it goes. As its a O ring not a gasket, should i use any kind of silicon to help seal it?

  11. #11
    apriliaforum expert maxiboi247's Avatar
    Join Date
    Jul 2008
    Location
    bracknell in berkshire
    Posts
    2,059
    just whip off the cylinder head and replace the o ring or as you said get some instant gasket on it aswel.
    your engine probs wont idle because its new and tight and the water doesnt help

    rs 125


    Haha Dom hasnt got mw2 yet

  12. #12
    Banned
    Join Date
    Aug 2009
    Location
    Worthing, West Sussex, UK
    Posts
    537
    Dont put any gasket cement on it! the compression just blows it out! Take it from someone who knows!

    Gasket,O ring, you know what I mean, dont get too picky with me

  13. #13
    apriliaforum expert maxiboi247's Avatar
    Join Date
    Jul 2008
    Location
    bracknell in berkshire
    Posts
    2,059
    yeh o-ring with a smear of instant gasket

    rs 125


    Haha Dom hasnt got mw2 yet

  14. #14
    moderator
    Join Date
    Jun 2008
    Location
    UK
    Posts
    8,332
    Quote Originally Posted by sk8inmadkid View Post
    dont get too picky with me
    Serious?

    Instant gasket does work.
    RIP Spike

  15. #15
    apriliaforum Member
    Join Date
    Oct 2009
    Posts
    93
    cheers for the help guys, should i coat the surfaces or the gasket itself?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •