Results 1 to 7 of 7

Thread: EFI Warning?

  1. #1
    apriliaforum Member frankd_nm's Avatar
    Join Date
    Oct 2008
    Location
    Las Cruces, NM
    Posts
    187

    EFI Warning?

    I did some work on the bike today and now I'm getting an EFI warning. Need help tracking down what it might be.

    What I did: I installed a new V Force3 reed
    • That involved dropping the oil tank
    • Remove the carb
    • Pulled the airbox out and cleaned the filter
    • Removed the airbox snorkel
    • Removed and replaced the reed cage
    • Changed the main jet
    • Put it all back together


    When I got it all back together the bike ran lousy. Revved less smoothly when sitting in neutral, and wouldn't go over 4000 rpm under load. The heavier the load the worse it ran. I barely made it up the hill to the house.

    I lifted the tank and checked that I had everything hooked up correctly. It appeared fine. I pulled the spark plug and checked it. It seemed like I was running rich (plug was black and wet). I pulled the TPS off the carb and checked that I had installed it correctly. It was.

    I went for another test ride and had the same problems.

    I lifted the tank again and looked everything over again. Everything looked fine. I pulled the TPS and electrical connections to the Carb and hooked them back up. Disconnected the sensor lead to the airbox and hooked it back up. Pulled the spark plug again for a check. Nothing wrong there.

    Turned the key on and the EFI Warning was on! I went over everything for a third time and still didn't see anything wrong. Started the bike and it ran great. Took it down the street and it runs fantastic. But the EFI warning is still on.

    Anybody have ideas where I might look?

  2. #2
    apriliaforum Junkie
    Join Date
    Sep 2006
    Location
    virginia
    Posts
    309
    Sorry I cant be any help to you. You'll get it sorted. Any changes w/ the new reeds/jet?

  3. #3
    apriliaforum Member frankd_nm's Avatar
    Join Date
    Oct 2008
    Location
    Las Cruces, NM
    Posts
    187
    It's a little hard for me to say how much improvement the reeds made. I haven't been on the bike for a couple of months due to a broken ankle and I only took it about a mile down the road to test it. I will say that it seems to have made a noticeable improvement in the mid range.

    The jetting I'm really not sure about yet. I went down to a 172 main jet, since I had been running rich. I'll have to see if I have to go back up to the 175 now that the airbox snorkel is gone and the reeds flow better.

  4. #4
    apriliaforum Member frankd_nm's Avatar
    Join Date
    Oct 2008
    Location
    Las Cruces, NM
    Posts
    187
    Problem Solved.

    I didn't have the TPS set correctly. Once I set that properly the EFI warning light went out.

  5. #5
    apriliaforum newb
    Join Date
    Aug 2006
    Location
    Penang, Malaysia
    Posts
    25
    sorry. what is tps? any picture?

  6. #6
    apriliaforum Member
    Join Date
    Nov 2005
    Location
    Pottstown, PA, USA
    Posts
    157
    Quote Originally Posted by akunabil View Post
    sorry. what is tps? any picture?
    Throttle position sensor. Tells a computer what angle the throttle is at.

    No idea how to set it (or to be honest what's it's doing on a carb'd engine; I guess used for the RAVE etc?) - never looked at that part of the manual..
    | 2009 Aprilia RS125 | 1982 Kawasaki AR80 | 1965 Honda C65 | 1964 Honda C105 | 1961 NSU Quickly |
    | Orchid Euro - Volkswagen and European Importation |

  7. #7
    Racing SERVICE Competition Steve / AF1 Racing's Avatar
    Join Date
    Sep 2003
    Location
    Austin, Texas USA
    Posts
    3,341
    The EFI error can also be thrown up if the temp sensor in the airbox has been manipulated at all.

    The TPS is position #8 in the diagram below:

    AF1 Racing, inc / ApriliaForum.com
    9900 North Interstate 35
    Austin, Texas 78753
    direct:512-459-3966 fax:512-482-8319

    Currently:
    '97 RS125 Two Stroke

    Previously:
    '00.5 Mille & '97 RS250.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •