Page 42 of 42 FirstFirst ... 32404142
Results 616 to 624 of 624

Thread: Ricks Motorsports Stator Version 2 - Thicker next step wires

  1. #616
    apriliaforum Junkie
    Join Date
    Jul 2014
    Location
    Earth
    Posts
    483
    i have installed rick coil and compufire rectifier for about 3-4months ago..

    since then.. the charging looks good.. on idle without load 13.5-13.8 take it out for riding on 5000-6000rpms i got very strong 13.8-13.9 like a stone.. it shows from koso slim voltmeter.. (didnt connect all the headlights, only 2 small dimmed lights)

    tried reconnect the headlight backed but only 1 side lowbeam.. the charging shows 12.8-12.9 on idle.. at 5000-6000rpms.. i get 13.3-13.6v..

    reconnect both headlight (lowbeam).. on idle it shows very low charging 11.5-11.9.. and will never recharging to high voltage... runs it at 5000-6000rpms and above.. it charged to 12.3-12.6 only.. once stopped at the traffic light.. the battery slowly drops back to low voltage 11.5-11.8v from 12.4++v.. (wondering what is gonna happens if the fan kicked in as well on the same time :'( )

    why it didnt charge on idle even the battery became so weak and does it normal with compufire rectifier???

  2. #617
    apriliaforum expert kzmille's Avatar
    Join Date
    Jul 2003
    Location
    North Florida
    Posts
    18,251
    I would say it is definitely not normal. Something wrong somewhere.
    This is America. Use your turn signals or WE WILL KILL YOU

  3. #618
    apriliaforum Junkie
    Join Date
    Jul 2014
    Location
    Earth
    Posts
    483
    or.. the rectifier is not working?

  4. #619
    apriliaforum expert Reubens32's Avatar
    Join Date
    Dec 2004
    Location
    Little Elm, Texas
    Posts
    813
    Quote Originally Posted by Kamm Matt View Post
    or.. the rectifier is not working?
    How about reinstalling the original REC and measuring voltage again from the battery at idle?
    2017 Husky FC350
    2016 Yamaha R1-M
    2014 Harley Road King Classic
    2012 Honda VFR1200F
    2010 RSV4 Factory (France's ex) on Misano MotoXP Ricambi race bodywork - Drop dead gorgeous!
    SOLD to Brian - 2004 RSV1060R Red & Silver, Ohlins 30mm Cartridge, Ohlins rear w/ Forged Wheels. Amauri built & maintained.

  5. #620
    apriliaforum Junkie
    Join Date
    Jul 2014
    Location
    Earth
    Posts
    483
    Quote Originally Posted by Reubens32 View Post
    How about reinstalling the original REC and measuring voltage again from the battery at idle?
    yup im thinking the same too.. will remove the solder and try reconnecting oem rectifire back..

  6. #621
    apriliaforum expert Reubens32's Avatar
    Join Date
    Dec 2004
    Location
    Little Elm, Texas
    Posts
    813
    Quote Originally Posted by Kamm Matt View Post
    yup im thinking the same too.. will remove the solder and try reconnecting oem rectifire back..
    Gotta warn ya' buddy... there's a good chance that it isn't the REC. :/
    2017 Husky FC350
    2016 Yamaha R1-M
    2014 Harley Road King Classic
    2012 Honda VFR1200F
    2010 RSV4 Factory (France's ex) on Misano MotoXP Ricambi race bodywork - Drop dead gorgeous!
    SOLD to Brian - 2004 RSV1060R Red & Silver, Ohlins 30mm Cartridge, Ohlins rear w/ Forged Wheels. Amauri built & maintained.

  7. #622
    apriliaforum expert steelman_2's Avatar
    Join Date
    Sep 2012
    Location
    Finland
    Posts
    919
    I did have a case that the quite new rectifier was blown, put the orig. back and it did run as should.

    In total this charging problem is easily solved I think, just few steps:

    - get rid of original wires and rectifier

    - buy a new well functioning rec

    - install it as near to battery as you can

    Name:  Retrifier install.jpg
Views: 249
Size:  38.9 KB

    Name:  Retifier install 3.jpg
Views: 251
Size:  26.6 KB


    - do new a hint thicker cables and straight cables to battery

    - have an extra generator in your pocket in case the original blows ( also new gasket to be ready for swap)
    Last edited by steelman_2; 08-03-2016 at 11:32 PM.
    I'm a (triathlo)nist, that's why I've joined A(prilia) & A(udi) club.

  8. #623
    apriliaforum Junkie
    Join Date
    Jul 2014
    Location
    Earth
    Posts
    483
    will try refit back the oem REC.. will see how it going..


    but before do that.. is there any method that we can check the rectifier either it is working or not? using multimeter especially for 3phase REC

  9. #624
    apriliaforum newb
    Join Date
    Jun 2016
    Location
    Brisbane, Australia
    Posts
    6
    I have found this to be an easy guide to follow to check the R/R.

    http://www.electrosport.com/technica...ting-guide.pdf

Page 42 of 42 FirstFirst ... 32404142

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •