• Futura and Caponord dash repair

    So....... Most of us know about the issues that some have had with their instrument cluster going dead. Some have had it happen while riding while others have had it happen after changing the battery, pulling the dash, etc...... My cluster recently took a crap on me after pulling it just to do a headlight bulb change. I pulled the connectors, changed the bulb, and the dash never came back on after I plugged it back in with the exception of the oil pressure, kickstand, and neutral lights. Every other function, including the backlights, were dead as hell. No speedo, no tach, no readouts at all. Incidentally, my dash was replaced under warranty while the original owner had it.........

    Anyways, since I head up a rather large electronics repair facility and have dealt with electronics for over 20 years, I figured that I would be better off taking a look to see if I could figure out WTF was wrong. I mean, what's the worse that could happen? I guess I could screw up something that was already broke....... Screw it, I'm going in!

    Before I go any further, I have to add an additional thanks to CapoGrandad, another Aprilia owner with the knowledge to check it out, and Joe, a guy that works for me. Without these two guy's assistance, I would not have gotten this solved as fast as I did!

    Here we go!

    Pulling the dash itself is easy: Remove the fluse cover, dash side panels, you know, those ones that fill in the space around the fairings and dash, and two bolts hold the cluster in place. Once those bolts are removed, it is easiest to move the panel to the right for access to the two connectors on the back. Remove those connectors and pull the dash out.

    Pulling the dash apart is not too bad either...... There are retainer tabs around the perimeter of the housing that you can easily unclip and pull the two housing halves apart. From there, it gets a bit more difficult. I found that I could NOT get the speedo and tach needles off the drive pins. I pulled them about as hard as I dared, but they would not come off, so I ended up using an exacto knife to carefully cut them off. This is required in order to gain access to the actual circuit board. A couple other guys have said they had no problems pulling the needles off, but mine were stuck on there good! Once you either pry the needles off, or cut them off, you can carefully pull the retainer tabs away from the board housing to release the circuit board and get to the goodies!

    Here is a pic of the whole circuit board. I never took any pics of the board before doing any repairs, so try to ignore those wires up towards the top right now. We'll get to those soon enough......

    Next we have a couple pics of the connector pin out diagrams.......

    Wiring harness side.........

    Cluster side.........

    I should note that once you have the circuit board out and if you have access to a multimeter, you can hook it back up to the bike for some additional tests. I used a power supply for my tests, but you CAN do it on the bike with the key on. The biggest thing you need to look for is applied voltage to a couple different places. With the multimeter connected to ground, you can check to ensure that you are getting voltage to the board by checking the 12V+ locations on the connector, then check at the bottom side of the zener diode where you should see 12V, and finally, on pin 19 on the IC chip. At all locations you should see 12VDC. If you have 12VDC at the Zener Diode, but not at the IC chip, then the fault is more than likely a bad solder connection under the large capacitor. You can check this as well by check for voltage on the back side of the board where the capacitor is soldered on. Check from ground to the bottom solder joint for the capacitor and you should see 12vdc. (It goes without saying that these tests need to be done with the key ON!)What is happening is that the top side of the feed through does not have any solder on the feed paths on the top of the board. This is causing the capacitor to loose the connection to the output of the Zener Diode so the IC chip that is the voltage regulator is not receiving any power.

    In this pic, it shows the Capaciter (marked) and Zener Diode. (To the right of the capacitor.) The Zener Diode test point is the lower solder joint on the diode.

    This next pic shows the back side of the board where the capacitor is soldered. The lower solder joint is your test point.

    Once you determine that this is your problem, there are three ways to fix it, one which works, but bypasses the capacitor (Not recommended), one does not require removal of the capacitor, and one that is the technically "correct" way to fix it.

    1: You can run bypass wires from the Zener Diode to Pin 19 on the IC chip.

    This pic shows the wires going from the Zener Diode to both the IC chip, Pin 19, and the capacitor. I took the cap out for this pic to show things a bit more clear:

    2: You can run a feed wire from the Zener Diode to the back side of the board to the lower solder point of the capacitor. This eliminates the need to pull the capacitor and works just as well. THIS IS THE METHOD I USE WHEN I REPAIR THESE DASHES.

    This one shows the Zener Diode soldering point:

    And the back side soldering point for the wire:

    3: You can pull the capacitor (being careful to note which pin is in which hole) apply solder to the mounting pad, and then replace the capacitor and then check your voltages again. I did this the first time I repaired mine, and it quit again a few thousand miles down the road.... This is when I went back to solution #2

    This pic shows the clean mounting pads on the upper side of the board which is the cause of this problem to begin with. To fix, use a soldering iron to apply solder to these pads before reinstalling the capacitor:

    Here is a microscope view of the capacitor mounting pads. You can easily see that there is NO solder to make a connection:

    This is a pic of the micro miniture soldering station I used for these repairs, but you can do it with a low heat soldering iron without too much trouble.

    I checked all three methods and they ALL work, but the easiest and fastest is #2.

    Once you are getting lights on the board again, you can put everything back together and keep on rocking! For those that have to cut their needles off, I used JB Kwik Weld after making sure I had everything oriented right and it works with no problems!

    DISCLAIMER! This may NOT fix your cluster. You may have other issues or you may screw it up worse! If you want, you can send them to me and I can fix it, or, armed with this thread and pics, get someone else to fix it, but play at your own risk here!
    This article was originally published in forum thread: Futura and Caponord dash repair started by meanstrk View original post
    Comments 5 Comments
    1. kingvolcano's Avatar
      kingvolcano -
      Great job, thank you!
    1. urbanimage's Avatar
      urbanimage -
      Quote Originally Posted by kingvolcano View Post
      Great job, thank you!
      Anyone help the dash on my 2004 futura is working fine when the bike is cold but after 2-3 miles go's dead returns next morning when cold again?
    1. Cris215's Avatar
      Cris215 -
      When I had my dash messed up I sent it in to Carmo USA. Honestly I tried fixing it myself but chickened out since I didn't want to mess with it. So I sent it in and they did a great job in fixing it. Hopefully this helps someone!

    1. davethedanger's Avatar
      davethedanger -
      old bmw k bikes had similar probs
    1. Motorcop44's Avatar
      Motorcop44 -
      Hello sir, my 01 Futura's dash is acting up. Speedo/tach, etc not working most of the time but will come back on for brief periods. Sounds like what you've described in you article. Are you still repairing them? Could I send it out your way?
  • Facebook