PDA

View Full Version : [MOVED] jammed fuel pump



farmerwardy
12-15-2002, 07:34 AM
my ditech was left standing still for 4 months due to damages and when i got it fixed it wouldn't start.the bloke at the shop said it was a jammed fuel pump and he cleaned it out then it ran fine for a day or two then it wouldn't start again now when i switch it on the injection check doesnt even buzz like normal.has this happened to anyone else and any ideas on how to fix it without having to buy a new pump?

DITECH rider
12-15-2002, 08:56 AM
HEY!!!! That could be the reason why my SR50 DITECH stops runing while i'm driving.
Wel i'l hear it from the dealer thuesday.
Luckely it won't cost me anything because it's a new scooter i have it 5 days now.

HogaSR50LC
12-20-2002, 04:56 AM
I had the same problem with my DiTech, contact me on ICQ and i will explain to you step by step how to fix the problem.

my icq # 178112425

DarlaM
03-12-2003, 08:57 PM
I would like to see what you did as my scooter keeps dying after riding it a short way.
Thanks DarlaM

lgcivttu
02-09-2006, 03:01 PM
I had the same problem with my DiTech, contact me on ICQ and i will explain to you step by step how to fix the problem.

my icq # 178112425

Mine is jammed too! I just took it out after it stopped pumping fuel.

Trushna
02-09-2006, 03:14 PM
...................................... wrong forum

p700
02-09-2006, 04:02 PM
I thought I was the only one. Mine "buzzes" and starts relatively fine. At top speed frequently it looses power briefly, then comes right back, and sometimes, during acceleration it looses power and I have to get right off the throttle, then back on for it to come back to life.

p700
02-09-2006, 04:02 PM
I had the same problem with my DiTech, contact me on ICQ and i will explain to you step by step how to fix the problem.

my icq # 178112425

I don't ICQ - can you PM me.

RS_Patrick
02-09-2006, 08:24 PM
Did you guys ever notice theres a whole section for DiTech problems right here: http://www.apriliaforum.com/forums/forumdisplay.php?f=37

WRONG FORUM :WTF: like someone already mentioned.
think you get way more awnsers in there.

DRT-Tuning
02-10-2006, 03:15 AM
That's the problem with people these days. They're so impatient...of the topicstarter had looked around for 10 more seconds.....

[MOVED]

adomke
07-20-2007, 03:34 PM
We don't have an ICQ and have no idea what it is I was wondering if someone could post back on how to help us fix the jammed fuel pump.

.::sTocKSr5O::.
07-21-2007, 02:42 AM
What a coincidence this thread should come up!

I noticed today that something strange is going on with my acceleration in the sense that it goes full power, then backs off ever so slightly, then powers up again.

This thread may have something to do with my symptoms. I ran out of fuel on Friday (empty) morning on my way to work. Four days with the Yellow Fuel light on (I pushed it I know :)) so it sounded like it was missing before it ran out... anyway, filled it up with some Shell 95 (servo only 30 metres from where I stopped). So far so good. The 95 is just as good as the 98 I've been using IMHO. But on my way home I noticed my acceleration was varying. Not really noticeable, but it is there. I wonder if I may have damaged my fuel pump because I rode the scoot when it was literally running on vapour!

So does anyone know if running the tank so low may indeed damage the fuel pump???

THE MAX
07-21-2007, 04:17 AM
Prob just air in your fuel system ..........

-Bzzzzzzzzzzzzzzzz a few times (contact on / off)

Or take the pump out the rubber/bracket and shake with it,while you bzzzzzz it