PDA

View Full Version : Help please!!



marksx125
05-31-2015, 06:05 PM
Hi all new to the forum and could do with some help, I've recently purchased a aprilia sx 125 full power, it has, full arrow system, vforce 3 reed block and been rejetted, it runs good but when I hit power band sometimes it sort of splutters and tops out anybody know what the problem is? Been told I may need a iridium plug and go one hotter? due to being tuned. And I've also read about people having the rs 125 which is the same engine and easily getting 90/100 MPH and mine pinned red lines in 6th at 73MPH?? Any help would be much appreciated.

ApriliaMX125
06-01-2015, 06:08 PM
Does it have the 34mil carb? And as for the splutter if its a midrange problem try adjusting your needle.

also make sure your powervalves clean and not blocked up with carbon, i had a similar problem i found a ram air filter sorted my splutter but drowns out the sound of the exhaust..

Chooky12345
06-06-2015, 01:03 AM
I would be trying the plug first. Its a quick easy change. What plug is in it at the moment?????????.
As for the speed difference what sprockets are you running??????

bassturbin
06-06-2015, 06:54 AM
Absolutely nothing to do with the spark plug!Never put hot plug this is dangerous for engine and piston!

First check to power valve, if run power valve after you can direct the other problems. If your main jet number big from 130 you need to put br10XX spark plug, Br10 from cold plugs because no other big number.

Whats your carburetor type?