PDA

View Full Version : Evotech tail tidy install problem



ducman999
10-26-2013, 12:31 PM
I must be some kind o dumb ass or something but I can not find any possible way to mount the seat lock on this tail tidy. Help!! No hole facing down on it anywhere I can see as is stated in others post.

ducman999
10-26-2013, 04:53 PM
Figured it out. Was missing a bracket that I just located!

mc18
10-26-2013, 10:23 PM
It takes a lot of tweaking to get the seat lock to work right. Even then it's not like stock set up. Or maybe it is just me.

Mr.Dorso
10-27-2013, 05:44 PM
agree, i had to bend some things so the cable would pull the latch right. Once the tweaking is done it works good.

BYRDMAN
10-27-2013, 08:10 PM
If u elbow the seat right above where the latch is its should latch everytime...

Styrofoam
11-04-2013, 07:45 PM
I had the same problems with my install of the evo tech tail. No matter what i did the seat would come unlocked / pop up. Trying different routing of the cable and modify cable latch at hook. Nothing worked the latch was poping out . What i finality did was space up the lock latch. I added two 1/4" standard flat washer under the seat lock assembly some blue lock tight re-bolted. works great and the key is EZ to turn with less pull on the latch. The seat in not tight and now has the some play from the thickness of the washer. Hope this helps.

lanter
11-04-2013, 10:15 PM
Place 1/8" nylon washers under the locking mechanism. That will stop the seat popping up.

Styrofoam
11-05-2013, 05:40 PM
Forgot to mention that i also spaced out the tail section too. Did not like the look of the maker light rubbing on the tail pipe heat guards. I added washer right on top of the steel spaces. As you know lining up all the parts and wires sucks. So to help i used some krazy glue on the washers to the steel spacers. Let it dry and reinstall.