PDA

View Full Version : Help! Cutting out and no power



Mr.Dorso
05-08-2013, 01:41 AM
I took the dorso out for a short ride today and she is surging and is cutting out at traffic lightsor if I leave it to idle. There is also no power or very soggy power above 4000rpm..

:mad:

I was thinking it's an electrical issue.. Last ride was around a week ago and all was good

Got her booked in to be looked at tomorrow by Aprilia service tech's.

Mr.Dorso
05-09-2013, 08:16 PM
Still in the shop :/ they need to remove the tank to get too all 4 plugs and change them, they replaced the two easy access one's and man were they black!! Hoping to get it back today but they are not sure due to other jobs.. Agghhhh Just under 10k on it and this is happening...

lanter
05-09-2013, 09:57 PM
Let us know how you make out.

Micah / AF1 Racing
05-12-2013, 09:52 AM
One of the MAP sensors is probably faulty, also check the ATM or ambient pressure sensor readings.

Mr.Dorso
05-12-2013, 09:43 PM
Thanks Micah, still there and don't think they have found the issue yet

Mr.Dorso
05-15-2013, 10:25 PM
Just got the call, after working on it all yesterday and this morning, they have found the o2 sensor faulty, need to submit warranty claim and wait for part to come in.... :mad:

lewispaulsmith
05-18-2013, 12:15 PM
my dorso 12 has a miss firein problem. iv changed all 4 plugs. its had the new map downloaded and its still a bag of shit. 3 months old and on 2k on the clock. # heap!. however the new map seam to be muchhhhhh better. apparently problem could be the exhaust lamba sensor so waitin for that now yawn!

Mr.Dorso
05-21-2013, 05:44 PM
coming onto 2 weeks now and still waiting!! told yesterday they found the fly-by-wire to be faulty also... waiting for parts, still......

and i'm being told i might have to pay for labour... anyone else had a warranty claim/issue and they had to pay for labour?? doesnt seem right..

Mr.Dorso
05-26-2013, 07:51 PM
She's back!! o2 sensor and demand sensor/fly-by-wire were replaced and map updated, not sure to which one though. After the first service and being told the new map was installed i didn't find much improvement, now the bike seems to idle better, is smoother at lower speeds, and seems like it has more punch all round! Looking forward to a good long ride on her to really notice the improvements, so happy to have the dorso back finally!!

Service techs called Aprilia and labour costs + new spark plugs were covered even though they were initially on the invoice, good times

Brinks_2
05-26-2013, 08:05 PM
Another demand sensor issue, at least your up and going now. Rip it up. :)