PDA

View Full Version : Arrow map + stock exhaust = engine lamp lit?! Help needed.



Sweczech
05-22-2012, 02:13 AM
Hi all,

New member but long time reader, thanks for a great forum.

Iím about to purchase the Arrow system and in trying to be proactive so I mapped the bike with the Arrow map (at an authorized ape dealer) last week. The problem is that the engine lamp is now lit up and the bike/engine response feels really bad. According to the mechanic it is the lambda getting the bad readings from the fuel mix and that is why the engine lamp is lit up, due to the Arrow map + stock pipes.

Reading at this forum I have never seen anybody with this problem. All of you running with Arrow map + stock exhaust, are you having any problems and/or is your engine lamp lit?

There were two of us having the same problem so there is a high chance the mechanic did something wrong. The bike feels like it lost 50% of its power now so it is only standing in the garage since I dont dare to ride it.

Thanks
Sweczech

Sweczech
05-22-2012, 04:13 AM
Ok, I’d rather reply to myself after talking to another ape mechanic so people can see this in case they got the same problem.

This is NOT normal, apparently the problem is that the mechanic did not re-calibrate/tech the system after re-mapping the ECU. The bike is in a kind of fail safe mode just for transport to the nearest garage.
The re-mapping will be done at a another ape dealer later, I will send an update on the status once it is done.

Sweczech
05-29-2012, 04:05 AM
Re-mapped and working great. The first mechanic did it wrong.

lanter
05-29-2012, 08:53 AM
Good to here! :cheers: