PDA

View Full Version : Digital Fuel Gauge Problems?



awind
09-19-2002, 12:03 AM
Hi, I'm another Capo newbie in Canberra Australia. On the day I picked up my Capo the amber fuel light began flashing within 15 minutes. I stopped the bike, checked the fuel and re-filled the tank. The digital gauge only registered 50% full. The amber warning light eventually went off. Second day: the fuel gauge reads no fuel at all, and the bike will not start. I try turning the ignition on and off a few times and eventually get a fuel reading, at this point the bike starts. Second week: refill the tank and only reads 3/4 full. The bike had been washed and detailed prior to delivery, but I wouldn't think this would be a problem. Anyone else have similar problems?
What a great bike :-)

CapoNordTodd
09-19-2002, 10:05 AM
There's two things that I can think of that would cause this.

There's an electrical connection under the tank that feeds fuel info to the dash, and there's the connection of the wiring harness to the dash. Either of those could be loose/corroded, but loose connection of the harness to the dash would make other gauges wacky as well.

Obviously, the electrical connector gets a signal from some kind of sensor in the tank, and that sensor could be bad as well.

Good luck!

mnrstrider
11-14-2002, 01:07 AM
i think just about everyone's bike has a little fuel gague quirk, I just go by the light, it should correct it's self over time, I think it might have something to do with a gauge smoothing out electrical thingy, thats why it's doesn't bounce around when riding...