PDA

View Full Version : Need a Little Help



undersea
09-23-2011, 07:57 PM
I have a 2010 Factory in the right side of the head theres a weep hole.there seems to be oil comming for it.theres also a weep hole on the right side of the motor as well but its not as bad.the dealer said they haven't seen this yet as mine was the first one.the bike has 2600 miles on it its stock with a leo vince slip on.they said the weep holes on the sides of the head are for water to excape as thats where the plug hole is.anyone having this problem?if so what was the fix?
thanks.

fastmike
09-24-2011, 12:57 AM
Be a lot easier to get help if you could post up some some pictures of what you are talking about. You may get some more responses and assistance.

klowry
09-25-2011, 10:15 PM
Under
Mine is in for valve cover gasket. It was leaking from the same weep hole.
Diagnosis was rear valve cover gasket leaking around the spark plug and coming out the weep hole for water to run off away from the spark plug. Dealer should be abe to warranty the valve cover and replace.
Karl

undersea
09-26-2011, 04:18 PM
Under
Mine is in for valve cover gasket. It was leaking from the same weep hole.
Diagnosis was rear valve cover gasket leaking around the spark plug and coming out the weep hole for water to run off away from the spark plug. Dealer should be abe to warranty the valve cover and replace.
Karl

thanks I was hoping that it was something easy and I can live with a leaking cover gasket.the bike is going to the dealer in the next week for other warrany work.