PDA

View Full Version : injection light comes on at high revs



sr50_rider
02-24-2004, 02:02 PM
hi , couold anyone explain my query
i was riding back from my collee today in farily heavy rain and i noticed my injection check light came on so i pulled over and turned off the bike for a few minutes . i then started it up and the light was not on then i gave it some revs on the stand and then at hiogh revs the light came back on. my friends dad says it could be water on the ht leads or spark plug. but i am thinking that it could maybe be because i recently installed a leo vinci zx? and help will be gratefully accepted . as i need the bike fixing very quickly for work and college

ditechspain
02-24-2004, 02:39 PM
do a site search for "self test" or "diagnostic" or something similar as there is a self test/diagnostic function on the Ditech and depending on the number of flashes you may have a simple problem or something major. Someone helpfully posted the details sometime in the last few months. I have saved it on the computer but for some reason it will not open. if only Microsoft products were as reliable as a Ditech!

aays888
02-24-2004, 03:48 PM
Here Dude,
try this link.

http://www.aprilialand.com/nuke/html/modules.php?name=News&file=article&sid=237&mode=&order=0&thold=0

sr50_rider
02-24-2004, 04:04 PM
thanx for all the help dudes i rann the diagnostic test and it just did the blink after letyting go of the accelerator and that was it i left the bike to dry and then started it and it was fine but i fear when travelling the 10 miles to college in the morning it may play up aghain

srditech/repsol
02-24-2004, 05:34 PM
man i jus got 20 blinks! the bastards must not have re attached the cables when they fitted my radiator.....also my light goes off after i start the bike..but ive seen a new sr round the corner to me and his one stays on....can someone help?

sr50_rider
02-24-2004, 05:56 PM
hey m8 my light stays on too when i start my bike mine is an 03 model (not purjet i dont think) the haga replica with the 41 on the front. but i am thinking maybe the problem with mine ios that i am on 11000km and i have only had the 500km service loli will hopefully have it booked in for the weekend:banana:

phidauex
02-24-2004, 07:11 PM
I believe the light is supposed to come on when you turn the key, stay on for several seconds while the pump primes, then turn off. The light should always be off while the scooter is running.

Try the self diagnostic thing in the link above, and let us know if you get something.

peace,
sam

Haribolman
02-25-2004, 03:01 AM
I believe the light is supposed to come on when you turn the key, stay on for several seconds while the pump primes, then turn off.

There was a thread about this a little while back. On some ditechs (I think it's the earlier models) the light goes out after the pump primes, on others it stays on until the engine is started.

JRTURBO
02-25-2004, 04:00 AM
Hi there

The injection check light on bikes early bikes would switch off after the pump primed, on bikes after 2002 aprox, or if you had one of the later injection/software maps loaded the check light stays on untill the bike has started.

Regards

Joe Rubido

aays888
02-25-2004, 03:52 PM
>>man i jus got 20 blinks! the bastards must not have re attached the cables when they fitted my radiator.....also my light goes off after i start the bike..but ive seen a new sr round the corner to me and his one stays on....can someone help?<<

Hey srditech/repsol,
when I first tried the test I too got 20 blinks. Anyway I let the test finish and tried it again, and NO blinks at all. And I do the test now weekly. With the light, mine stays on until I start my engine and my bike is a 2002 Ditech.

Anthony.

phidauex
02-25-2004, 05:52 PM
In any case, regardless of year, your injection check light should not be on while the vehicle is running. It should come on while the pump primes, and may or may not stay on until you start the engine. If it doesn't come on ever, then its bulb is burned out. ;)

peace,
sam