Results 1 to 4 of 4

Thread: Stalling while high rpm engine braking

  1. #1
    apriliaforum newb crorsv4f's Avatar
    Join Date
    Jul 2015
    Location
    Croatia
    Posts
    14

    Stalling while high rpm engine braking

    Hi,
    Just bought and install 2012 APRC engine in '09 Factory, check and adjust the valve (only one was little tight), calibrate the throttle bodies.
    While riding at 8000 rpm or higher and release the throttle engine became to stalling, also visible on rev counter!
    Engine has 5500km and in excellent condition, runnig fine, very powerfull while accelerating, idle is stable, no errors!
    TB pressure on vacuum gauge is -260mbar for both front cylinder, and -240mbar for both rear, but the master and slave bypass on each bank are fully closed.
    Any ideas?
    many thanks...

    Gabro Race map,
    Akrapovic silencer

  2. #2
    apriliaforum expert plocky's Avatar
    Join Date
    Oct 2015
    Location
    Tasmania
    Posts
    2,466
    Did you run Handle Self learning?
    Is the ECU from the old engine or new engine?
    2015(16) RSV4 RR Ascari Black 201HP

  3. #3
    apriliaforum newb crorsv4f's Avatar
    Join Date
    Jul 2015
    Location
    Croatia
    Posts
    14
    Yes. I perform throttle and handle learning.
    ECU is from old engine, custom Gabro Race map 13A9AD23, I spoke with Gabro and he told me that it will run fine.

    My concern is about TB, cause they have been previously adjusted on the covered screw between bodies...

  4. #4
    apriliaforum newb crorsv4f's Avatar
    Join Date
    Jul 2015
    Location
    Croatia
    Posts
    14
    Try a few combination of master and slave adjustement, but results is always the same...
    I realise that it is not happening in first and second gear, only third and higher!
    Start thinking that maybe is not the problem in TB...maybe slippery clutch or something!
    Any ideas??

Similar Threads

  1. Engine sputter & stall while riding
    By beatdownpro in forum Pegaso 650 Cube and IE
    Replies: 11
    Last Post: 09-30-2017, 08:02 AM
  2. Engine stuttering (almost stalling) when hard on the brakes?
    By Fangit in forum 2008-2016 Shiver 750 / Dorsoduro 750
    Replies: 7
    Last Post: 06-20-2013, 09:17 AM
  3. engine stall while riding
    By sav in forum SL1000 Falco Forum (all years)
    Replies: 14
    Last Post: 10-28-2007, 08:37 PM
  4. backfiring while "engine braking"
    By ride-red in forum RSV Tuono, Tuono R, Tuono Racing, and Tuono Factory (2002-2005)
    Replies: 34
    Last Post: 09-09-2006, 06:27 PM
  5. High RPM engine failures...
    By keean in forum RS250
    Replies: 1
    Last Post: 09-01-2004, 09:50 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •