Results 1 to 5 of 5

Thread: Sudden dead bike!

  1. #1
    apriliaforum newb
    Join Date
    Apr 2018
    Location
    Worcester
    Posts
    3

    Sudden dead bike!

    Hi guys,
    Looking for pearls of wisdom!
    Im stuck in motorcycle heaven, blue ridge mountains, with a dead 2001 Futura.
    Symtoms as follows:
    After 800 faultless mile ride including major downpours EFI light came on. Noticeable drop off in power. Light went out and all good for about 100 yards! Light back on and bike restarted but high idle and no power. Bike stops, no EFI light but non starter -spins over fine. Starts again but really rough running with no light. EFI light on runs slightly better but dies again. Interrogated fault codes - fault code 1.
    Any thoughts or help gratefully received before bike becomes fishing weight!!

  2. #2
    apriliaforum expert deefred's Avatar
    Join Date
    Sep 2004
    Location
    Sweden, LinkŲping
    Posts
    5,604
    Water in harness maybe.
    Does the fuel pump prime?
    2001 RST Futura in stream Silver.
    Mods: Modified ÷hlins fork from mille R, EBC brake discs, HEL front brakelines, Carbon RS 250 front fender, Wiring mod for charging. Engine related:05 map, Iridium plugs, tuneboy, derestriced intake, old mille airboot, staintunes exhaust. Lambda bung hardbrazed in the "breadbox". ÷hlins mille R rear shock with 110N/mm spring and the integrated hydraulic preload adjuster. LED Voltmeter installed inside the dash for monitoring charging. Duc 999 radial m/c for brake and clutch. EBC 320mm brake discs
    NWS hugger. Equipment: Famsa tankbag,
    CBR 600 -07 MOSFET R&R FH008EE providing stable 14.4 - 14.5 V (with my wiring mod). Daytona heated grips with mccoi pwm controller and automatic chain oiler

  3. #3
    apriliaforum newb
    Join Date
    Apr 2018
    Location
    Worcester
    Posts
    3
    Quote Originally Posted by deefred View Post
    Water in harness maybe.
    Does the fuel pump prime?
    Hi,
    Thanks for the reply and suggestions.
    I couldnít hear the pump, thatís one thing Iím going to check this morning, you donít happen to know which is the fuel pump rely by any chance?
    Ive seen some harness issues on the forum as well so will look there also - maybe a box or two of matches will help drying things out!
    Trying to download manual but not easy to read on phone!
    Wish me luck .....

  4. #4
    apriliaforum expert spesnaz's Avatar
    Join Date
    Mar 2014
    Location
    California
    Posts
    1,292
    Thinking the same thing, the power lead that corrodes in that "u" loop behind the coolant reservoir.

    To check this, you'll need to remove the right middle fairing cover, the air deflector that covers the coolant reservoir, and the coolant reservoir. Just set it aside, it can remain connected. Zip tied to the frame behind the radiator fan, you'll see the large diameter harness in a black PVC tube. Water collects in this tube, it's like the p-trap under your sink drain. make a small cut in this loop at the bottom, and have a look for water ingress. there's a crimp splice in the wiring, and this connection will corrode and break.

    Next thought is the fuel injection relay.

    Do you have a wiring diagram for the Futura?

    Bob

  5. #5
    apriliaforum newb
    Join Date
    Apr 2018
    Location
    Worcester
    Posts
    3
    Thanks guys, managed to get a fault code out of the mis - firing hulk. Code 21 coolant sensor. Have unplugged it for now and bike runs, not perfect but 🤞it keeps going for now! Checked out the loom which was ok.
    Great to know there are people out there with good info - appreciate the input! 👍👍

Similar Threads

  1. Dead bike again!
    By mattym in forum RST1000 Futura (all years)
    Replies: 51
    Last Post: 05-12-2007, 06:54 AM
  2. Seized? Dead Bike?
    By Cavking in forum RS50 Technical
    Replies: 8
    Last Post: 06-15-2005, 12:44 PM
  3. Terrential Rain - Dead bike
    By MrSix in forum RS50 Technical
    Replies: 8
    Last Post: 05-04-2005, 03:47 AM
  4. Dead bike
    By Rutan in forum RSVR and RSVR Factory (2004-2009)
    Replies: 42
    Last Post: 02-25-2005, 09:10 PM
  5. dead bike!!
    By nora2004 in forum RS125 Euro-archive
    Replies: 5
    Last Post: 07-15-2004, 03:12 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •