Results 1 to 3 of 3

Thread: RSV4 no spark, help needed

  1. #1
    apriliaforum newb
    Join Date
    Jan 2018
    Location
    Poland
    Posts
    2

    RSV4 no spark, help needed

    Hello everyone
    I can not start engine in my RSV4. So far I checked spark plugs, ignition coils, relays. There is no spark on any cylinder. But I am not sure if my attempts were corrects.
    First of all, can any one, please, tell me how can I check ignition coils in RSV4? According to service manual I know how to measure it's resistance, but is there any way to check secondary winding?, or can I check coil with spark plug with DC supply?, Coil has 3 pins, 1 - +12V, 2 - ground, 3 - trigger? Am I right?, what resistance should be between 1 and 3? In my coils there is a shortcut between 1 and 3 (around 0ohm)? is it normal?
    Is it possible that all 4 coils are damaged?, it all started when I disassembled engine due to low oil pressure - oil pump was replaced. After that I can not start engine?
    No errors are reported by ECU - checked with Guzzidiag. When starter is activated fuel pump relay is activated too. Connecting LED diode between 1 and 2 I see that LED is blinking - but there is no spark on the plug
    any suggestions are welcome

  2. #2
    apriliaforum Junkie
    Join Date
    Dec 2015
    Location
    DePere, WI
    Posts
    497
    Happen to check all the fuses? If everything else is working as it should then a plug in or clip isn't connected tightly? If your coils we're bad not all four would go bad at the same time....so it tells me theres something else????

  3. #3
    apriliaforum newb
    Join Date
    Jan 2018
    Location
    Poland
    Posts
    2
    All fuses are ok. I also think not all 4 coils broke down at the same time...The question is how to check coils to be sure they are ok?, of course computer can be also damaged, and how can I be sure that ignition module is not faulty (without sending it to electronic service)?

Similar Threads

  1. 2004 rs 50 no spark help please
    By billyslad in forum RS50 Technical
    Replies: 23
    Last Post: 03-02-2017, 01:44 PM
  2. 2003 aprilla sr 50 no spark help
    By Markmaws in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 0
    Last Post: 10-23-2012, 02:54 PM
  3. Touno - DOA, no electrics, help needed
    By djinma in forum RSV Tuono, Tuono R, Tuono Racing, and Tuono Factory (2002-2005)
    Replies: 10
    Last Post: 09-27-2012, 05:03 PM
  4. rz 350 NO SPARK help
    By h1dave in forum RS250
    Replies: 3
    Last Post: 10-30-2009, 09:11 AM
  5. no spark help
    By tim2tone69 in forum USA Forum Member Locator
    Replies: 0
    Last Post: 09-23-2009, 05:56 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •