Results 1 to 9 of 9

Thread: RSVR Gen2 non starter

  1. #1
    apriliaforum newb
    Join Date
    Oct 2017
    Location
    Nottingham
    Posts
    6

    RSVR Gen2 non starter

    Hi I still have a problem with my 2005 RSVR not starting, having fitted new battery,and starter relay,their is nothing when I hit the starter button,but if you short out the starter solenoid it turns over,also the red immobilizer warning light in the top left of the instrument lights is always flashing and have noticed that when you turn ignition on the rev counter needle only goes round to 6000 revs b4 returning to zero is this the norm or is this telling you a fault code ??...any help please ?

  2. #2
    apriliaforum Member
    Join Date
    Jan 2015
    Location
    20 Harwood Place Kingsworthy winchester Hants SO237PS
    Posts
    178
    Hi Del, I tried to send you a pm, but it says you have it turned off.

    Sent from my E5823 using Tapatalk

  3. #3
    apriliaforum expert jess67's Avatar
    Join Date
    Nov 2011
    Location
    sth oz
    Posts
    1,165
    Quote Originally Posted by vergil View Post
    Hi Del, I tried to send you a pm, but it says you have it turned off.


    Sent from my E5823 using Tapatalk
    You cant send or receive pm's with under 10 posts

  4. #4
    just another Aprilia fanatic amauri's Avatar
    Join Date
    Sep 2003
    Location
    Westminster, CA - USA
    Posts
    13,938
    Quote Originally Posted by Del2171 View Post
    having fitted new battery,and starter relay,their is nothing when I hit the starter button
    tip over sensor is up side down
    Never accept mediocrity, always demand competence.

    Certified Aprilia Moto Service in Southern California
    Call me at 714 892-4056 for appointment

  5. #5
    apriliaforum expert theknurl's Avatar
    Join Date
    Mar 2007
    Location
    Palos Verdes Est. SoCal
    Posts
    2,866

    Thumbs up !

    Quote Originally Posted by amauri View Post
    tip over sensor is up side down
    Thanks Amauri

    Noel-theknurl

    The Forum Curmudgeon
    I'm not PC either

    email/PayPal theknurl@yahoo.com
    Skype theknurl
    ph. 310-414-7247 PST, GMT -8

  6. #6
    apriliaforum expert steelman_2's Avatar
    Join Date
    Sep 2012
    Location
    Finland
    Posts
    901
    Yesterday after seeing Amauri's reply I knew he was there ...... again ! Thank God there's Amauri !
    I'm a (triathlo)nist, that's why I've joined A(prilia) & A(udi) club.

  7. #7
    apriliaforum Junkie dfoustou's Avatar
    Join Date
    Aug 2014
    Location
    silver spring
    Posts
    354
    Quote Originally Posted by steelman_2 View Post
    Yesterday after seeing Amauri's reply I knew he was there ...... again ! Thank God there's Amauri !
    +1 !!
    Dionysis

    79 CX500C
    07 RSV1000R
    08 WR250R

    IBA#58777

  8. #8
    apriliaforum newb
    Join Date
    Oct 2017
    Location
    Nottingham
    Posts
    6
    Hi sorry I'm so late getting back to you, thank you for your reply since then I've found out theirs a fault with the immobilizer as the red key light flashes all the time, but am still at a loss what to do, apparently a cheap quick fix is to bypass the immobilizer but am struggling to find anyone with the time to do job,spoke to Aprilia performance in Tamworth but the main man Griff was too busy to help me out , I'm on WhatsApp if its easier to contact me on 07956917054 any help would be greatly appreciated, regards Del

  9. #9
    apriliaforum expert TeddyG's Avatar
    Join Date
    Feb 2012
    Location
    Portland OR
    Posts
    625
    The immobilizer flashing on and off continually is normal- mine is located at the upper right corner of the instrument panel and has a key symbol on it. If it starts w/ the starter solenoid shorted, replace it

Similar Threads

  1. RSVR Gen2 non starter
    By Del2171 in forum RSVR and RSVR Factory (2004-2009)
    Replies: 7
    Last Post: 01-15-2018, 01:18 PM
  2. Non-starter.. please help
    By dmunga in forum RS125 Euro-archive
    Replies: 2
    Last Post: 11-28-2005, 07:33 AM
  3. Non starter!!!!
    By raggyroller in forum RS50 Technical
    Replies: 10
    Last Post: 01-13-2005, 06:25 PM
  4. Non Starter
    By allan F in forum RST1000 Futura (all years)
    Replies: 22
    Last Post: 06-29-2004, 02:26 PM
  5. non starter
    By lynx in forum RS50 Technical
    Replies: 9
    Last Post: 03-14-2004, 12:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •