Results 1 to 3 of 3

Thread: Starter, relay and switch ordered, any tips, tricks or pitfalls you know of?

  1. #1
    apriliaforum Member
    Join Date
    May 2012
    Location
    Cherryville, NC
    Posts
    233

    Question Starter, relay and switch ordered, any tips, tricks or pitfalls you know of?

    I got my upgraded forks put back on my 08 Shiver last week. After everything was back together, I tried to crank her for a quick test ride. The engine would turn over and sound like it was gonna fire but didn't. I tried 2 or 3 times then the starter switch stuck. I pulled it to off then tried to crank it and the starter didn't turn. I just get a click that sounds like it comes from behind the radiator when I hit the switch.

    I put a trickle charger on the battery and tried a few days later. The starter did not turn. I still just get that click.

    The battery is an unknown in this equation, I have not had a chance to have it load tested. If I do need a new battery also, do you guys suggest an AGM or a Lithium? I have had very bad results from a Shorai Lithium battery in my Guzzi but that could just be the Guzzi's fault or my fault, I guess.

    I'm the third owner of the bike and it has just under 18,000 miles on it. So, I went ahead and placed an order from our friends at AF1 Racing for a new starter, relay and starter switch. Do any of you have any tips or tricks to putting these parts on or warnings about easy to screw up things I might come across when installing this stuff?
    2008 Aprilia Shiver
    2007 Moto Guzzi Breva 1100

  2. #2
    apriliaforum prov-nov
    Join Date
    Oct 2017
    Location
    Crawley UK
    Posts
    32
    The click sounds like the solenoid operating. Measure the voltage at the starter when you press the button.

    If you are not getting 12V it is a faulty solenoid. Try shorting across the solenoid to make the starter turn.

    If you are getting 12V the starter motor is faulty. Try tapping it to free it, otherwise dismantle and clean.

    Also check all connections are clean and tight.

  3. #3
    apriliaforum expert Frodo's Avatar
    Join Date
    Jul 2007
    Location
    Kapiti, New Zealand
    Posts
    2,467
    Quote Originally Posted by DJB quad View Post
    The click sounds like the solenoid operating. Measure the voltage at the starter when you press the button.

    If you are not getting 12V it is a faulty solenoid. Try shorting across the solenoid to make the starter turn.

    If you are getting 12V the starter motor is faulty. Try tapping it to free it, otherwise dismantle and clean.

    Also check all connections are clean and tight.
    Good suggestions.
    Frodo
    2015 Shiver
    New Zealand

Similar Threads

  1. Any tips/tricks to installing a center stand on a Shiver?
    By phlip in forum 2008-2016 Shiver 750 / Dorsoduro 750
    Replies: 2
    Last Post: 07-06-2017, 11:57 AM
  2. Tips, Tricks or a How to remove an engine...
    By dastrix in forum 2010-2018 RSV4 - All Variants
    Replies: 22
    Last Post: 02-20-2015, 03:48 PM
  3. What is the uprated starter relay and battery
    By nickodemon in forum SL1000 Falco Forum (all years)
    Replies: 10
    Last Post: 10-27-2012, 09:15 PM
  4. FS: Thermostat, fan temp switch and a starter relay off 2002 Mille
    By Steve Hunt in forum Aprilia Parts and Accessories for Sale / Wanted
    Replies: 0
    Last Post: 09-19-2011, 06:23 PM
  5. Do you know of any S1/S2 Aprilia vids?
    By Olof Eriksson in forum 2006-2011 Aprilia RXV, SXV, MXV 4.5/5.5 V-Twins
    Replies: 12
    Last Post: 07-31-2007, 10:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •