Results 1 to 4 of 4

Thread: Tuono fault code 0231/45 - please help...

  1. #1
    apriliaforum newb
    Join Date
    Dec 2017
    Location
    St Albans, UK
    Posts
    9

    Tuono fault code 0231/45 - please help...

    Hi
    My 2010 Tuono v twin won't start. It turns over, but won't fire up. The diagnostics show error code 0231/45 which I believe is the fuel pump open or disconnected. The fuel pump is not priming as can't hear it, and I've seen a thread on here which said the problem can be a loose connector located next to the battery. I've checked that I was one and all other connectors which appear to be fine. I also checked power is going to the connector next to the battery and it is. The bike has only been ridden half a dozen times in past 12 months, only has 4,000 miles on the clock and it never sees rain. Its never let me down and always starts on the button, even after its been laid up for months during winter. Does anyone have any ideas what it may be?
    Last edited by Squeak; 12-03-2017 at 04:58 PM.

  2. #2
    apriliaforum expert jess67's Avatar
    Join Date
    Nov 2011
    Location
    sth oz
    Posts
    1,009
    Did you chase the wire from the fuel pump to that white 2 pin connector? If you wiggle the connector with the ignition on, still nothing but there is power coming in to the plug? There have been cases of the fuel pump harness failing - check around where it enters the baseplate. Other than that the pump may have failed. Not a common issue but it can happen. If you want help with getting the pump out let us know.

  3. #3
    apriliaforum newb
    Join Date
    Dec 2017
    Location
    St Albans, UK
    Posts
    9
    Hi
    Yes I checked the fuel pump connector located next to the battery and there was power coming to it, but I haven't checked from connector to and around baseplate, but will do now, thanks. If that seems fine is it worth removing the pump and checking that?

  4. #4
    apriliaforum expert jess67's Avatar
    Join Date
    Nov 2011
    Location
    sth oz
    Posts
    1,009
    Yeh next step would be to pull the pump. There are plenty of threads regarding this with lots of info. I haven't had to change a pump but I have had it out to renew the fuel lines and the filter. For all the effort of just doing the pump its probably worth doing this also. Check the Cheaper Alternative Parts lists for cheaper than OEM pumps and filters. If you change the fuel lines only use quality submersible line.

Similar Threads

  1. Fault codes help please
    By 4motion2006 in forum RSVR and RSVR Factory (2004-2009)
    Replies: 3
    Last Post: 04-27-2017, 04:21 PM
  2. Fault Code Help please
    By Danfinarch in forum 2010-2017 RSV4 - All Variants
    Replies: 5
    Last Post: 04-16-2015, 04:56 PM
  3. Help with Fault Codes
    By dam718 in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 19
    Last Post: 03-30-2006, 05:52 AM
  4. Fault Codes Help Please
    By allan F in forum RST1000 Futura (all years)
    Replies: 21
    Last Post: 07-24-2004, 02:25 AM
  5. problem with tuono please help.
    By OchoRDR in forum RSV Tuono, Tuono R, Tuono Racing, and Tuono Factory (2002-2005)
    Replies: 3
    Last Post: 04-27-2004, 08:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •