Results 1 to 3 of 3

Thread: New 2015 Piaggio Typhoon (50cc) Lost power today at mile 250

  1. #1
    apriliaforum newb
    Join Date
    Aug 2017
    Location
    Orlando, FL
    Posts
    3

    New 2015 Piaggio Typhoon (50cc) Lost power today at mile 250

    I bought a new 2015 Piaggio Typhoon (49c) for my daily commute. It was an upgrade in a lot of ways from my previous scooter, and it's been running great since I bought it a couple weeks ago.

    Today, it lost power about 5 minutes from my house during my morning commute. It has 253 miles on it, bought new from dealer.

    Besides being incredibly pissed off that it died before the break in period was over, I'm wondering what could have happened. I'm only on my third tank of gas and I only fill up using the highest octane gas the stations sell. I was at WOT when I lost power, which wasn't the engine immediately dying, but essentially it felt as though an engine break had been engaged. Immediately afterword, the engine would start, but not accelerate. It would bog and die.

    Thoughts?

  2. #2
    apriliaforum expert
    Join Date
    Jul 2015
    Location
    ontario
    Posts
    875
    take it to the dealer for free shit. keep us posted
    --- diploma for engine repair in 2012 ---

    derbi bullet 2006 - piaggio AC - malossi T.C. half - custom GPS dash - TPR 70CC - topperf crank - vl13 reed and spacer- yamaha rt180 kickstand - giannelli shotV4 - phbg 21mm - doppler mesh top venturi filter

    complete wtp volta bmx 2012 - sanko seamless japanese cromoly heat treated and blue printed frame - 21lbs

    1992 lt250r suzuki quadracer - maier plastics -chromed shearer pipe - chromed works suspension - ++++++++ - 220lbs

    previous vehicles - subaru legacy turbo 1991 - mazda mx6 turbo 1990.

  3. #3
    apriliaforum newb
    Join Date
    Aug 2017
    Location
    Orlando, FL
    Posts
    3
    Small update: Dealer has had the scooter since the 28th. They've taken taken the carb apart three times (that I know of). The problem persists. It will start, run, then die. They are back and forth with Piaggio Tech which has not helped resolve the issue. I've been unable to get a loaner from them, or any hard answers. I'm pretty unimpressed at this point.

    The dealer also either lost/stole my helmet from the underseat storage, or the tow company did. So there's that.

    This sucks.

Similar Threads

  1. SXV 5.5 Lost All Power Today
    By Djaniero in forum 2006-2011 Aprilia RXV, SXV, MXV 4.5/5.5 V-Twins
    Replies: 14
    Last Post: 02-19-2016, 01:57 PM
  2. 2005 Piaggio Typhoon 50cc Need some help
    By viktorpatsan in forum Scarabeo 50, SR50, Mojito 50, Rally, Fly 50
    Replies: 1
    Last Post: 07-24-2013, 05:10 PM
  3. Piaggio Typhoon Lost Top End speed...
    By redman412 in forum Scarabeo 50, SR50, Mojito 50, Rally, Fly 50
    Replies: 8
    Last Post: 10-22-2011, 05:06 AM
  4. Installed New ZX pipe lost power and speed
    By rhino666 in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 35
    Last Post: 06-20-2011, 07:41 AM
  5. Too much POWER! Piaggio Typhoon
    By redman412 in forum Scarabeo 50, SR50, Mojito 50, Rally, Fly 50
    Replies: 6
    Last Post: 10-10-2010, 05:55 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •