Results 1 to 9 of 9

Thread: Aprilia Mojito 2005 not charging

  1. #1
    apriliaforum newb
    Join Date
    Jun 2017
    Location
    Norway
    Posts
    4

    Aprilia Mojito 2005 not charging

    Hello!

    Please excuse my English.

    I have a 2005 Mojito 50cc. The battery will not charge.

    I suspected that the stator or regulator was faulty. I measured about 15V AC in to the regulator when idle and about 47V when I give the engine throttle. This leads me to believe that the regulator is faulty.
    So I ordered a new regulator on ebay. Installed it. But the bike will still not charge the battery.

    Can anyone here think of a reason why??
    Maybe the regulator I ordered is also faulty?

    I tried to measure the DC out of the regulator. But I am not sure witch of the 6 wires are what. I got 11.8 V DC at some point there.

    Please help

  2. #2
    apriliaforum expert
    Join Date
    Jul 2015
    Location
    ontario
    Posts
    861
    test the battery then start it up and test the battery again.

    - running the bike should make 14v.
    Last edited by sublunacy; 06-04-2017 at 01:45 PM.
    --- diploma for engine repair in 2012 ---

    derbi bullet 2006 - piaggio AC - malossi T.C. half - custom GPS dash - TPR 70CC - topperf crank - vl13 reed and spacer- yamaha rt180 kickstand - giannelli shotV4 - phbg 21mm - doppler mesh top venturi filter

    complete wtp volta bmx 2012 - sanko seamless japanese cromoly heat treated and blue printed frame - 21lbs

    1992 lt250r suzuki quadracer - maier plastics -chromed shearer pipe - chromed works suspension - ++++++++ - 220lbs

    previous vehicles - subaru legacy turbo 1991 - mazda mx6 turbo 1990.

  3. #3
    apriliaforum newb
    Join Date
    Jun 2017
    Location
    Norway
    Posts
    4
    Hi!
    Thank you for the reply.

    I have fully charged the battery with a charger.
    When I test the battery with a meter it shows about 12.4V

  4. #4
    apriliaforum expert
    Join Date
    Jul 2015
    Location
    ontario
    Posts
    861
    sounds like you need a new battery. tie them down or they will not last more than a year. the plates crumble since its a high discharge type battery.

    --
    ttyl
    --- diploma for engine repair in 2012 ---

    derbi bullet 2006 - piaggio AC - malossi T.C. half - custom GPS dash - TPR 70CC - topperf crank - vl13 reed and spacer- yamaha rt180 kickstand - giannelli shotV4 - phbg 21mm - doppler mesh top venturi filter

    complete wtp volta bmx 2012 - sanko seamless japanese cromoly heat treated and blue printed frame - 21lbs

    1992 lt250r suzuki quadracer - maier plastics -chromed shearer pipe - chromed works suspension - ++++++++ - 220lbs

    previous vehicles - subaru legacy turbo 1991 - mazda mx6 turbo 1990.

  5. #5
    apriliaforum newb
    Join Date
    Jun 2017
    Location
    Norway
    Posts
    4
    Quote Originally Posted by sublunacy View Post
    sounds like you need a new battery. tie them down or they will not last more than a year. the plates crumble since its a high discharge type battery.

    --
    ttyl
    The battery is brand new

  6. #6
    apriliaforum expert
    Join Date
    Jul 2015
    Location
    ontario
    Posts
    861
    Quote Originally Posted by tangosierra View Post
    The battery is brand new
    so it will turn over and start. but the battery goes dead after maybe 30 minutes of driving?

    when its running the the battery should read 14v. if the battery is not getting 14v then the stator needs to be tested.
    --- diploma for engine repair in 2012 ---

    derbi bullet 2006 - piaggio AC - malossi T.C. half - custom GPS dash - TPR 70CC - topperf crank - vl13 reed and spacer- yamaha rt180 kickstand - giannelli shotV4 - phbg 21mm - doppler mesh top venturi filter

    complete wtp volta bmx 2012 - sanko seamless japanese cromoly heat treated and blue printed frame - 21lbs

    1992 lt250r suzuki quadracer - maier plastics -chromed shearer pipe - chromed works suspension - ++++++++ - 220lbs

    previous vehicles - subaru legacy turbo 1991 - mazda mx6 turbo 1990.

  7. #7
    apriliaforum newb
    Join Date
    Jun 2017
    Location
    Norway
    Posts
    4
    Quote Originally Posted by sublunacy View Post
    so it will turn over and start. but the battery goes dead after maybe 30 minutes of driving?

    when its running the the battery should read 14v. if the battery is not getting 14v then the stator needs to be tested.
    When I throttle/give gas, the battery has about 12V

    I have also tested the stator with multimeter. It gives bestven 14 and 45V AC, depending on throotle. That means the stator works, yes?

  8. #8
    apriliaforum expert
    Join Date
    Jul 2015
    Location
    ontario
    Posts
    861
    test the stator for leaks to ground and test the resistance if you want to check it. busted cdi/regulators can kill the stator.
    --- diploma for engine repair in 2012 ---

    derbi bullet 2006 - piaggio AC - malossi T.C. half - custom GPS dash - TPR 70CC - topperf crank - vl13 reed and spacer- yamaha rt180 kickstand - giannelli shotV4 - phbg 21mm - doppler mesh top venturi filter

    complete wtp volta bmx 2012 - sanko seamless japanese cromoly heat treated and blue printed frame - 21lbs

    1992 lt250r suzuki quadracer - maier plastics -chromed shearer pipe - chromed works suspension - ++++++++ - 220lbs

    previous vehicles - subaru legacy turbo 1991 - mazda mx6 turbo 1990.

  9. #9
    apriliaforum expert
    Join Date
    Jul 2015
    Location
    ontario
    Posts
    861
    i am pretty confused about your problem. i mean there is nothing else to check that i can think of.

    --
    have you maybe shorted it out backwards at the battery? thats all that comes to mind. just a touch is all it takes i think.
    --- diploma for engine repair in 2012 ---

    derbi bullet 2006 - piaggio AC - malossi T.C. half - custom GPS dash - TPR 70CC - topperf crank - vl13 reed and spacer- yamaha rt180 kickstand - giannelli shotV4 - phbg 21mm - doppler mesh top venturi filter

    complete wtp volta bmx 2012 - sanko seamless japanese cromoly heat treated and blue printed frame - 21lbs

    1992 lt250r suzuki quadracer - maier plastics -chromed shearer pipe - chromed works suspension - ++++++++ - 220lbs

    previous vehicles - subaru legacy turbo 1991 - mazda mx6 turbo 1990.

Similar Threads

  1. Aprilia SR50 R carb not charging the battery
    By Stakksund in forum Scarabeo 50, SR50, Mojito 50, Rally, Fly 50
    Replies: 0
    Last Post: 07-05-2015, 12:31 PM
  2. Replies: 1
    Last Post: 12-10-2004, 03:02 PM
  3. Battery not charging - PV not working either
    By JaMMer in forum RS125 Euro-archive
    Replies: 13
    Last Post: 02-21-2004, 07:34 AM
  4. Battery not charging nor rave unit working
    By JaMMer in forum RS125 Euro-archive
    Replies: 9
    Last Post: 02-09-2004, 10:31 AM
  5. Rossi to Aprilia for 2005?
    By Spence in forum RST1000 Futura (all years)
    Replies: 2
    Last Post: 11-02-2003, 11:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •