Results 1 to 4 of 4

Thread: Cant get starter motor to work

  1. #1
    apriliaforum newb
    Join Date
    May 2009
    Posts
    14

    Cant get starter motor to work

    Hi All,

    I have a problem trying to get a starter motor to work on a 1998 SR50LC.

    I carried out continuity testing of all wires on from the switches down to the first plug, then to the relay and from the relay to the motor and all wires are working and in tact.

    I then tried a new starter motor, still nothing and just to be sure changed the relay.

    However, still no turning over of the motor. I can hear the relay 'clicking' but that's as far as it goes.

    At the moment I have the loom on the bike and the switches connected, don't think im missing any of the circuit that isn't connected.

    Only wiring bits not connected are the indicators, rear light assembly and the headlights...

    Click image for larger version. 

Name:	IMG_6590.jpg 
Views:	8 
Size:	501.8 KB 
ID:	327405

    Click image for larger version. 

Name:	IMG_6591.jpg 
Views:	9 
Size:	503.9 KB 
ID:	327406
    Last edited by ryanwylie; 02-25-2017 at 03:11 PM.

  2. #2
    apriliaforum Junkie 2Strokesforlife's Avatar
    Join Date
    Aug 2016
    Location
    Jenison, Michigan
    Posts
    360
    Sorry for the delayed response, I'm kinda at a loss with this one. I would make sure that all the connectors are plugged into where they belong and that the lights are all plugged in as well.
    2009 SR 50 Factory
    Malossi 70cc BBK
    Malossi HPC Crankshaft
    Stage6 Waterpump Impeller
    Arrow Extreme Pipe
    Malossi VL 13
    Ecu De-restricted 2.8.0
    7 Gram Dr. Pulley Sliders
    Stage6 Soft Contra Spring
    Water Trap
    RS 24/10
    Stage6 260mm Front Brake
    Stage6 Torque Control MKII 107mm
    Stage6 R/T Clutch Bell 460g
    Malossi Special Belt
    Malossi E5 Air Filter
    Stock Gears Installed

  3. #3
    apriliaforum expert
    Join Date
    Jul 2015
    Location
    ontario
    Posts
    865
    if it clicks then your half way there.

    what about the big ground wire that bolts to the starter - is it ok?

    ---
    also these little 4lbs batteries do not last more than a year or two. can you confirm it is at full 14v not 12v wich would indicate a battery not holding full charge.

    ---
    i just see wires so whats the deal? is it a project fixer upper or are you really knee deep in a mess? whats up?
    --- diploma for engine repair in 2012 ---

    derbi bullet 2006 - piaggio AC - malossi T.C. half - custom GPS dash - TPR 70CC - topperf crank - vl13 reed and spacer- yamaha rt180 kickstand - giannelli shotV4 - phbg 21mm - doppler mesh top venturi filter

    complete wtp volta bmx 2012 - sanko seamless japanese cromoly heat treated and blue printed frame - 21lbs

    1992 lt250r suzuki quadracer - maier plastics -chromed shearer pipe - chromed works suspension - ++++++++ - 220lbs

    previous vehicles - subaru legacy turbo 1991 - mazda mx6 turbo 1990.

  4. #4
    apriliaforum Junkie 2Strokesforlife's Avatar
    Join Date
    Aug 2016
    Location
    Jenison, Michigan
    Posts
    360
    There's usually a safety feature where at least one of the brakes have to be pulled to start the bike. If the brake lights and other connectors aren't hooked up, it may not be able to complete that circuit.
    2009 SR 50 Factory
    Malossi 70cc BBK
    Malossi HPC Crankshaft
    Stage6 Waterpump Impeller
    Arrow Extreme Pipe
    Malossi VL 13
    Ecu De-restricted 2.8.0
    7 Gram Dr. Pulley Sliders
    Stage6 Soft Contra Spring
    Water Trap
    RS 24/10
    Stage6 260mm Front Brake
    Stage6 Torque Control MKII 107mm
    Stage6 R/T Clutch Bell 460g
    Malossi Special Belt
    Malossi E5 Air Filter
    Stock Gears Installed

Similar Threads

  1. starter motor wont work
    By jack harley in forum RS50 Technical
    Replies: 6
    Last Post: 03-13-2016, 06:47 PM
  2. Can't get rear brake to work!! Help!!!
    By ginchan in forum Aprilia and Piaggio 500cc
    Replies: 4
    Last Post: 09-07-2011, 02:40 PM
  3. Need A Working Starter Motor
    By PRESTIGE in forum RS125 Euro-archive
    Replies: 4
    Last Post: 10-04-2006, 05:09 PM
  4. Any FL owners pitch in to get Sargent something to work with?
    By tonyinva in forum RSVR and RSVR Factory (2004-2009)
    Replies: 3
    Last Post: 09-28-2006, 11:41 PM
  5. figures, first day I ride to work it's got to get windy
    By philip_g in forum SL1000 Falco Forum (all years)
    Replies: 6
    Last Post: 04-15-2006, 02:57 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •