Results 1 to 2 of 2

Thread: Dashboard - no function

  1. #1
    apriliaforum newb Endurance's Avatar
    Join Date
    Nov 2011
    Location
    Burscheid, Germany
    Posts
    24

    Dashboard - no function

    I'm preparing my bike for the next season, new battery, oil etc.
    When I started the engine for the first time, the dashoard had no function
    I hope that I can identify the the root cause.
    I checked the postings and found the hints: "fuse", "wetness" and "self healing".

    I you have got additional tips for me - welcome

  2. #2
    apriliaforum expert BigSteve's Avatar
    Join Date
    Apr 2007
    Location
    Melksham, Wiltshire, UK
    Posts
    7,561
    Have you by any chance disturbed the connectors on the back of the dash or any of the earths when doing the maintenance ...

    (2003 Infinity Blue Capo) - Leo Vince x3 Cans/K&N Air filter/Snorkle-less/Catfish Map/ZX-6R FH016 Mosphet Rectifier/Front Coils re-located/Metal Fuel CRC Fixings/Brown Connector-less/Hyperpro Springs F&R/Rear Hugger/R&G Heated Grips/Krauser Alloy Panniers/Givi G45 Box/BMW GS1150 HandGuards with Touratech Extensions/Kawasaki Z1000 Mirrors/CREE LED's/Wilks Raid Rep Sump Guard & aprilia Crash Bars + Lots of Stickers..

    (2000 RSV Mille Gen 1) Moto GP Rep ..

    (2004 BMW R1150 RT) Bigger touring screen, headlight protector & aftermarket reflective decals ..

    (1990 Kawasaki ZZ-R 1100C1) Remus Innovation S/S Full System, Double Bubble Screen, ZXR750 full lift Carbtops & RenTec rack ..

Similar Threads

  1. Replies: 2
    Last Post: 12-04-2013, 07:06 AM
  2. No Blue Lights on Dashboard
    By Malk in forum RST1000 Futura (all years)
    Replies: 9
    Last Post: 05-27-2013, 06:53 AM
  3. Bike won't start & no lights on dashboard
    By Red 5 in forum Scarabeo 50 Ditech, SR 50 Ditech, SR Factory
    Replies: 19
    Last Post: 03-14-2010, 10:40 AM
  4. NO RPM Function! HELP!
    By canucksAprilia in forum 2006-2011 Aprilia RXV, SXV, MXV 4.5/5.5 V-Twins
    Replies: 3
    Last Post: 05-26-2009, 10:08 AM
  5. No light, no dashboard?
    By FrancoisK in forum SL1000 Falco Forum (all years)
    Replies: 0
    Last Post: 07-21-2006, 12:29 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •