Results 1 to 4 of 4

Thread: RS125 wont run withought choke on???

  1. #1
    apriliaforum newb
    Join Date
    Jun 2012
    Location
    Essex
    Posts
    2

    Unhappy RS125 wont run withought choke on???

    Just rebuilt my rs125 bottom end after oil pump decided to retire early and engine seized at about 70mph scary!!

    Engine has been fully rebuilt but now will only run with the choke on :/ ?????????????

    Please any ideas would be soo much help!!!!!

  2. #2
    apriliaforum expert chrism15's Avatar
    Join Date
    Sep 2011
    Location
    warrington uk
    Posts
    3,200
    big air leak, inlet manifold sealed up level and tight? bit of instant gasket along the joints on reed cage to inlet manifold ect?

    do the spray test:

    take off side panels

    start it up and get it to run with the choke off as much as it will let you

    get a areosol of flammable contents - be sensible about it so dont use "deicer" haha (use WD40/ CARB CLEANER ECT THAT BURNS EASILY BUT WONT HARM THE ENGINE)

    Whilst engine is running spray closly over areas you suspect the engine is drawing unwanted air in

    look in areas like inlet manifold and reed cage, air box rubber (make sure the airbox rubber is tight too!) basically any joints bewteen airbox and crankcase

    if you spray on a area and the revs go up even slightly, or drop slightly then thats what needs sealing up

    for example if you spray on the inlet manifold and the revs go up slightly or down slightly then remove the inlet manifold, clean it slightly with sand paper and apply instant gasket or copper grease and bolt it back on tight and level to make a aior tight seal
    Engine Always Screaming!

    Its Not What You Ride Its How You Ride It

  3. #3
    apriliaforum newb
    Join Date
    Jun 2012
    Location
    Essex
    Posts
    2
    Il give it ago fingers crossed thanx for the help

  4. #4
    apriliaforum expert chrism15's Avatar
    Join Date
    Sep 2011
    Location
    warrington uk
    Posts
    3,200
    carb cleaner is best

    im asssuming you are using stock airbox and have the correct jet for the set up yerr?

    because running a open/k&n/cone/foam air filters and using too small of a jet can create same symtoms as it will draw in LOADS of air
    Engine Always Screaming!

    Its Not What You Ride Its How You Ride It

Similar Threads

  1. Pegaso -96 only runs 10 sec on full choke.
    By maglin in forum Pegaso 650 Cube and IE
    Replies: 4
    Last Post: 04-09-2012, 05:37 AM
  2. Runs better with choke on
    By Reubstaa in forum RS50 Technical
    Replies: 32
    Last Post: 03-30-2012, 03:39 PM
  3. Who runs a slip-on, with a chip, without a chip?
    By BitchMonkey in forum RSV Tuono, Tuono R, Tuono Racing, and Tuono Factory (2002-2005)
    Replies: 3
    Last Post: 06-16-2004, 12:03 PM
  4. Choke on the 24mm Mikuni ???
    By Rendog in forum RS50 Technical
    Replies: 2
    Last Post: 10-03-2003, 03:59 PM
  5. Anyone else run Metzeler Rennsports on the Track???
    By MaXX in forum RSV1000 Mille, Mille R, and Mille SP (1998-2003)
    Replies: 5
    Last Post: 07-23-2003, 09:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •