Page 2 of 4 FirstFirst 1234 LastLast
Results 16 to 30 of 60

Thread: Just bought 70cc SR 50, tuning questions!!

  1. #16
    apriliaforum Member onu123's Avatar
    Join Date
    May 2009
    Location
    Estonia
    Posts
    222
    I'd say this stock exhaust is messing everything up.
    It was a miracle that it ran as it did before.
    Your cylinder & carb DEMAND a good performance exhaust.

    And for the safety of your engine, keep the air-box on all of the time =)
    And the plug being gray or caramel... seems like too much air / too little fuel.

  2. #17
    apriliaforum expert
    Join Date
    May 2008
    Location
    Central California
    Posts
    1,023
    The old plug looked like just the right color. The new plug after the missing was light grey/tan. The needle jet is a W16.

    We tried all sorts of variations. The best moment lasted two short full throttle spanning two blocks each before sputtering again at the mid range. This was with the air screw all the way in, needle all the way in (clip at top) it still felt no stronger than my 50 w/ leo pipe.

    The plug says lean in my opinion but even at a WOT good roll, when I flip the choke on, it starts to bog down. In the past, this to me has always indicated that the main jet was a bit rich (but on the stock 12mm carb).

    I'm thinking we should try a smaller carb if you can find one we can borrow for a little bit and maybe look at that leo vinci exhaust. Swing down to Scuderia and ask the service department, maybe they will have a clue. I'm gonna head down in the morning and ask for pricing on hooking up the computer to my RSV.

  3. #18
    apriliaforum expert
    Join Date
    May 2008
    Location
    Central California
    Posts
    1,023
    There are a few leo vinci exhausts on ebay cheap right now for the 50cc. I wonder if any of them would work....

    Looks like this should fit our application but its for the 50cc bore......... still better than stock. I'd call leo vinci to make sure, they're in Richmond across the bay.
    http://cgi.ebay.com/ebaymotors/LeoVi...Q5fAccessories
    Last edited by KooLaid; 01-17-2011 at 04:02 PM.

  4. #19
    apriliaforum newb
    Join Date
    Jan 2011
    Location
    san francisco
    Posts
    28
    Quote Originally Posted by KooLaid View Post
    There are a few leo vinci exhausts on ebay cheap right now for the 50cc. I wonder if any of them would work....

    Looks like this should fit our application but its for the 50cc bore......... still better than stock. I'd call leo vinci to make sure, they're in Richmond across the bay.
    http://cgi.ebay.com/ebaymotors/LeoVi...Q5fAccessories


    thanks dave! il start looking around too, guess at this point we dont have anything to loose? think im going to get the leo vince big bore tt pipe...

  5. #20
    apriliaforum Member onu123's Avatar
    Join Date
    May 2009
    Location
    Estonia
    Posts
    222
    Well... TT would improve the performace... somewhat... But it's really not the best pipe for your cylinder.

    Maybe you find something more suitable from this list...
    Cheaper ones:
    Tecnigas RS II
    Stage6 PRO
    Gianelli Shot (I'd recommend that or C16)
    Bidalot R
    Bidalot C16 (Bidalot being a cheaper version of Yasuni...)

    More costly ones:
    Yasuni C16
    Polini For Race 3

  6. #21
    apriliaforum newb
    Join Date
    Jan 2011
    Location
    orlando FL
    Posts
    21
    I just finished repairing my 99 sr50. Mine has 70cc BBK, leo vince pipe, 20mm carb and all that is with the stock airbox. Surprisingly my jet size is 80 and pilot jet size is 35. needle clip in the middle. The bike runs like a dream.

    I Hope my setup can give you some clues to fix yours. By the way, I would suggest you use a leak down tester to make sure your crank case is sealed right. Mine wasn't and it ran bad just like yours.

  7. #22
    apriliaforum newb
    Join Date
    Jan 2011
    Location
    san francisco
    Posts
    28
    Quote Originally Posted by motorhead-FL View Post
    I just finished repairing my 99 sr50. Mine has 70cc BBK, leo vince pipe, 20mm carb and all that is with the stock airbox. Surprisingly my jet size is 80 and pilot jet size is 35. needle clip in the middle. The bike runs like a dream.

    I Hope my setup can give you some clues to fix yours. By the way, I would suggest you use a leak down tester to make sure your crank case is sealed right. Mine wasn't and it ran bad just like yours.
    this could be something else we need to look at! thanks for all the imput, going to get a pipe and then try again.

  8. #23
    apriliaforum expert
    Join Date
    May 2008
    Location
    Central California
    Posts
    1,023
    I was thinking reed valve problem........ We didn't have time to get that far but would be the next thing we pull off.

  9. #24
    apriliaforum newb
    Join Date
    Jan 2011
    Location
    san francisco
    Posts
    28
    Quote Originally Posted by KooLaid View Post
    I was thinking reed valve problem........ We didn't have time to get that far but would be the next thing we pull off.
    dave good point...

  10. #25
    apriliaforum newb
    Join Date
    Jan 2011
    Location
    san francisco
    Posts
    28
    Is anyonefamiliar with the leo Vince HM70 pipe? I can get it for 240 bucks
    Part number 4070

    The other exhausts are hard to find...

  11. #26
    apriliaforum newb
    Join Date
    Jan 2011
    Location
    san francisco
    Posts
    28
    bought the leo vince hm70 pipe, got a good deal on it! it will come tues and i will throw it on.

    went from a 95 main to a 101 and nothing changed still sputtery, and jumpy as if there is a miss in the timing or something after tues if no luck with exhaust etc its off to the shop im done with it!

  12. #27
    apriliaforum Member onu123's Avatar
    Join Date
    May 2009
    Location
    Estonia
    Posts
    222
    Okay, there might be a leak somewhere then... Is the plug still only "creamy"?

    And you bought a good exhaust! It's stainless steel & should preform well on your cylinder & all...

  13. #28
    apriliaforum prov-nov
    Join Date
    Sep 2010
    Location
    christchurch, new zealand
    Posts
    58
    compression and leakdown test !

  14. #29
    apriliaforum newb
    Join Date
    Jan 2011
    Location
    san francisco
    Posts
    28
    yea maybe an air leak? im not sure tues i will throw the pipe on a try again.

    also i will throw the 80 jet in just to see what it does? I just feel like no matter what i do it performs the same and feels the same mid range just gone/sputtery/jumpy/ weak....i dont get it

    glad I got a good pipe!! hope it all works out...i want this thing to run bad ass again!!

    whats the procedure of a compression test and leak down test? damn this thing is a pain in the ass!!

  15. #30
    apriliaforum expert
    Join Date
    May 2008
    Location
    Central California
    Posts
    1,023
    check the intake manifold? The airbox pipe looked like it wanted to fall apart. So the intake might be in the same state.

Page 2 of 4 FirstFirst 1234 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •