Results 1 to 8 of 8

Thread: My Piaggio 50 Won't start !

  1. #1
    apriliaforum newb
    Join Date
    May 2010
    Location
    eastlake, mi
    Posts
    2

    My Piaggio 50 Won't start !

    This scooter will not start or even act like it wants to start ever.

    I took a compresion test and it was 150psi

    I checked for spark. It had spark.

    Well since it had both spark and compression, I figured it must be a fuel issue.

    But even when I sprayed starter fluid , It did not even pop or anything.

    I am stuck and don't know what to check now.

    PLEASE HELP

    PS the Piaggio 50 is a 2007 and it is a four stroke. I did also check to see that the valves were moving up and down and the timing chain is not broken.
    Last edited by trafficjamz; 05-08-2010 at 12:49 AM. Reason: added pic

  2. #2
    apriliaforum expert
    Join Date
    Nov 2006
    Location
    Trenton, Michigan
    Posts
    598
    Are you sure you have spark? The reason I ask is if you used starting fluid in it, even if you’re not getting fuel, it should have at least fired for a second. You looked at the spark plug and there is an arc across it? Does the float bowl have fuel in it? I would check the on/off switch, and if it has a kickstand kill switch, oh, and also the safety switch in the levers. You normally have to hold the lever in to get it to start, right. Change the plug for the hell of it. It may be a weak spark from the one you think is good. Check your fuses too. I had one that had bullet style fuse, and it was intermittent. The spring was not pushing hard enough on it, and the ends had corrosion. Just some thoughts.....
    Jeff

  3. #3
    apriliaforum newb
    Join Date
    May 2010
    Location
    eastlake, mi
    Posts
    2
    Quote Originally Posted by jeffc3210 View Post
    Are you sure you have spark? The reason I ask is if you used starting fluid in it, even if you’re not getting fuel, it should have at least fired for a second. You looked at the spark plug and there is an arc across it? Does the float bowl have fuel in it? I would check the on/off switch, and if it has a kickstand kill switch, oh, and also the safety switch in the levers. You normally have to hold the lever in to get it to start, right. Change the plug for the hell of it. It may be a weak spark from the one you think is good. Check your fuses too. I had one that had bullet style fuse, and it was intermittent. The spring was not pushing hard enough on it, and the ends had corrosion. Just some thoughts.....
    Jeff
    It cranks over just fine.
    When the spark plug is out I can SEE the spark arc.
    I have changed the plug also.
    I will look close at all the fuses today.
    What is a kick stand kill switch?

  4. #4
    apriliaforum expert
    Join Date
    Nov 2006
    Location
    Trenton, Michigan
    Posts
    598
    Quote Originally Posted by trafficjamz View Post
    It cranks over just fine.
    When the spark plug is out I can SEE the spark arc.
    I have changed the plug also.
    I will look close at all the fuses today.
    What is a kick stand kill switch?
    Well, I really shouldn't have mentioned a kickstand killswitch for the mopeds. Shiftable bikes won't let you put the bike in gear with the kickstand down. It'll kill the engine if you do. I forgot this morning I was talking about a variable trans bike. If you see spartk, and there is fluid, there should be fire. Let us me know what you find out.......
    Jeff

  5. #5
    Banned
    Join Date
    Oct 2009
    Location
    Baltimore Maryland
    Posts
    317
    bad timing?? thats about all I could think off if its not a fule or spark issue. or maby a wire in the front shook lose from the ignition or something thats also happened to me. third thing id suggest checking would be the reed cage if its a 2 stroke. The bike absolutely will not start with a cracked reed

  6. #6
    Banned
    Join Date
    Oct 2009
    Location
    Baltimore Maryland
    Posts
    317
    oh sorry you mentioned its a 4 stroke

  7. #7
    apriliaforum prov-nov boomin5002's Avatar
    Join Date
    Jun 2009
    Location
    Oregon
    Posts
    34
    Did you get your scooter started? I just bought a 2007 Fly 50 4t (like yours) and it has spark, fuel, and turns good. No start. Any news on yours?

  8. #8
    apriliaforum expert
    Join Date
    Nov 2006
    Location
    Trenton, Michigan
    Posts
    598
    Ha, funny thing is, after I wrote a response about not starting, I picked up a 07 Piaggio 50 cc Fly for the daughter. Well, it had an issue with it starting too. It turns out that the kill switch had come apart and was causing a short. You have to take the front half headlight cover off and then the rear half to get to it. Then you use a screwdriver to push the tabs in to slide the switch out the front after disconnecting the plug to it. Pop the top off, realign everything, put the top back on and use some epoxy to glue the top shut to keep it from coming undone again. Now works great!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •