Results 1 to 9 of 9

Thread: What are the symptoms when your fuel pump is bad?

  1. #1
    apriliaforum expert Switchbak's Avatar
    Join Date
    May 2007
    Posts
    1,053

    What are the symptoms when your fuel pump is bad?

    Hello All (except sprinkles)

    I just got my new bbk installed and it runs like a beast except for the missing/sputtering during acceleration only. I get 56mph and it feels strong and growly. I have a vl12 due to arrive at my house today fed-ex.

    Anyway, I have been smelling gas since I got my scoot back from the dealer and this is something new as my scoot has never had any odors or oil leaks etc. Yesterday while I was tightening the loose exhaust I noticed gas at the bottom of the FUEL PUMP, the hoses were loose with the shit clamps they installed so I got new ones and tightened and wiped away gas and since then when the scoot sits for a while a new drop develops at the bottom of the fuel pump. So, I have no more leaks at the hoses but it appears that I have a leak coming from the canister.

    I see that AF1 sells fuel pumps,
    Are our fuel pumps known to be faulty? I have about 12,700 miles on my pump.
    Also, very importantly, could this leak in my fuel pump be the culprit for my sputtering during acceleration?

    Your devoted fellow sr50 owner,
    Thanks

  2. #2
    apriliaforum expert Dragster pilota's Avatar
    Join Date
    Jul 2003
    Location
    Mosta Hill Sweden
    Posts
    618
    switchbak in da house:
    So, I have no more leaks at the hoses but it appears that I have a leak coming from the canister.


    That's a pretty good (or in your case bad) sign that the pump needs to be replaced, I have seen a couple leaking like you explain and it will never be able to give 100% pressure, if it's still under warranty it's an easy claim for your dealer to do....

    DP says: The pump is a verry important part of the Factory, not 100% OK the scoot will not run 100% either....

  3. #3
    apriliaforum Junkie
    Join Date
    Jun 2008
    Location
    CT, USA
    Posts
    269
    I had one incident where fuel came out of one of the tubes under the footboards, after a short trip, (a hundred yards or so) where I stopped to put something under the seat. I assumed this was some sort of overflow/overprime valve kicking in. Now I am wondering if I should be concerned about my fuel pump too
    2009 SR50 Factory
    Leo Vince ZX
    Polini kevlar belt
    4.8 gram rollers
    Polini blue contra spring

  4. #4
    apriliaforum expert Switchbak's Avatar
    Join Date
    May 2007
    Posts
    1,053
    I'm out of warranty,
    I dont mind the cost as much as I mind not knowing what's causing the sputtering, the sputtering is ONLY during acceleration.

    Should I order a new fuel filter also?

  5. #5
    apriliaforum Junkie blue rocket's Avatar
    Join Date
    Jun 2008
    Location
    CT
    Posts
    320
    Quote Originally Posted by Switchbak View Post
    ...when the scoot sits for a while a new drop develops at the bottom of the fuel pump. So, I have no more leaks at the hoses but it appears that I have a leak coming from the canister.

    Thanks
    exact issue mine had, it was faulty. You need a new fuel pump, no way to fix that, sorry

    Getting a new one did not change any of the sputtering issues my bike exhibits, just doesnt leak and smell of fuel anymore.
    2009 Aprilia SR 50 Factory (PureJet)
    - 2.8.0 Development Mode
    - NGK ZMR7AP Spark Plug (Indexed, Gap ~.65)
    - Aprilia Rear Race Shock
    - Aprilia Factory Side Baffles
    - LED Tail Light / Smoked Lenses
    - Custom Water Trap with Insulated line
    - Carbon Exhaust Canister / Carbon Tag Removal Plate


  6. #6
    apriliaforum Junkie blue rocket's Avatar
    Join Date
    Jun 2008
    Location
    CT
    Posts
    320
    Quote Originally Posted by LKB3rd View Post
    I had one incident where fuel came out of one of the tubes under the footboards, after a short trip, (a hundred yards or so) where I stopped to put something under the seat. I assumed this was some sort of overflow/overprime valve kicking in. Now I am wondering if I should be concerned about my fuel pump too
    look at the pump, if it looks complete dry around the ring in the front part (where the harness plugs in) i would imagine you are fine. If you see any bit of wetness, you're screwed!

    ugh.
    2009 Aprilia SR 50 Factory (PureJet)
    - 2.8.0 Development Mode
    - NGK ZMR7AP Spark Plug (Indexed, Gap ~.65)
    - Aprilia Rear Race Shock
    - Aprilia Factory Side Baffles
    - LED Tail Light / Smoked Lenses
    - Custom Water Trap with Insulated line
    - Carbon Exhaust Canister / Carbon Tag Removal Plate


  7. #7
    apriliaforum Junkie
    Join Date
    Jun 2008
    Location
    CT, USA
    Posts
    269
    Probably worth trying a new spark plug if it hasn't been replaced lately. I have had issues with sputtering, and different spark plugs definitely helped or worsened it. ngk cr7eix, and zmr7ap are the ones that have worked well for me, and I found that the cr7eix indexed with the backside of the ground facing the injector(up and forward) helped with a stubborn sputter I was having, prior to having it solved by an ecu map change and a zmr7ap.
    2009 SR50 Factory
    Leo Vince ZX
    Polini kevlar belt
    4.8 gram rollers
    Polini blue contra spring

  8. #8
    apriliaforum Junkie blue rocket's Avatar
    Join Date
    Jun 2008
    Location
    CT
    Posts
    320
    Quote Originally Posted by LKB3rd View Post
    Probably worth trying a new spark plug if it hasn't been replaced lately. I have had issues with sputtering, and different spark plugs definitely helped or worsened it. ngk cr7eix, and zmr7ap are the ones that have worked well for me, and I found that the cr7eix indexed with the backside of the ground facing the injector(up and forward) helped with a stubborn sputter I was having, prior to having it solved by an ecu map change and a zmr7ap.
    btw Len, they didnt install the condesation kit, they installed the Insulated Compressor line ( i guess that's what aprilia recommended)...who knows if it will fix anything, but i'm running right now without a water trap.
    2009 Aprilia SR 50 Factory (PureJet)
    - 2.8.0 Development Mode
    - NGK ZMR7AP Spark Plug (Indexed, Gap ~.65)
    - Aprilia Rear Race Shock
    - Aprilia Factory Side Baffles
    - LED Tail Light / Smoked Lenses
    - Custom Water Trap with Insulated line
    - Carbon Exhaust Canister / Carbon Tag Removal Plate


  9. #9
    apriliaforum Junkie turbohog's Avatar
    Join Date
    Jul 2008
    Location
    florida
    Posts
    260

    sr50 ditech fuel pump

    i am going thru fuel pump issues right now, it ccould be a great help if anyone had any old bad pumps i may be able to pick a needed part ot two off of....thanks in advance. i have 2 scoots not running at this time because of the need for pumps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •