Results 1 to 8 of 8

Thread: Service code for my 2009 SR.

  1. #1
    apriliaforum newb
    Join Date
    Jul 2008
    Posts
    11

    Cool Service code for my 2009 SR.

    I just bought a 2009 SR50 Factory. After 150 miles it started to miss some after start up, then runs ok after it warms up. I looked everywhere in the manuel and asked the people I bought it from for the service code so I could run a diagnostic test on it but no luck. Could any one give me the service code? Also I upgraded the variator to a molassi, Where can I find 5.5 or 6.0 gram rollers for it? Thanks

  2. #2
    apriliaforum Junkie lau_americanu's Avatar
    Join Date
    Jul 2008
    Location
    Columbus, Ohio
    Posts
    336
    Quote Originally Posted by sensign67 View Post
    I just bought a 2009 SR50 Factory. After 150 miles it started to miss some after start up, then runs ok after it warms up. I looked everywhere in the manuel and asked the people I bought it from for the service code so I could run a diagnostic test on it but no luck. Could any one give me the service code? Also I upgraded the variator to a molassi, Where can I find 5.5 or 6.0 gram rollers for it? Thanks
    I think the service code is 45256..im not sure tho but might as well give it a try
    2009 Aprilia SR50 Factory
    Derestricted ECU
    Leo Vince ZX
    4.8 gram rollers
    red clutch springs
    Malossi Tc Unit
    58mph on flat
    Scooter Tuning Is Not A Crime!!!

    Malaguti F12 Phantom. Ducati Corse Replica
    Malossi 70cc kit
    Dell'Orto 19mm Carb
    Tecnigas RS
    62-65mph

  3. #3
    apriliaforum newb
    Join Date
    Jul 2008
    Posts
    11

    Thumbs up

    Code is correct for the 09 sr50 Thanks!

  4. #4
    apriliaforum prov-nov
    Join Date
    Aug 2017
    Location
    Los Angeles
    Posts
    41
    Hi is there another code? I tried this one and it didn't work. My sr is having a problem down low. If it gets over 5k it runs good for a few min then either Boggs out or won't start again?

  5. #5
    apriliaforum Member KarimK's Avatar
    Join Date
    Apr 2017
    Location
    Calgary, AB
    Posts
    94
    Quote Originally Posted by Lrckmotogp View Post
    Hi is there another code? I tried this one and it didn't work. My sr is having a problem down low. If it gets over 5k it runs good for a few min then either Boggs out or won't start again?
    Only one there is.
    2005 Derbi GPR 50 Nude - SR 50 replacement
    80cc Malossi MHR Replica kit
    21mm Polini CP

  6. #6
    apriliaforum prov-nov
    Join Date
    Aug 2017
    Location
    Los Angeles
    Posts
    41
    Ya it worked!! I must have done it wrong! Now there is a EFI connect that comes up with a light bulb with arrows that alternate every flash?

  7. #7
    apriliaforum prov-nov
    Join Date
    Aug 2017
    Location
    Los Angeles
    Posts
    41
    Quote Originally Posted by KarimK View Post
    Only one there is.

    also changed the fuel system from gas tank to injector! The service code is gone my ECU code went away now it's just DBS x 5 on the memo side?

  8. #8
    apriliaforum Member KarimK's Avatar
    Join Date
    Apr 2017
    Location
    Calgary, AB
    Posts
    94
    Quote Originally Posted by Lrckmotogp View Post
    Ya it worked!! I must have done it wrong! Now there is a EFI connect that comes up with a light bulb with arrows that alternate every flash?
    That means disconnected rear lights I think
    2005 Derbi GPR 50 Nude - SR 50 replacement
    80cc Malossi MHR Replica kit
    21mm Polini CP

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •