Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: NEW SR50.... red circle light is flashing... please help

  1. #1
    apriliaforum Junkie thamil's Avatar
    Join Date
    May 2008
    Location
    Vegas
    Posts
    452

    NEW SR50.... red circle light is flashing... please help

    a red light that's circular with the triangle and "!" in the middle..came on and is flashing after I shut off the bike. they didn't have a manual for the scoot, when they sold it to me. They told me it was a flashing light to let theives know it has an alarm... I did not believe that, so i looked it up online, and it says that means to call an aprilia dealer!?!?! any idea what it could be?

    I thought maybe it could be cuz it needs the oil up front, but the dealer filled that before I left...

  2. #2
    apriliaforum expert deathwest's Avatar
    Join Date
    Feb 2005
    Location
    Switzerland
    Posts
    1,474
    When the engine is shut off it's probably the immobilizer (anti-theft). If it appears when the engine runs then you've a problem
    2001 SR50 Ditech (Morini)
    31'220 km (engine 8070km)
    Top speed : less than 80km/h (belt needs to be replaced)
    7 gr. rollers & stock exhaust
    Castrol TTS (fully synth.)
    I use any type of fuel

  3. #3
    apriliaforum Junkie thamil's Avatar
    Join Date
    May 2008
    Location
    Vegas
    Posts
    452
    so that light blinks as an engine immobilizer?

    I started the engine up and it kept the light on and said, "service" with the little triangle lit up....

  4. #4
    apriliaforum expert deathwest's Avatar
    Join Date
    Feb 2005
    Location
    Switzerland
    Posts
    1,474
    so it's different then, you have to take it to the dealer. I don't know exactly the factory, maybe if it's a fault you can view it on the dash in the diagnostic mode. If you don't know bring it to the dealer.

    But with engine stopped it's just to show that there is a protection. Like on some cars. In fact you can't start the bike without a coded key which is in the key. You can't simply make a copy of the key or connect wires together to start it. You need a code and that's the immobilizer
    2001 SR50 Ditech (Morini)
    31'220 km (engine 8070km)
    Top speed : less than 80km/h (belt needs to be replaced)
    7 gr. rollers & stock exhaust
    Castrol TTS (fully synth.)
    I use any type of fuel

  5. #5
    apriliaforum Junkie thamil's Avatar
    Join Date
    May 2008
    Location
    Vegas
    Posts
    452
    Quote Originally Posted by deathwest View Post
    so it's different then, you have to take it to the dealer. I don't know exactly the factory, maybe if it's a fault you can view it on the dash in the diagnostic mode. If you don't know bring it to the dealer.

    But with engine stopped it's just to show that there is a protection. Like on some cars. In fact you can't start the bike without a coded key which is in the key. You can't simply make a copy of the key or connect wires together to start it. You need a code and that's the immobilizer
    WOW! thanks.... I used the "other" key that came with it, and it started wit no problem, like new. with the "original" key it asks for a password, then starts up.... but it did leave the red light on and say "service"

  6. #6
    apriliaforum expert DonWerner's Avatar
    Join Date
    Apr 2006
    Location
    Denmark
    Posts
    902
    If the word SERVICE pops up when the bike is running, it's off to the dealership. The blinking red light when the bike is off, is the anti-theft protection, which you shouldn't worry about.
    2006 Orange Aprilia SR 50 Factory
    Piaggio PureJet Engine (50cc)
    Fully De-restricted
    Ariete grips
    Custom paint-job (mirrors)
    Stock variator w/ 4.5 grams Giannelli rollers
    Giannelli Reverse pipe
    Cubrix Alarm - Model NCG420
    NGK CPR8E Sparkplug
    Top-speed 80 km/h - 50 mph @ 9k RPM
    Topspeed Video ~ Bikeride Video ~ Alarm Video ~ My DVD Movies ~ E-Mail Me (Form Mail)

  7. #7
    apriliaforum Junkie thamil's Avatar
    Join Date
    May 2008
    Location
    Vegas
    Posts
    452
    Quote Originally Posted by DonWerner View Post
    If the word SERVICE pops up when the bike is running, it's off to the dealership. The blinking red light when the bike is off, is the anti-theft protection, which you shouldn't worry about.
    thank you!

  8. #8
    Quote Originally Posted by DonWerner View Post
    If the word SERVICE pops up when the bike is running, it's off to the dealership. The blinking red light when the bike is off, is the anti-theft protection, which you shouldn't worry about.
    My 2006 does that (new to me yesterday). Only flashes every 3 seconds when the key is off. I'll assume it is an anti theft device.
    2014 California 1400 Touring ABS in White
    Eldorado w/Automatic Trans circa 1972 in Black
    Looking for California 1400 only discussions:
    guzzicalifornia.forumcircle.com

  9. #9
    Aprilia Forum Moderator High Gain Tuning's Avatar
    Join Date
    Jun 2008
    Location
    Parker Colorado
    Posts
    12,984
    Yes, that is the anti-theft.

  10. #10
    apriliaforum expert DJ GT-S's Avatar
    Join Date
    May 2008
    Location
    Quebec City, Canada
    Posts
    1,109
    Oh shit my WR250X was stolen!
    Former owner of a 2006 R Factory Morini Ditech
    Designated mechanic for a purdy '11 Alitalia rep

  11. #11
    Quote Originally Posted by DJ GT-S View Post
    Thanks for the sentiment, but there is no mention of the general alarm light flashing while the key is off to indicate that the anti-theft system is in operation, made in that manual.


    2014 California 1400 Touring ABS in White
    Eldorado w/Automatic Trans circa 1972 in Black
    Looking for California 1400 only discussions:
    guzzicalifornia.forumcircle.com

  12. #12
    apriliaforum expert TiminIndy's Avatar
    Join Date
    Oct 2003
    Location
    Indianapolis, IN USA
    Posts
    10,009
    Two different things. The small red light that flashes when it is off indicates the immobilizer is armed. The service triangle with eh '!' indicates service is needed. You should run the diagnostic check and see what error codes are there.

    Is this brand new or just new to you? If not, how many miles on it?

    BTW, both keys that came with it should have the electronic chip in them to disarm the immobilizer.

  13. #13
    Aprilia Forum Moderator High Gain Tuning's Avatar
    Join Date
    Jun 2008
    Location
    Parker Colorado
    Posts
    12,984
    Quote Originally Posted by TiminIndy View Post
    Two different things. The small red light that flashes when it is off indicates the immobilizer is armed. The service triangle with eh '!' indicates service is needed.
    This is the same exact light on 2004 and newer.

  14. #14
    apriliaforum expert TiminIndy's Avatar
    Join Date
    Oct 2003
    Location
    Indianapolis, IN USA
    Posts
    10,009

    Exclamation

    Quote Originally Posted by High-Gain SR50 View Post
    This is the same exact light on 2004 and newer.
    I thought he was talking about the bigger triangle around the '!' that appears on the LED screen (I saw it when my fuel pump crapped out).

  15. #15
    apriliaforum expert DJ GT-S's Avatar
    Join Date
    May 2008
    Location
    Quebec City, Canada
    Posts
    1,109
    Quote Originally Posted by mtiberio View Post
    Thanks for the sentiment, but there is no mention of the general alarm light flashing while the key is off to indicate that the anti-theft system is in operation, made in that manual.


    I didn't link you to the manual so you'd look up what it meant, that had already been explained, I linked you because you said you didn't have it and it's full of handy information.

    But to avoid any confusion, the triangle "!" led in the tachometer is a general warning lamp, like the triangle "!" light in volvos (and hmm, doesn't mercedes also use it?), it lights up to get your attention about something, which will usually be detailed on the multifunction display.

    If the bike is on and the ! is lit up, that means there's something wrong somewhere. If the bike is off and it's flashing, it's the immobilizer, again, kind of like the flashing LEDs used in cars.
    Oh shit my WR250X was stolen!
    Former owner of a 2006 R Factory Morini Ditech
    Designated mechanic for a purdy '11 Alitalia rep

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •