Page 1 of 13 12311 ... LastLast
Results 1 to 15 of 195

Thread: Futura and Caponord dash repair

  1. #1
    apriliaforum expert meanstrk's Avatar
    Join Date
    Sep 2004
    Location
    Carthage, NC
    Posts
    4,634

    Futura and Caponord dash repair

    So....... Most of us know about the issues that some have had with their instrument cluster going dead. Some have had it happen while riding while others have had it happen after changing the battery, pulling the dash, etc...... My cluster recently took a crap on me after pulling it just to do a headlight bulb change. I pulled the connectors, changed the bulb, and the dash never came back on after I plugged it back in with the exception of the oil pressure, kickstand, and neutral lights. Every other function, including the backlights, were dead as hell. No speedo, no tach, no readouts at all. Incidentally, my dash was replaced under warranty while the original owner had it.........

    Anyways, since I head up a rather large electronics repair facility and have dealt with electronics for over 20 years, I figured that I would be better off taking a look to see if I could figure out WTF was wrong. I mean, what's the worse that could happen? I guess I could screw up something that was already broke....... Screw it, I'm going in!

    Before I go any further, I have to add an additional thanks to CapoGrandad, another Aprilia owner with the knowledge to check it out, and Joe, a guy that works for me. Without these two guy's assistance, I would not have gotten this solved as fast as I did!

    Here we go!

    Pulling the dash itself is easy: Remove the fluse cover, dash side panels, you know, those ones that fill in the space around the fairings and dash, and two bolts hold the cluster in place. Once those bolts are removed, it is easiest to move the panel to the right for access to the two connectors on the back. Remove those connectors and pull the dash out.

    Pulling the dash apart is not too bad either...... There are retainer tabs around the perimeter of the housing that you can easily unclip and pull the two housing halves apart. From there, it gets a bit more difficult. I found that I could NOT get the speedo and tach needles off the drive pins. I pulled them about as hard as I dared, but they would not come off, so I ended up using an exacto knife to carefully cut them off. This is required in order to gain access to the actual circuit board. A couple other guys have said they had no problems pulling the needles off, but mine were stuck on there good! Once you either pry the needles off, or cut them off, you can carefully pull the retainer tabs away from the board housing to release the circuit board and get to the goodies!

    Here is a pic of the whole circuit board. I never took any pics of the board before doing any repairs, so try to ignore those wires up towards the top right now. We'll get to those soon enough......



    Next we have a couple pics of the connector pin out diagrams.......

    Wiring harness side.........



    Cluster side.........



    I should note that once you have the circuit board out and if you have access to a multimeter, you can hook it back up to the bike for some additional tests. I used a power supply for my tests, but you CAN do it on the bike with the key on. The biggest thing you need to look for is applied voltage to a couple different places. With the multimeter connected to ground, you can check to ensure that you are getting voltage to the board by checking the 12V+ locations on the connector, then check at the bottom side of the zener diode where you should see 12V, and finally, on pin 19 on the IC chip. At all locations you should see 12VDC. If you have 12VDC at the Zener Diode, but not at the IC chip, then the fault is more than likely a bad solder connection under the large capacitor. You can check this as well by check for voltage on the back side of the board where the capacitor is soldered on. Check from ground to the bottom solder joint for the capacitor and you should see 12vdc. (It goes without saying that these tests need to be done with the key ON!)What is happening is that the top side of the feed through does not have any solder on the feed paths on the top of the board. This is causing the capacitor to loose the connection to the output of the Zener Diode so the IC chip that is the voltage regulator is not receiving any power.

    In this pic, it shows the Capaciter (marked) and Zener Diode. (To the right of the capacitor.) The Zener Diode test point is the lower solder joint on the diode.



    This next pic shows the back side of the board where the capacitor is soldered. The lower solder joint is your test point.




    Once you determine that this is your problem, there are three ways to fix it, one which works, but bypasses the capacitor (Not recommended), one does not require removal of the capacitor, and one that is the technically "correct" way to fix it.

    1: You can run bypass wires from the Zener Diode to Pin 19 on the IC chip.

    This pic shows the wires going from the Zener Diode to both the IC chip, Pin 19, and the capacitor. I took the cap out for this pic to show things a bit more clear:




    2: You can run a feed wire from the Zener Diode to the back side of the board to the lower solder point of the capacitor. This eliminates the need to pull the capacitor and works just as well. THIS IS THE METHOD I USE WHEN I REPAIR THESE DASHES.



    This one shows the Zener Diode soldering point:



    And the back side soldering point for the wire:



    3: You can pull the capacitor (being careful to note which pin is in which hole) apply solder to the mounting pad, and then replace the capacitor and then check your voltages again. I did this the first time I repaired mine, and it quit again a few thousand miles down the road.... This is when I went back to solution #2

    This pic shows the clean mounting pads on the upper side of the board which is the cause of this problem to begin with. To fix, use a soldering iron to apply solder to these pads before reinstalling the capacitor:



    Here is a microscope view of the capacitor mounting pads. You can easily see that there is NO solder to make a connection:



    This is a pic of the micro miniture soldering station I used for these repairs, but you can do it with a low heat soldering iron without too much trouble.



    I checked all three methods and they ALL work, but the easiest and fastest is #2.

    Once you are getting lights on the board again, you can put everything back together and keep on rocking! For those that have to cut their needles off, I used JB Kwik Weld after making sure I had everything oriented right and it works with no problems!

    DISCLAIMER! This may NOT fix your cluster. You may have other issues or you may screw it up worse! If you want, you can send them to me and I can fix it, or, armed with this thread and pics, get someone else to fix it, but play at your own risk here!
    Last edited by meanstrk; 06-21-2008 at 09:58 AM.
    Ron
    MSgt USMC (Retired!)
    Semper Fi!
    A group #45
    IBA #38812

    RST Futura
    Colin Edwards RSV R Mille #066 (Sold now. Sigh...)
    2007.5 Tuono

    For custom paint work, check out http://www.trading-paint.com

  2. #2
    apriliaforum expert bobdavis73's Avatar
    Join Date
    Jul 2003
    Location
    Noblesville, IN
    Posts
    3,985

    Awesome Post

    I sure hope I never need this but I am thrilled to have this information if I ever do.

    Sooo Cool. Great Job

    Bob


    "Although all men are born free, slavery has been the general lot of the human race. Ignorant - they have been cheated; asleep - they have been surprised; divided - the yoke has been forced upon them. But what is the lesson? ...the people ought to be enlightened, to be awakened, to be united, that after establishing a govenment they should watch over it.... It is universally admitted that a well-instructed people alone can be permanently free."
    --James Madison

  3. #3
    apriliaforum expert Fox Fader's Avatar
    Join Date
    Jun 2006
    Location
    Columbus, GA
    Posts
    3,646
    Glad to see this fix. If it happens to me at least now I'll know where to start.

    A few years ago I had to do something similar, I needed to make a 2001 Explorer cluster fit in a 1998 Explorer. Hours later I got it figured out, I definatly didn't want to try to crack into this high dollar cluster not inculcated. Thanks Ron!!
    __________________
    ____@FoxFader_____
    Current Swag 1 - '01 Futura in Silver, Acumen DGVáPainted W-screenáPazzo Knock-offs.
    Current Swag 2
    Jesus, family, me. Psalm 121 - Red Pill Mille Clip - Delkevic Sound Clip

    Past Swags: 10 R6 Raven, 09 RSV 1000R, 06 GSXR 1000 SF, 02 Bandit 1200 N, 03 RSV 1000, 05 Katana 600, 98 VLX 600, 00 GSXR 750, 01 Futura 1000, 02 Bandit 1200S, 83 V65 Magna, 91 Nighthawk 750, 9? 700 Honda, 93 GSXR 750wp, 91 Katana 600, 78 KZ400, 82 CB450 Custom
    HF152, 10-26954
    HF564,

    __________________
    __________________

  4. #4
    apriliaforum Member BillyFutura's Avatar
    Join Date
    Jul 2005
    Location
    Ventura County, So. Calif.
    Posts
    164
    Thanks Ron for getting this in before you go into surgery! My prayers will be with you buddy!
    Question, after you put solder on the pads, the assumption is that when you resolder the cap in from the other side, the solder will flow on topside making proper connection to the cap wire,,yes? Hey, this really looks like a manufacturing defect problem ya think? Recall material!

    Great writeup! Thanks so much for the detail. I will tear into mine tomorrow and see what happens!
    Last edited by BillyFutura; 12-07-2006 at 10:10 PM.
    2001 Stream Silver Futura (sold)
    2002 Ash Black Futura
    Heli-bars, AF1 fuel qd fix, Throttlemeister, c/f hugger, Famsa 246 tank bag, Evoluzione air filter, Wilber full tilt shock(-1"), Falco forks modified by Lindemann Engineering, Taylormade exhaust, John's rectifier, R&G frame sliders, Scottoiler w/dual injector, Odyssey 545 drycell battery, Stebel Nautilus Compact Dual-Tone airhorn, HID headlamps, , Garmin Zumo GPS, Passport radar detector, Doran tire pressure monitor, Pazzo levers, heated grips.

  5. #5
    apriliaforum expert The Fixer's Avatar
    Join Date
    Apr 2005
    Location
    Chicago. Don't get me started...
    Posts
    2,188

    Thumbs up

    Quote Originally Posted by bobdavis73
    I sure hope I never need this but I am thrilled to have this information if I ever do.

    Sooo Cool. Great Job

    Bob
    Yeah, I actually backed up a copy of it ...thanks Ron.
    ďThe roadís what counts...donít worry about where itís goiní."
    - Sam Shepard
    "When I'm riding my motorcycle, I'm glad to be alive. When I stop riding my motorcycle, I'm glad to be alive."
    -Neil Peart
    __________________________________________

  6. #6
    apriliaforum expert EditTim's Avatar
    Join Date
    Jan 2004
    Location
    Atlanta, GA
    Posts
    1,219
    Ron, nice work! It goes without saying that people like yourself and plenty others make this the best forum on the web!
    Now someone needs to give this thread a STICKY!
    Tim

    '07 Tuono Factory

    Leo Vince cans, 15/42, CF bits, Rizoma bars, bar ends, & mirrors, Austin Racing rear sets w/ GP shift, Factory Pro Evo shift star kit, radial clutch/brake, CRG levers, Evotech hangers, Powerbronze, billet sidestand, 6k HID, AF1 link plates, lightened flywheel, ÷hlins TTX, BSTs, Bazzaz Fi-TC

    '04 Futura in Gloss Black
    Factory Pro shift kit, 15/43, GP shift, CRG's, Evo clutch slave, Bef semi-full (ceramic coated), Wilbers shock, 6k HID, Mille fork lowers DLC coated w/ ÷hlins and 4-pad calipers, radial clutch/brake, lightened flywheel

    '03 Mille R Colin Edwards Rep #84
    Track bitch... Motobits rearsets. Sharkskinz & Non-CE tank in Aprilia "Red" (street plastic safely stored), Engine & suspension work.

  7. #7
    apriliaforum expert Befbever's Avatar
    Join Date
    Sep 2003
    Location
    Belgium, home of Euro trash.
    Posts
    9,329

    Thumbs up always knew it would be the flux capacitor...

    since I head up a rather large electronics repair facility and have dealt with electronics for over 20 years,
    Now you tell us.... coupled with the laconic nature of a true Marine, this explains a few replies you made in the past.

    Awesome work, Ron.
    Even an electronics dumbass like me should be able to fix it thanks to this thread. Hope I never need to though.

    Now someone needs to give this thread a STICKY!


    Get well soon.
    This Must Be The Place
    _____________________________________________
    - Futura '03 - shelved what's not sold.

    - 2010 Honda VFR1200F. Remus Ti can, Bazzaz Z-Bomb restriction eliminator.

  8. #8
    apriliaforum expert RobC's Avatar
    Join Date
    Jul 2003
    Location
    Brum
    Posts
    4,780
    Quote Originally Posted by Bikeaholic
    Very helpful thread and I donít want to clutter it up but just an observation if I may.

    It looks like the Capacitor simply connects across the Diode so re-soldering the Capacitor on its own would still not have restored the Voltage at the regulator. It looks like you may have had a bad connection between the Diode and the board as well.
    unless the capacitor lead provides the connection between top and bottom of the board - a lack of or faulty through-hole plating?

  9. #9
    apriliaforum expert
    Join Date
    Jan 2006
    Location
    Leicester, UK
    Posts
    742
    The track from the diode to the regulator passes through the board at the capactor connection. If the through-plated hole is good, no problem. If the plating is poor or cracked, the then when the board is first soldered the solder does not run up through the hole to make a good joint on both sides of the board, and the through plating is the only connection. If there is a crack in the plating, it may make so-so contact for a while, but eventually it will fail and then the dashboard 'dies'.
    A statesman is a dead politician. Thats what we need, more statesmen.

  10. #10
    apriliaforum expert meanstrk's Avatar
    Join Date
    Sep 2004
    Location
    Carthage, NC
    Posts
    4,634
    Too much info
    Last edited by meanstrk; 12-31-2006 at 08:36 AM.
    Ron
    MSgt USMC (Retired!)
    Semper Fi!
    A group #45
    IBA #38812

    RST Futura
    Colin Edwards RSV R Mille #066 (Sold now. Sigh...)
    2007.5 Tuono

    For custom paint work, check out http://www.trading-paint.com

  11. #11
    apriliaforum expert Powerful Pierre's Avatar
    Join Date
    Jul 2003
    Location
    Nottingham, UK
    Posts
    4,442
    Ron, you're a great asset to this forum...

    This DOES need turning into a sticky so maybe any discussion should be on another thread just to keep this one simple.

  12. #12
    apriliaforum expert RPB's Avatar
    Join Date
    Apr 2004
    Location
    Netherlands aka Holland
    Posts
    1,030

    Ron, great job!! Thanks for the write-up.
    Rob - '01 Rosso Flame

    "Riders Create More Problems Than Motorcycles Are Designed To Handle" - Keith Code

  13. #13
    apriliaforum Member oafyuf's Avatar
    Join Date
    Feb 2006
    Location
    London
    Posts
    112

    Bump!

    POST OF THE YEAR! Microscope view? Man...
    De-restricted airbox, 05 fuel map, de-brown connectored, de-sidestand switched, de-plastic fuel QD'd, double-bubble windscreen, Bagster tank bag, AF-1 H-pipe.

    +++++++++++++++++++++++++++
    Did you know that it's unlucky to be superstitious?

  14. #14
    apriliaforum Junkie FuturaJoe's Avatar
    Join Date
    Mar 2006
    Location
    Boston, MA
    Posts
    306
    Very Nice!
    Current:
    '04 Aprilia RST Futura

    Past:
    '03 ST4s ABS
    '02 R1150RT
    '02 Ducati ST2
    '04 BMW Rockster

  15. #15
    apriliaforum expert Bikeaholic's Avatar
    Join Date
    Jul 2003
    Location
    Scot & Switzerland (Scoterland)
    Posts
    1,180
    Ron .........Would you agree that the smaller pad next to the Capacitor could be used to repair any broken or unsound trough plating? Iím thinking that a pin soldered on both sides would make the connection more secure.

Page 1 of 13 12311 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •